Virtualbox update - all VMs crash -> conflict with Ext. Pack

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby morgano » Aug 1st, '16, 14:17

Still same strange refuse of the GUI to install extpack:
New install of Virtualbox on Cauldron (mga6)
Same problem and resultion as in my post above.
Actually it is the same system, but i uninstalled virtualbox, upgraded mga5 to cauldron three monts ago or so, and first now want to use virtualbox again so installed it,

...and by using virtualbox GUI menu Archive > Look for updates , had it look for and install correct extpack, but failed with:
Spoiler:
Failed to run /usr/lib64/virtualbox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-68n595/stdout --stderr /tmp/VBoxExtPackHelper-68n595/stderr --elevated install --base-dir /usr/lib64/virtualbox/ExtensionPacks --cert-dir /usr/lib64/virtualbox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /home/morgan/.config/VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-5.1.2.vbox-extpack --sha-256 394d933be4022b2b15225670fe6e2a4486f34e5a565a719e0de5984089ccd975 --replace.


Failed to execute child process "/usr/lib64/virtualbox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-68n595/stdout --stderr /tmp/VBoxExtPackHelper-68n595/stderr --elevated install --base-dir /usr/lib64/virtualbox/ExtensionPacks --cert-dir /usr/lib64/virtualbox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /home/morgan/.config/VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-5.1.2.vbox-extpack --sha-256 394d933be4022b2b15225670fe6e2a4486f34e5a565a719e0de5984089ccd975 --replace" (No such file or directory)

Misslyckades med att installera tilläggspaketet /home/morgan/.config/VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-5.1.2.vbox-extpack.

The installer failed with exit code 1: .

Resultatkod: NS_ERROR_FAILURE (0x80004005)
Komponent: ExtPackManagerWrap
Gränssnitt: IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}

All paths it listed existed except /usr/lib64/virtualbox/ExtPackCertificates, so i created it but that did not help.
Then I just did as described before
Spoiler:
# VBoxManage extpack uninstall 'Oracle VM VirtualBox Extension Pack'
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully uninstalled "Oracle VM VirtualBox Extension Pack".
[root@svarten morgan]# VBoxManage extpack install /home/morgan/.config/VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-5.1.2.vbox-extpack
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "Oracle VM VirtualBox Extension Pack".
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 589
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby ozky » Nov 24th, '16, 14:24

I have made some test problem is gksu-polkit,every time i install it extpack fails to install with gui but without it or remove it no any errors.
Kdesu works in Cauldron or Mga5 no any errors installing extpack,beesu also works but gksu-polkit seems to break this polkit auth virtualbox use to install extpack.
Image
Just leave me alone i know what i'm drinking.
User avatar
ozky
 
Posts: 569
Joined: Jul 2nd, '11, 08:48
Location: Ulvila Finland

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby zeebra » Jan 10th, '18, 17:32

viking60 wrote:No worries :D It might still help others.
Just to clarify; the thing that worked was keeping the .vdi and delete the VM in Virtualbox and then recreate it - as in generating a new - and point it to the existing .vdi. The -vdi's were fine all the time in my case too.

(The backup stuff was only to prevent that the VB control panel should not completely erase the virtual disk during deletion so that I had an existing disk to point to.)


Some virtual images carry settings that might be incompatible with the new version of the software, if you carry it over to another computer or another installation. To reduce this problem, you have to reduce the settings in your CURRENT Virtualbox installation, then re-import the Virtual OS and start it once again. Once it has been started for the first time, you can now change the settings again to your preferred settings, without creating any settings conflicts in the Virtual OS image and the Virtualbox installation.
zeebra
 
Posts: 120
Joined: Sep 7th, '13, 21:20

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby morgano » Jan 12th, '18, 20:10

zeebra wrote:Some virtual images carry settings that might be incompatible with the new version of the software, if you carry it over to another computer or another installation. To reduce this problem, you have to reduce the settings in your CURRENT Virtualbox installation, then re-import the Virtual OS and start it once again. Once it has been started for the first time, you can now change the settings again to your preferred settings, without creating any settings conflicts in the Virtual OS image and the Virtualbox installation.

Is there a quick guide to what is the most compatible settings, and maybe a shortcut to clear them all?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 589
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby doktor5000 » Jan 13th, '18, 08:35

No there's not, as this is not necessary at all. The whole point of virtualisation is to abstract the physical host hardware.
Apart from that, exporting VMs is only necessary if you move them from one hypervisor to a different one. And this is not the recommended way to move a virtualbox VM from one virtualbox host to another.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15165
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby zeebra » Jan 19th, '18, 15:00

morgano wrote:
zeebra wrote:Some virtual images carry settings that might be incompatible with the new version of the software, if you carry it over to another computer or another installation. To reduce this problem, you have to reduce the settings in your CURRENT Virtualbox installation, then re-import the Virtual OS and start it once again. Once it has been started for the first time, you can now change the settings again to your preferred settings, without creating any settings conflicts in the Virtual OS image and the Virtualbox installation.

Is there a quick guide to what is the most compatible settings, and maybe a shortcut to clear them all?


No, but as far as I remember, it is the settings under "system" that enables various motherboard, processor and acceleration features. The tickboxes. I don't remember which ones exactly, but 1 or 2 of those can make the "old image" unbootable in a new Virtualbox installation, without it giving the exact reason.
zeebra
 
Posts: 120
Joined: Sep 7th, '13, 21:20

Re: Virtualbox update - all VMs crash -> conflict with Ext.

Postby doktor5000 » Jan 19th, '18, 18:50

zeebra wrote:The tickboxes. I don't remember which ones exactly, but 1 or 2 of those can make the "old image" unbootable in a new Virtualbox installation, without it giving the exact reason.

That's if you change those after the initial installation for windows VMs, not when transferring VMs between different installations/hosts.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15165
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Previous

Return to Basic support

Who is online

Users browsing this forum: No registered users and 0 guests

cron