Observations on Mageia 7

This forum is for general chat between members about Mageia.

Technical questions are supposed to be posted in support forums. Not here !

Observations on Mageia 7

Postby jiml8 » Dec 23rd, '19, 22:18

Getting to Mageia 7 from Mageia 6 was horrid, but now that the deed is done the result is generally pretty nice. I have a few comments.

The biggest positive I see is that there have been a LOT of memory leaks fixed in KDE in M7. That is a huge improvement which should have a major impact on stability for systems that are up for a long time. So far, I won't commit myself on that; mine has been up and down a fair amount as I deal with this issue and that issue, At the present time, it has been up for about 3 1/2 days and I don't see any leakage from the major KDE components (kwin_x11, plasmadesktop). I have seen some leakage in chromium. There may have been some leakage in firefox; not sure. And the fact that I am not sure actually is a substantial improvement. There was also a race condition in the desktop effects when entering expo mode. So far, since the upgrade, that really very annoying problem has not bitten me; maybe it is fixed. I can hope so anyway.

I also had some intermittent issues regarding some of the features of plasma. I won't enumerate them because they seem to be gone now. I have this idea that there was some configuration things in M6 that are changed in M7 and they caused occasional problems until, in the normal course of things, KDE/Plasma rewrote those files, likely during a logout or reboot.

The biggest negative I see are the browsers. Both firefox and chromium are Pissing. Me. Off. Both browsers are incorporating more and more user security, and they are doing it their way. Well, their security changes are colliding with MY security protocols in a big way and, as I study how they are doing it, I want to disable that and continue to do it my way because my way suits my purposes better than their way does. But I can't disable their protocols totally, and I therefore have some non-functioning capability that I have not totally figured out. I am having similar problems on all my virtual machines. Similar, but not identical. Some functions won't work in M7 but will work in OpenSUSE Leap 15.1 or Mint 18. So, for now, when I hit a problem in one environment, I try it in another environment. If it works there, I keep on going. Ugly, but for now workable.

Maybe I will give Opera a try...

Changes in the network-scripts are biting me. VLANs are no longer being handled correctly. A route is being written that effectively disables the vlan. I have a pretty good idea what is going on there but I have not yet decided on the best way to handle it. I am inclined to say that the change in scripting has improperly broken VLANs but it could be that my VLANs on this box are not properly configured and the misconfiguration was tolerated by earlier versions of Mageia but is no longer tolerated. In any event, I restore the vlan by just removing the route.

The documentation on this subject seems to be very distro-dependent and some of it is contradictory. I've been following the Redhat model since that is the ancestor of Mageia, but maybe I need to reconsider that. I have found no documentation at all on this subject for Mageia.

Given that testing this will involve at least several reboots, I have given it a low priority to sort out. When (eventually) I do that, I likely will write some documentation.

On bootup, the boot process hangs for about a minute as the system "waits for hotplugged networks to start". This entire workstation is configured with static networking. I don't use network-manager here, and I have removed all interfaces from ifplugd. The way I use the system, any of that automated networking really gets in the way. So, I would love to kill that hotplugged networking thing, but I have not figured out how. I've rooted around in /lib/systemd but don't have it figured out.

Again, it is a bootup thing so gets a low priority.

Also, on bootup, sddm won't start. I keep getting kicked into some other desktop manager (lxde?). I have to move to a console, log in as root, and start sddm. I used MCC to enable sddm on startup, but it doesn't seem to work. Every time I check on it, sddm has been disabled again. In fact, I can go into the system services section on MCC, check the "on boot" box for sddm, select OK, and leave that section. Go back into it and look, and "on boot" for sddm is unchecked.

I have not yet dug into that. Where does MCC save its config information for system services?

So, that's where I'm at. I expect the reduction in memory leaks will make the system a lot more stable. At least, I hope it will. Other than the browser issues (which are multiple and not fully understood at this time) the other issues are (mostly) minor annoyances.
jiml8
 
Posts: 1071
Joined: Jul 7th, '13, 18:09

Re: Observations on Mageia 7

Postby jiml8 » Jan 5th, '20, 22:51

I believe I have the problem of sddm not being set to start on boot solved.

In MCC on the services control page, I found that xdm was enabled on boot. I turned off xdm, then exited the service manager, then re-entered the service manager, then set sddm to start at boot, then exited the service manager again.

When I re-entered the service manager, sddm was listed as starting at boot.

I will note that if I turned off xdm, then turned on sddm, then exited the service manager, it did not work. xdm was turned off, but sddm was not turned on. I had to do it one at a time for it to work.

I have not rebooted to confirm this. But the fact that it shows as set to start on boot is encouraging.
jiml8
 
Posts: 1071
Joined: Jul 7th, '13, 18:09

Re: Observations on Mageia 7

Postby jiml8 » Jan 5th, '20, 23:31

I was gone for a week and, as usual, I left my workstation running and logged in with one VM running, and the display locked.

I do this because I often access the workstation remotely, I need the email client running to receive and process my email, then forward some of it to my phone, and sometimes I need that VM as well.

I am back now, and sunday is usually system maintenance day. So, today while doing maintenance I noticed that dbus was running away, showing memory usage of about 1.4 GB. I have seen this problem intermittently in Mageia 6. It does not happen all the time or even most of the time, and it invariably leads to a crash if I don't restart the desktop.

Well, I had a bunch of updates pending, so I went ahead and did them. I tried to log out of KDE and the logout utility refused to start - probably related to the dbus problem. So I just rebooted.

So there is at least one intermittent KDE problem that is not fixed. Dbus is still running away, at least occasionally. Why? I don't know.
jiml8
 
Posts: 1071
Joined: Jul 7th, '13, 18:09

Re: Observations on Mageia 7

Postby martinw » Jan 6th, '20, 22:39

Normally the active display manager is selected via the /etc/systemd/system/display-manager.service soft link. drakdm should create that link, but that might have got missed during your difficult upgrade.
martinw
 
Posts: 548
Joined: May 14th, '11, 10:59

Re: Observations on Mageia 7

Postby jiml8 » Jan 16th, '20, 19:40

It has now been more than a month since I made this upgrade.

Now, for a very long time, there has been a bug in KDE that would bite me periodically. I described it here:
viewtopic.php?f=7&t=12629&p=74140&hilit=expo+mode

Since the update, this problem has not occurred even once. I hesitate to say it is gone, but I have not seen it at all.

This is a good thing.
jiml8
 
Posts: 1071
Joined: Jul 7th, '13, 18:09


Return to General discussions about Mageia

Who is online

Users browsing this forum: No registered users and 0 guests

cron