[SOLVED] Intel video card problem after upgrade from MGA6

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] Intel video card problem after upgrade from MGA6

Postby hman » Aug 12th, '19, 08:41

Hi all,
yesterday i upgrade my laptop from Mageia 6 to Mageia 7.1 but i have a problem with Intel video driver:
i have an hybrid graphics so i have an Haswell Integrated Graphics Controller (8086:0416) and an Nvidia card. After upgrade i tryed also to remove xorg.conf file and launch XFdrake to renew, but after boot i receive always the same warning message if i try to use Intel driver:
[Problem with video driver]
A kernel module, display driver, has been detected that conflicts with the driver that the X server is configured to use. Starting the X server may therefore fail (italian original message in attach image)

if i use nouveau driver i haven't this message but cinnamon crash, i tryed also to use mageia-prime to switch completely to Nvidia card from boot but server X seems doesn't start, i see only boot message without graphic window, i also tryed to use bumblebee to start cinnamon session editing /usr/share/xsession/cinnamon.desktop to run a script with
Code: Select all
/usr/bin/primusrun /usr/bin/cinnamon
but doesn't start.
Attachments
intel-error.jpg
intel-error.jpg (129.42 KiB) Viewed 66 times
Last edited by hman on Aug 12th, '19, 19:52, edited 1 time in total.
Blog: http://www.integrazioneweb.com/

Some projects:
- Monosim github.com/armando-basile/monosim/
- Comex-Project github.com/armando-basile/comex-project
- Sagent github.com/armando-basile/sagent
hman
 
Posts: 28
Joined: Feb 20th, '12, 11:56

Re: Intel video card problem after upgrade from MGA6

Postby ITA84 » Aug 12th, '19, 09:27

Have you had a look at the Mageia 7 Errata? If none of that helps you, and if you have installed the NVidia proprietaty drivers, you might want to try blacklisting nouveau (add a text file in /etc/modprobe.d with just "blacklist nouveau" and reboot)
ITA84
 
Posts: 195
Joined: Mar 5th, '13, 18:15

Re: Intel video card problem after upgrade from MGA6

Postby hman » Aug 12th, '19, 09:37

Hi ITA84,
blacklist nouveau

already done without success, seems that nouveau driver start however. I'm reading mageia-prime guide and could try to use this option to exclude nouveau:
https://github.com/ghibo/mageia-prime#o ... mmand-line
Blog: http://www.integrazioneweb.com/

Some projects:
- Monosim github.com/armando-basile/monosim/
- Comex-Project github.com/armando-basile/comex-project
- Sagent github.com/armando-basile/sagent
hman
 
Posts: 28
Joined: Feb 20th, '12, 11:56

[SOLVED] Intel video card problem after upgrade from MGA6

Postby hman » Aug 12th, '19, 19:52

Fix it removing xorg.conf and launch
Code: Select all
/usr/sbin/mageia-prime-install -g -b


work fine :D
Blog: http://www.integrazioneweb.com/

Some projects:
- Monosim github.com/armando-basile/monosim/
- Comex-Project github.com/armando-basile/comex-project
- Sagent github.com/armando-basile/sagent
hman
 
Posts: 28
Joined: Feb 20th, '12, 11:56


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron