[SOLVED]Mouse cursor jumps ramdomly

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED]Mouse cursor jumps ramdomly

Postby mackowiakp » Apr 11th, '19, 16:42

It is very strange, because I use this computer for 2 years. Yesterday mouse cursor (KDE) start to jumps randomly or to the upper left corner. Of course I try two other USB mouses and wireless mouse. Still the same result. So I check/change USB ports both ver 2 and 3. No changes. It is extremely strange for me. Maybe somebody had the same problem?

EDIT1

Maybe the problem is touch screen (kind of hardware failure). This in AIO PC, I dont need touch screen at all. So how can I turn off totally this feture in X config files? Just for test at the beginning. It is not possible tu disable touch screen from BIOS level.
Last edited by mackowiakp on Apr 13th, '19, 10:31, edited 1 time in total.
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 542
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Mouse cursor jumps ramdomly

Postby ITA84 » Apr 12th, '19, 20:08

Doesn't the touch pad have a button or a marked area that you can tap twice to disable it?

In any case, if it's managed with the Synaptics driver, adding
Code: Select all
Option "Ignore" "on"

in its section should disable it completely. If there's no such section in your xorg.conf file (or there's no file at all), you may create a section for it (or in a xorg.conf.d snippet) like this one
Code: Select all
Section "InputClass"
        Identifier "SynPS/2 Synaptics TouchPad"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/event*"
        Option "Ignore" "on"
EndSection

However, if you're ok KDE Plasma (I'm sure there's something similar on Gnome, but I don't know where), you can go to System Settings -> Input Devices -> Touchpad -> Enable/Disable Touchpad make it so the touchpad is disabled when the mouse is plugged in
ITA84
 
Posts: 98
Joined: Mar 5th, '13, 18:15

Re: Mouse cursor jumps ramdomly

Postby mackowiakp » Apr 13th, '19, 05:27

Doesn't the touch pad have a button or a marked area that you can tap twice to disable it?


It does not has touchpad like Synaptics very common in laptops . This is All-In-One desktop PC (Lenovo) with 24 inch touch screen. I try run Windows and Knoppix and result is the same. I have to disable touch screen. It is impossible to turn it of from System Settings -> Input Devices because there is no touch screen listed as available device.

Below listing of /etc/X11/xorg.conf.d dir:

Code: Select all
[root@gosia-aio xorg.conf.d]# ls
00-keyboard.conf


And content of xorg.conf file:

Code: Select all
[root@gosia-aio X11]# cat xorg.conf
# File generated by XFdrake (rev 262502)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
EndSection

Section "Module"
    Load "v4l" # Video for Linux
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
   
    # Apple iMac modes
    ModeLine "1024x768"   78.525 1024 1049 1145 1312   768  769  772  800 +hsync +vsync
    ModeLine "800x600"    62.357  800  821  901 1040   600  601  604  632 +hsync +vsync
    ModeLine "640x480"    49.886  640  661  725  832   480  481  484  514 +hsync +vsync
   
    # Apple monitors tend to do 832x624
    ModeLine "832x624"    57      832  876  940 1152   624  625  628  667 -hsync -vsync
   
    # Apple PowerBook G3
    ModeLine "800x600"    100     800  816  824  840   600  616  624  640 -hsync -vsync
   
    # Apple TI Powerbook
    ModeLine "1152x768"   78.741 1152 1173 1269 1440   768  769  772  800 +vsync +vsync
   
    # Pismo Firewire G3
    ModeLine "1024x768"   65     1024 1032 1176 1344   768  771  777  806 -hsync -vsync
   
    # iBook2
    ModeLine "1024x768"   65     1024 1048 1184 1344   768  771  777  806 -hsync -vsync
   
    # 17" Apple Studio Display
    ModeLine "1024x768"   112.62 1024 1076 1248 1420 768 768 780 808 +hsync +vsync
   
    # HiRes Apple Studio Display
    ModeLine "1280x1024"  135    1280 1288 1392 1664  1024 1027 1030 1064
   
    # Another variation
    ModeLine "1280x1024"  134.989 1280 1317 1429 1688  1024 1025 1028 1066 +hsync +vsync
   
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "Intel Corporation"
    BoardName "Intel 810 and later"
    Driver "intel"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection


Then I try to find word "touchscreen" in all files in /etc/X11, recursively. Nothing was found:

Code: Select all
[root@gosia-aio X11]# grep -r touchscreen *
[root@gosia-aio X11]# grep -r Touchscreen *


So, how can I disable touch screen?
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 542
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Mouse cursor jumps ramdomly

Postby mackowiakp » Apr 13th, '19, 06:23

SOLVED !. I change entry in file /usr/share/X11/xorg.conf.d/40-libinput.conf:

Code: Select all
Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "off" # CHANGED FROM ON to OFF
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection


Thats all. xinput does not shows at this moment Lenovo Touchscreen and of course touchscreen does not work.
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 542
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Mouse cursor jumps ramdomly

Postby isadora » Apr 13th, '19, 09:09

Good news mackowiakp. :)

Would you please mark this topic [SOLVED]?
You can do so by editing the title/subject of the first message in the topic.
Place [SOLVED] in front of subject/title.

Thanks ahead. :)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2435
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron