Wifi drops Internet/no wifi after sleep

Wifi drops Internet/no wifi after sleep

Postby DiBosco » Apr 4th, '19, 12:10

Folks,

I have an HP laptop that I have reinstalled form scratch with M6.1.

It works fine other than wi-fi drops its connection after a minute or so. It says it still has a connection to the access point, but you can't even ping anything.

dmesg tells me a couple of potentially interesting things:

Code: Select all
could not load the ucode section

failed to wake nic for hcmd


If I sleep and then wake up things are even worse. It won't even see any SSIDs.

I've Googled those two error messages and seen plenty of advice, especially for the hcmd issue, but they're pretty much all saying update the Kernel to 4.14 and I am. (Plus they're mostly from about 2016.)

The Wireless card is an Intel 3165 and I have iwlwifi as its module.

If there's any other info that is helpful let me know and I'll post it.

I'm completely up-to-date with all software updates.

I should also add it was OK with Mageia 6.0

Thanks :)
DiBosco
 
Posts: 252
Joined: Aug 31st, '11, 10:22

Re: Wifi drops Internet/no wifi after sleep

Postby doktor5000 » Apr 5th, '19, 00:15

DiBosco wrote:I have an HP laptop that I have reinstalled form scratch with M6.1.
[...]
I should also add it was OK with Mageia 6.0


If you had updates on the 6.0 installation then there's no difference to a fresh 6.1 install, they consist of the same packages.

You should at least add the output of lspcidrake -v and also
journalctl -ab output after a fresh boot at the point where the connection is not working anymore.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14684
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Networking

Who is online

Users browsing this forum: No registered users and 0 guests

cron