titlebars-System menu (minimize, maximize and close) GONE!

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

titlebars-System menu (minimize, maximize and close) GONE!

Postby reltek » Feb 13th, '19, 21:55

Hello,

I am new to this forum and I don't know where this question would go in this forum. So, note to admin; If you need to move this topic to appropriate board, please do so.

I am running Mageia 4 and KDE 4.12. Yes, I know know... This is an ancient version, but that's what I have been using and it's been working for me ever since.

Well, my question or issue is this. I accidentally disabled or removed the titlebar for the whole system. This titlebar has system menu with MINIMIZE, MAXIMIZE and CLOSE option. So, any time I open any programs, that title bar is missing and I DON't KNOW WHAT I DID or HOW TO GET IT BACK. It is very much annoying to say the least that I can't simply click on the X button and close a window...

Please, can someone help me?

Thank you in advance.
reltek
 
Posts: 5
Joined: Feb 26th, '16, 19:02

Re: titlebars-System menu (minimize, maximize and close) GON

Postby reltek » Feb 13th, '19, 22:48

I just found out that my kwin crashed and that I can restart it by running the following in terminal.

Code: Select all
kwin --replace


That works but once I close the terminal, kwin stops working. How can I keep it running the whole time from boot?

Thank you,
reltek
 
Posts: 5
Joined: Feb 26th, '16, 19:02

Re: titlebars-System menu (minimize, maximize and close) GON

Postby ITA84 » Feb 14th, '19, 13:58

reltek wrote:How can I keep it running the whole time from boot?


You could use
Code: Select all
kwin --replace &

The & at the end makes it run in background. Alternatively, you could enter the kwin --replace command in KRunner (press Alt+Space)

As an aside, the disappearing title bars make me think KWin crashed and isn't running anymore, so the --replace part is technically unnecessary (but it doesn't hurt to leave it in)
ITA84
 
Posts: 92
Joined: Mar 5th, '13, 18:15

Re: titlebars-System menu (minimize, maximize and close) GON

Postby reltek » Feb 14th, '19, 16:24

Thank you, ITA84

I am not sure what you meant by ALT+SPACE. I clicked on the ALT button and SPACEBAR at the same time and it did nothing.

So, I simply added the kwin --replace on the startup program under system settings as a script. It works. :)

Thank you again, ITA84.

Have a great day. :)
reltek
 
Posts: 5
Joined: Feb 26th, '16, 19:02


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest