Epson L485 Scanner won't work

Epson L485 Scanner won't work

Postby HoaniP » Sep 4th, '18, 02:38

I've recently bought a new computer and multifunction printer/copier/scanner.

I thought I had done my due diligence before I bought them, but now find that I can't get the scanner to work. The printer is fine.

Here are the details of the hardware & software:

Computer: HP PAV 24-R043A AIO All-in-one with AMD A10-9630P, 2.4GHz, 4 core CPU; 16GB DDR4-2400 memory; Integrated Radeon R5 graphics

O/S Mageia 6, which I update as soon as updates come through.

Multifunction device: Epson Eco Tank L485

What I've done:

1. I connected the scanner by USB 3 port to the computer, and turned it on;

2. I opened Mageia control centre and searched for scanners. It has detected "Epson PID 111E flatbed scanner";

3. I opened XSANE (version 0.999). It said "Searching for scanners",then opened the scanning window. I tried to perform a scan. Nothing happened. I've tried several times, with the same result.

4. I went to sane-project.org, and looked for my scanner under Supported Harware. L485 does not appear on the list, neither does any L4XX series.

5. I googled, and found a driver at http://download.ebz.epson.net/dsc/du/02 ... ies&OSC=LX

I reached this site from a link on this site: https://www.epson.co.in/Support/Printer ... lter=Linux

I downloaded the software, unpacked it, and found it contained three folders: CORE, DATA, and PLUGINS. Each folder contained a .rpm file, so I installed those.

6. I used the Application Menu, and found Image Scan! for linux. I selected that, and received a message saying "Could not send command to scanner. Check scanner's status."

7. I checked everything I know how to check, but with no success (including that the scanner was plugged in and turned on). NOTE: I am a GUI user, and have never learnt to use the command line.

I found some help at https://tutorialforlinux.com/2014/12/08 ... asy-guide/

I have found some ideas from googling, and have checked the Mageia and other forums, with no success.

I found this post on the Mageia forums viewtopic.php?f=24&t=12108&p=70804&hilit=l485+epson+scanner#p70804 but it has not helped.

I hope someone can help me, please.

FYI, I tried asking epson, and got a response that I should check with Linux LOL

I hope someone can help.

Thank you.
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand

Re: Epson L485 Scanner won't work

Postby doktor5000 » Sep 4th, '18, 07:19

For a start, I'd try to use a regular, non USB-3.0 port as that does create issues sometimes.

Please also at least provide the output as root of
Code: Select all
lspcidrake -v
lsusb
sane-find-scanner
scanimage -L


You may also want to take a look at https://wiki.mageia.org/en/Epson_scanners
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14527
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Epson L485 Scanner won't work

Postby HoaniP » Sep 4th, '18, 08:48

Thank you for your help.

OUTPUT OF LSPCIDRAKE -V

Code: Select all
[root@localhost ~]# lspcidrake -v
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 5 [BRIDGE_HOST] (vendor:1022 device:1575)
i2c_piix4       : Advanced Micro Devices, Inc. [AMD]|FCH SMBus Controller [SERIAL_SMBUS] (vendor:1022 device:790b subv:103c subd:8374) (rev: 4a)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Host Bridge [BRIDGE_HOST] (vendor:1022 device:157b)
unknown         : Advanced Micro Devices, Inc. [AMD]|FCH SATA Controller [AHCI mode] [STORAGE_SATA] (vendor:1022 device:7901 subv:103c subd:8374) (rev: 49)
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Root Port [BRIDGE_PCI] (vendor:1022 device:157c)
unknown         : Advanced Micro Devices, Inc. [AMD]|Device 157d [BRIDGE_HOST] (vendor:1022 device:157d)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 0 [BRIDGE_HOST] (vendor:1022 device:1570)
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Root Port [BRIDGE_PCI] (vendor:1022 device:157c)
snd_hda_intel   : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Audio Controller [MULTIMEDIA_AUDIO_DEV] (vendor:1022 device:157a subv:103c subd:8374)
snd_hda_intel   : Advanced Micro Devices, Inc. [AMD/ATI]|Kabini HDMI/DP Audio [MULTIMEDIA_AUDIO_DEV] (vendor:1002 device:9840 subv:103c subd:8374)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 2 [BRIDGE_HOST] (vendor:1022 device:1572)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Host Bridge [BRIDGE_HOST] (vendor:1022 device:157b)
ehci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB EHCI Controller [SERIAL_USB] (vendor:1022 device:7908 subv:103c subd:8374) (rev: 49)
fam15h_power    : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 4 [BRIDGE_HOST] (vendor:1022 device:1574)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Root Complex [BRIDGE_HOST] (vendor:1022 device:1576 subv:103c subd:8374)
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [NETWORK_ETHERNET] (vendor:10ec device:8168 subv:103c subd:8374) (rev: 15)
unknown         : Advanced Micro Devices, Inc. [AMD]|FCH LPC Bridge [BRIDGE_ISA] (vendor:1022 device:790e subv:103c subd:8374) (rev: 11)
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Root Port [BRIDGE_PCI] (vendor:1022 device:157c)
Card:ATI Volcanic Islands and later (amdgpu/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Wani [Radeon R5/R6/R7 Graphics] [DISPLAY_VGA] (vendor:1002 device:9874 subv:103c subd:8374) (rev: ce)
unknown         : Realtek Semiconductor Co., Ltd.|RTL8821CE 802.11ac PCIe Wireless Network Adapter [NETWORK_OTHER] (vendor:10ec device:c821 subv:103c subd:831a)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 1 [BRIDGE_HOST] (vendor:1022 device:1571)
xhci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB XHCI Controller [SERIAL_USB] (vendor:1022 device:7914 subv:103c subd:8374) (rev: 20)
k10temp         : Advanced Micro Devices, Inc. [AMD]|Family 15h (Models 60h-6fh) Processor Function 3 [BRIDGE_HOST] (vendor:1022 device:1573)
unknown         : Advanced Micro Devices, Inc. [AMD]|Device 1578 [CRYPT_OTHER] (vendor:1022 device:1578 subv:103c subd:8374)
rtsx_pci        : Realtek Semiconductor Co., Ltd.|RTS5229 PCI Express Card Reader (vendor:10ec device:5229 subv:103c subd:8374) (rev: 01)
hub             : Linux 4.14.65-desktop-1.mga6 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Advanced Micro Devices, Inc.|Unknown [Hub|Unused|Full speed (or root) hub] (vendor:0438 device:7900)
usbhid          : ILITEK|Multi-Touch-V5300 [Human Interface Device|No Subclass|None] (vendor:222a device:0134)
usbhid          : Lite-On Technology Corp.|HP Wireless Keyboard Kit [Human Interface Device|Boot Interface Subclass|Keyboard] (vendor:04ca device:00a9)
usblp           : EPSON|L485 Series [Printer|Printer|Bidirectional] (vendor:04b8 device:111e)
btusb           : Realtek |Bluetooth Radio  [Wireless|Radio Frequency|Bluetooth] (vendor:0bda device:b00a)
hub             : Linux 4.14.65-desktop-1.mga6 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
uvcvideo        : Generic|HP 2.0MP High Definition Webcam [Video|Video Control] (vendor:0408 device:5230)
hub             : Linux 4.14.65-desktop-1.mga6 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0003)
hid_generic     : Lite-On Technology Corp. HP Wireless Keyboard Kit
hid_multitouch  : ILITEK Multi-Touch-V5300
hid_generic     : Lite-On Technology Corp. HP Wireless Keyboard Kit
hid_generic     : ILITEK Multi-Touch-V5300
hid_generic     : Lite-On Technology Corp. HP Wireless Keyboard Kit
[root@localhost ~]#

OUTPUT OF lsusb

Code: Select all
[root@localhost ~]# lsusb
Bus 001 Device 005: ID 0bda:b00a Realtek Semiconductor Corp.
Bus 001 Device 006: ID 04b8:111e Seiko Epson Corp.
Bus 001 Device 004: ID 04ca:00a9 Lite-On Technology Corp.
Bus 001 Device 003: ID 222a:0134 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 0408:5230 Quanta Computer, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@localhost ~]#


OUTPUT OF sane-find-scanner

Code: Select all
[root@localhost ~]# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04b8, product=0x111e) at libusb:001:006
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
[root@localhost ~]#


OUTPUT OF scanimage -L

Code: Select all
[root@localhost ~]# scanimage -L
device `epkowa:usb:001:006' is a Epson PID 111E flatbed scanner
device `v4l:/dev/video0' is a Noname HP 2.0MP High Definition Webcam virtual device
[root@localhost ~]#


PLEASE NOTE:After reading the Mageia Wiki, I uninstalled xsane, but I could not find xsane backend in the Control Centre.
Last edited by isadora on Sep 4th, '18, 10:29, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand

Re: Epson L485 Scanner won't work

Postby wintpe » Sep 5th, '18, 12:43

I also have a epson scanner the 330 and that works a charm under mageia 6.

however you will notice a post in the printers area with a epson printer/scanner from me.

viewtopic.php?f=24&t=12439

and i have a similar issue, with the scanner on that.

in my case the drivers supplied by epson for the scanner part are incompatible with mageia

I managed to get it working on mageia 5 with a recompile of the driver, but the driver versions available wont work on 6, i think they will probably work on 7.

however as a workaround for the person i was setting it up, the scanner can scan to sdcard directly, so until i get to update that system, the user is doing that instead.

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1177
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: Epson L485 Scanner won't work

Postby HoaniP » Sep 5th, '18, 12:52

Thanks, Peter.

That seems like a good work around in the meantime. I'll give it a go.

HoaniP
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand

Re: Epson L485 Scanner won't work

Postby HoaniP » Sep 10th, '18, 02:54

Greetings.

I've tried using a SD card, but the device only allows printing (e.g. photos) from a card, not scanning to a card.

I hope that doktor5000 will be able to help.

Thank you.
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand

Re: Epson L485 Scanner won't work

Postby wintpe » Sep 10th, '18, 13:35

I find that hard to believe as all the other epson printers do it that have an sdcard slot and a scanner, but i must admit i cant find it in the docs.

however i did find this.

Scan to Cloud (L485 Only) – Share your scans through
email or store them online in cloud storage services.

so you use your phone or tablet to operate the scan, and send to your computer

lastly have you tried this

http://download.ebz.epson.net/dsc/du/02 ... 88c1e8bc9c

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1177
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: Epson L485 Scanner won't work

Postby doktor5000 » Sep 10th, '18, 15:44

HoaniP wrote:[root@localhost ~]# lspcidrake -v
usblp : EPSON|L485 Series [Printer|Printer|Bidirectional] (vendor:04b8 device:111e)
[root@localhost ~]#


I believe this might be your issue. See also https://wiki.mageia.org/en/Mageia_5_Err ... blp_loaded
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14527
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Epson L485 Scanner won't work

Postby HoaniP » Sep 29th, '18, 01:41

Thank you doktor5000. Sorry I've been so long replying. I've been away.

I'm getting a bit nervous about changing things as root, so I need to check that I've got his right, before I change anything.

It seems that the best thing for me to try is to follow the advice in the wiki: to "add 'blacklist usblp' to /etc/modprobe.conf, to prevent it from loading on each boot." This would stop usblp from loading at boot time, and would hopefully fix the problem.

To do this, I need to log in as root, go to /etc/modprobe.conf , click on it, then amend the text file by adding a new line, which says 'blacklist usblp', with out the quote marks. After doing this, the modprobe.conf file would look like this:

install usb-interface /sbin/modprobe xhci_hcd; /sbin/modprobe xhci_pci; /sbin/modprobe ehci_hcd; /sbin/modprobe ehci_pci; /bin/true
blacklist usblp

Is this correct?

Thank you.
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand

Re: Epson L485 Scanner won't work

Postby doktor5000 » Oct 1st, '18, 23:01

HoaniP wrote:To do this, I need to log in as root, go to /etc/modprobe.conf , click on it, then amend the text file by adding a new line, which says 'blacklist usblp', with out the quote marks. After doing this, the modprobe.conf file would look like this:

No. To edit a file, you do not need to login (presumably you mean graphical login) as root and "click" on some file. The following should be sufficient:
Code: Select all
su -
enter your root password, press enter
Code: Select all
echo "blacklist usblp" >> /etc/modprobe.conf

which will append the line blacklist usblp to the file /etc/modprobe.conf

But before doing that permanent change, best try before as root via
Code: Select all
rmmod usblp

if that helps. If it does not, blacklisting will not help you.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14527
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Epson L485 Scanner won't work

Postby HoaniP » Oct 21st, '18, 22:30

Sorry to take so long in replying. Thank you for your help.

Here is a copy of my attempt following your last post:

Code: Select all
[papa@localhost ~]$ su
Password:
[root@localhost papa]# rmmod usblp
rmmod: ERROR: Module usblp is not currently loaded
[root@localhost papa]#     


I guess that if usblp is not loaded, then that won't be the problem.
Last edited by isadora on Oct 22nd, '18, 10:42, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
HoaniP
 
Posts: 24
Joined: Sep 16th, '12, 10:01
Location: Christchurch, New Zealand


Return to Printers and Scanners

Who is online

Users browsing this forum: No registered users and 0 guests