Suddenly asked for root password to mount a partition

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Suddenly asked for root password to mount a partition

Postby Erik » Jun 7th, '18, 16:53

Suddenly at logging in (Mageia 6, Plasma 5.12) I am asked for a password in order to mount a partition on my hard drive. I do not need this partition to be mounted at logging in and was never asked for it before. The other user in my home partition does not get this request. I prefer to get back to the earlier situation where I was never asked at logging in to give password for in irrelevant partition.

What has changed???

Greetings

Erik
Erik
 
Posts: 108
Joined: Jun 18th, '12, 17:22

Re: Suddenly asked for root password to mount a partition

Postby wintpe » Jun 7th, '18, 18:05

when you logged out, did you leave an app or dolphin open on a file in that partition.

I wonder if its trying to re-establish the status from when you logged out.

usually to mount a partition on a drive, for the first time you do need to provide the root password unless you configure it not to do so.

so thats why im thinking an app left open on a file in that partition is trying to reestablish connection with that file and triggering the mount.

I sometimes get the same if i leave a web browser connected to a authenticated site, it askes for the password on startup to try to re-establish the previous status.

unless ive got the wrong end of the stick on your question.

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1168
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: Suddenly asked for root password to mount a partition

Postby Erik » Jun 8th, '18, 11:17

Yes this must be it, I guess. I have been searching for som KDE file that mentions sda11 and the only one I could find, is kded_device_automounterrc. I replaced it with the same file from another installation on a SSD drive and now I am no longer asked for a password at logging in. Studying the content of this file I am convinced there must be some other file somewhere, but I cannot find it. In the original file the parameters were the same as for the other partitions, that did not cause asking for a password to be mounted.

Thank you for your answer. If you can tell me more I'll be grateful.

Greetings,

Erik.
Erik
 
Posts: 108
Joined: Jun 18th, '12, 17:22

Re: Suddenly asked for root password to mount a partition

Postby doktor5000 » Jun 9th, '18, 15:52

Erik wrote:If you can tell me more I'll be grateful.

What more in particular ?

Apart from that, you're missing essential details, like what partition/filesystem is that, is it in your /etc/fstab or do you maybe have it in dolphin's places panel ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14468
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Suddenly asked for root password to mount a partition

Postby Erik » Jun 21st, '18, 15:31

Dear Doktor,

the file kded_device_automounterrc contains:

[Devices][/org/freedesktop/UDisks2/block_devices/sda11]
EverMounted=true
Icon=drive-harddisk
LastNameSeen=23,4 GiB harde schijf
LastSeenMounted=false


This was the case when I was asked for the root password tot mount this partition every time I logged in. I replaced this file with one from another M6 installation. After this I was no longer asked, but the stanza about sda11 was exactly the same. This is why I asked if there is another file somewhere that I died not yet find.

This partition is not mentioned in fstab, because normally I won't need it for my M6 installation on this computer. Sda11 is mentioned in Dolphin in the Places panel with the other partitions. When I want to mount it, I am asked for the root password, as expected. None of the other partitions tried to be mounted at login.

I think it very strange that the asking for the root password for sda11 at login ceased after the replacing of the file kded_device_automounterrc with one that was exactly the same as the foregoing. This is why I asked for further explanation.

Thank you and greetings,

Erik.
Erik
 
Posts: 108
Joined: Jun 18th, '12, 17:22


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest