MageiaUpdate broke LibreOffice; can't reinstall! [SOLVED]

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

MageiaUpdate broke LibreOffice; can't reinstall! [SOLVED]

Postby Xhermin » Jun 7th, '18, 04:01

Since the usual solution is to uninstall the remainder of the suite and reinstall, I tried that. Trying to install either 32 or 64 bit versions of LO5.4.3.2 or LO5.4.7.2 generates the MCC error message "Sorry, the following package cannot be selected". Actually, 5.4.7.2_x85_64 seems to me missing. LibreOffice itself is up to version 6.x - at least on my Win10 box. I have Mageia 6, Plasma desktop, all current updates.
Code: Select all
uname -a

Linux localhost 4.14.44-desktop-2.mga6 #1 SMP Mon May 28 22:35:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


LibreOffice is an ABSOLUTE MUST for me, if this doesn't get solved for me, QUICKLY, this is a dealbreaker for me continuing to use this distro!!!
Last edited by Xhermin on Jun 7th, '18, 23:28, edited 1 time in total.
Xhermin
 
Posts: 29
Joined: Oct 26th, '12, 20:57

Re: MageiaUpdate broke LibreOffice; MCC won't let me reinsta

Postby daniewicz » Jun 7th, '18, 04:24

Have you recently updated your repositories?
The dude abides.
User avatar
daniewicz
 
Posts: 153
Joined: Feb 10th, '13, 03:37

Re: MageiaUpdate broke LibreOffice; MCC won't let me reinsta

Postby benmc » Jun 7th, '18, 09:16

in a root terminal, what does
Code: Select all
# urpmi libreoffice
return?
benmc
 
Posts: 666
Joined: Sep 2nd, '11, 12:45
Location: Pirongia, New Zealand

Re: MageiaUpdate broke LibreOffice; MCC won't let me reinsta

Postby wintpe » Jun 7th, '18, 11:19

when "Sorry, the following package cannot be selected" comes up, its usually that you have something installed thats incompatible with the packages available in the mageia repo.

as suggested by Benmc, using a a terminal
Code: Select all
su -

enter root password

urpmi libreoffice


dont expect that to work, but the error it gives will be a much better clue to the problem to "Sorry, the following package cannot be selected"

it might be package incompatible with .......

removing that package, if its not tied into other packages may resolve the problem.

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1168
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: MageiaUpdate broke LibreOffice; MCC won't let me reinsta

Postby Xhermin » Jun 7th, '18, 23:20

This is a relatively fresh Mageia6 install, the repos shoudn't need refreshing/tweaking this soon, but I'll try it. MageiaUpdate has previously been pretty good about dealing with repo shifts automatically. Stay tuned.
Xhermin
 
Posts: 29
Joined: Oct 26th, '12, 20:57

Re: MageiaUpdate broke LibreOffice; MCC won't let me reinsta

Postby Xhermin » Jun 7th, '18, 23:27

Shave my feet and paint me purple, that worked. I really need to learn urpmi, I'm so used to Debian-based apt/synaptik that I don't consider the alternatives.
Xhermin
 
Posts: 29
Joined: Oct 26th, '12, 20:57

Re: MageiaUpdate broke LibreOffice; can't reinstall! [SOLVED

Postby daniewicz » Jun 9th, '18, 03:13

Awesome! :D
The dude abides.
User avatar
daniewicz
 
Posts: 153
Joined: Feb 10th, '13, 03:37


Return to Basic support

Who is online

Users browsing this forum: No registered users and 0 guests