[RESOLVED] Mageia update fails and loops

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[RESOLVED] Mageia update fails and loops

Postby griffin » May 16th, '18, 14:55

Mageia update failed and looped, then it segfaulted.

It said it wanted to remove a couple of packages and update 51 packages, then it failed with the following message:
Code: Select all
libGL.so.1 is needed by (installed) libmesaglu1-9.0.0-6.1.mga6.i586

At that point it looped, so I deselected all 51 packages, quit Mageia update and started to open this thread. When I opened Mageia Control Center and tried to run Mageia update manually to document the looping behaviour, it updated a libhz database, reported that all packages were up to date and, when I quit to exit Mageia update, it segfaulted:
Code: Select all
kernel: drakconf[7363]: segfault at b ip 00007fed28922898 sp 00007ffd12f151d0 error 4 in libgobject-2.0.so.0.5400.3[7fed28901000+51000]

I rebooted the system, and now urpmi --auto-update shows me this:
Code: Select all
# urpmi --auto-update
medium "Core Release (distrib1)" is up-to-date
    $MIRRORLIST: media/core/updates/media_info/20180516-080102-synthesis.hdlist.cz
updated medium "Core Updates (distrib3)"                                                                                                                                                                                     
medium "Nonfree Release (distrib11)" is up-to-date
medium "Nonfree Updates (distrib13)" is up-to-date
medium "Tainted Release (distrib21)" is up-to-date
medium "Tainted Updates (distrib23)" is up-to-date
medium "Core 32bit Release (distrib31)" is up-to-date
    $MIRRORLIST: media/../../i586/media/core/updates/media_info/20180131-204129-synthesis.hdlist.cz
updated medium "Core 32bit Updates (distrib32)"                                                                                                                                                                             
medium "Nonfree 32bit Release (distrib36)" is up-to-date
medium "Nonfree 32bit Updates (distrib37)" is up-to-date
medium "Tainted 32bit Release (distrib41)" is up-to-date
medium "Tainted 32bit Updates (distrib42)" is up-to-date
A requested package cannot be installed:
libmesagl1-17.3.2-1.1.mga6.i586 (in order to keep libmesagl1-17.3.6-1.mga6.i586)
Continue installation anyway? (Y/n) y
The following packages have to be removed for others to be upgraded:
libdri-drivers-17.3.6-1.mga6.i586
 (due to unsatisfied mesa == 17.3.6)
libmesagl1-17.3.6-1.mga6.i586
 (due to unsatisfied libdri-drivers >= 17.3.6-1.mga6) (y/N) y
To satisfy dependencies, the following packages are going to be installed:
  Package                        Version      Release       Arch   
(medium "Core Updates (distrib3)")
  kbookmarks                     5.42.0       1.1.mga6      x86_64 
  kcmutils                       5.42.0       1.1.mga6      x86_64 
  kcompletion                    5.42.0       2.1.mga6      x86_64 
  kitemviews                     5.42.0       1.1.mga6      x86_64 
  kjobwidgets                    5.42.0       1.1.mga6      x86_64 
  knewstuff                      5.42.0       1.2.mga6      x86_64 
  knotifyconfig                  5.42.0       1.1.mga6      x86_64 
  ktextwidgets                   5.42.0       1.1.mga6      x86_64 
  kunitconversion                5.42.0       1.1.mga6      x86_64 
  lib64blkid1                    2.28.2       2.1.mga6      x86_64 
  lib64dri-drivers               17.3.9       1.mga6        x86_64 
  lib64drm2                      2.4.91       1.1.mga6      x86_64 
  lib64drm_amdgpu1               2.4.91       1.1.mga6      x86_64 
  lib64drm_intel1                2.4.91       1.1.mga6      x86_64 
  lib64drm_nouveau2              2.4.91       1.1.mga6      x86_64 
  lib64drm_radeon1               2.4.91       1.1.mga6      x86_64 
  lib64fdisk1                    2.28.2       2.1.mga6      x86_64 
  lib64gbm1                      17.3.9       1.mga6        x86_64 
  lib64glapi0                    17.3.9       1.mga6        x86_64 
  lib64graphite2_3               1.3.10       1.1.mga6      x86_64 
  lib64kf5bookmarks5             5.42.0       1.1.mga6      x86_64 
  lib64kf5completion5            5.42.0       2.1.mga6      x86_64 
  lib64kf5jobwidgets5            5.42.0       1.1.mga6      x86_64 
  lib64kf5kcmutils5              5.42.0       1.1.mga6      x86_64 
  lib64kf5kdnssd5                5.42.0       1.1.mga6      x86_64 
  lib64kf5newstuff5              5.42.0       1.2.mga6      x86_64 
  lib64kf5newstuffcore5          5.42.0       1.2.mga6      x86_64 
  lib64kf5notifyconfig5          5.42.0       1.1.mga6      x86_64 
  lib64kf5pty5                   5.42.0       1.1.mga6      x86_64 
  lib64kf5textwidgets5           5.42.0       1.1.mga6      x86_64 
  lib64kf5unitconversion5        5.42.0       1.1.mga6      x86_64 
  lib64kitemviews5               5.42.0       1.1.mga6      x86_64 
  lib64kms1                      2.4.91       1.1.mga6      x86_64 
  lib64mesaegl1                  17.3.9       1.mga6        x86_64 
  lib64mesagl1                   17.3.9       1.mga6        x86_64 
  lib64mount1                    2.28.2       2.1.mga6      x86_64 
  lib64osmesa8                   17.3.9       1.mga6        x86_64 
  lib64raw16                     0.18.11      1.mga6        x86_64 
  lib64smartcols1                2.28.2       2.1.mga6      x86_64 
  lib64sndfile1                  1.0.28       3.2.mga6      x86_64 
  lib64tiff5                     4.0.9        1.5.mga6      x86_64 
  lib64uuid1                     2.28.2       2.1.mga6      x86_64 
  lib64wayland-egl1              17.3.9       1.mga6        x86_64 
  lib64xatracker2                17.3.9       1.mga6        x86_64 
  libdrm-common                  2.4.91       1.1.mga6      x86_64 
  mesa                           17.3.9       1.mga6        x86_64 
  perl                           5.22.3       3.2.mga6      x86_64 
  perl-base                      5.22.3       3.2.mga6      x86_64 
  perl-doc                       5.22.3       3.2.mga6      noarch 
  util-linux                     2.28.2       2.1.mga6      x86_64 
  wget                           1.19.5       1.mga6        x86_64 
29MB of disk space will be freed.
30MB of packages will be retrieved.
Proceed with the installation of the 51 packages? (Y/n)y
installing kunitconversion-5.42.0-1.1.mga6.x86_64.rpm lib64kf5kdnssd5-5.42.0-1.1.mga6.x86_64.rpm lib64kms1-2.4.91-1.1.mga6.x86_64.rpm kcmutils-5.42.0-1.1.mga6.x86_64.rpm libdrm-common-2.4.91-1.1.mga6.x86_64.rpm lib64kitemviews5-5.42.0-1.1.mga6.x86_64.rpm util-linux-2.28.2-2.1.mga6.x86_64.rpm lib64xatracker2-17.3.9-1.mga6.x86_64.rpm perl-5.22.3-3.2.mga6.x86_64.rpm lib64mesagl1-17.3.9-1.mga6.x86_64.rpm lib64kf5bookmarks5-5.42.0-1.1.mga6.x86_64.rpm lib64mesaegl1-17.3.9-1.mga6.x86_64.rpm lib64kf5newstuff5-5.42.0-1.2.mga6.x86_64.rpm knewstuff-5.42.0-1.2.mga6.x86_64.rpm lib64kf5textwidgets5-5.42.0-1.1.mga6.x86_64.rpm lib64kf5jobwidgets5-5.42.0-1.1.mga6.x86_64.rpm lib64tiff5-4.0.9-1.5.mga6.x86_64.rpm lib64kf5notifyconfig5-5.42.0-1.1.mga6.x86_64.rpm wget-1.19.5-1.mga6.x86_64.rpm lib64mount1-2.28.2-2.1.mga6.x86_64.rpm lib64sndfile1-1.0.28-3.2.mga6.x86_64.rpm lib64graphite2_3-1.3.10-1.1.mga6.x86_64.rpm perl-doc-5.22.3-3.2.mga6.noarch.rpm mesa-17.3.9-1.mga6.x86_64.rpm lib64raw16-0.18.11-1.mga6.x86_64.rpm kcompletion-5.42.0-2.1.mga6.x86_64.rpm lib64blkid1-2.28.2-2.1.mga6.x86_64.rpm kjobwidgets-5.42.0-1.1.mga6.x86_64.rpm kbookmarks-5.42.0-1.1.mga6.x86_64.rpm lib64wayland-egl1-17.3.9-1.mga6.x86_64.rpm kitemviews-5.42.0-1.1.mga6.x86_64.rpm lib64gbm1-17.3.9-1.mga6.x86_64.rpm lib64kf5pty5-5.42.0-1.1.mga6.x86_64.rpm lib64kf5unitconversion5-5.42.0-1.1.mga6.x86_64.rpm lib64kf5kcmutils5-5.42.0-1.1.mga6.x86_64.rpm lib64drm_nouveau2-2.4.91-1.1.mga6.x86_64.rpm ktextwidgets-5.42.0-1.1.mga6.x86_64.rpm lib64drm_radeon1-2.4.91-1.1.mga6.x86_64.rpm lib64uuid1-2.28.2-2.1.mga6.x86_64.rpm lib64osmesa8-17.3.9-1.mga6.x86_64.rpm perl-base-5.22.3-3.2.mga6.x86_64.rpm lib64smartcols1-2.28.2-2.1.mga6.x86_64.rpm lib64fdisk1-2.28.2-2.1.mga6.x86_64.rpm lib64drm_intel1-2.4.91-1.1.mga6.x86_64.rpm lib64kf5completion5-5.42.0-2.1.mga6.x86_64.rpm lib64glapi0-17.3.9-1.mga6.x86_64.rpm lib64kf5newstuffcore5-5.42.0-1.2.mga6.x86_64.rpm lib64drm_amdgpu1-2.4.91-1.1.mga6.x86_64.rpm lib64dri-drivers-17.3.9-1.mga6.x86_64.rpm lib64drm2-2.4.91-1.1.mga6.x86_64.rpm knotifyconfig-5.42.0-1.1.mga6.x86_64.rpm from /var/cache/urpmi/rpms
Installation failed:    libGL.so.1 is needed by (installed) libmesaglu1-9.0.0-6.1.mga6.i586
While some packages may have been installed, there were failures.
A requested package cannot be installed:
libmesagl1-17.3.2-1.1.mga6.i586 (in order to keep libmesagl1-17.3.6-1.mga6.i586)
Continue installation anyway?

urpmi --auto-update quit at that point without waiting for the response. Mageia update seemed to be broken. However, running urpmi --auto-update again a little while later worked and apparently resolved the problem, so I'll close this thread.
griffin
 
Posts: 95
Joined: Sep 9th, '11, 03:51

Re: [RESOLVED] Mageia update fails and loops

Postby filip » May 18th, '18, 15:50

It seems that the your package mirror was not synched before last update. Or the package was fixed in between.
filip
 
Posts: 400
Joined: May 4th, '11, 22:10
Location: Kranj, Slovenia


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest