drakconf segfaults.

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

drakconf segfaults.

Postby jiml8 » May 14th, '18, 19:09

I have just completed the "great upgrade" and now I can't start drakconf.

Trying it from a terminal yields the following messages:
Code: Select all
Too late to run INIT block at /usr/lib/perl5/vendor_perl/5.22.2/x86_64-linux-thread-multi/Glib/Object/Introspection.pm line 257.
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.22.3/Gtk3.pm line 525.
FATAL: Could not allocate gigacage memory with maxAlignment = 34359738368, totalSize = 103079215104.
(Make sure you have not set a virtual memory limit.)
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.22.3/Gtk3.pm line 525.
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby martinw » May 14th, '18, 21:03

Looks like that may come from the updated webkit libraries:
https://bugs.webkit.org/show_bug.cgi?id=183329
What does
Code: Select all
ulimit -v

and (as root)
Code: Select all
sysctl vm.overcommit_memory

show?
martinw
 
Posts: 411
Joined: May 14th, '11, 10:59

Re: drakconf segfaults.

Postby jiml8 » May 15th, '18, 01:20

ulimit returns unlimited, and I have set vm.overcommit_memory to 2. Did that a long time ago.
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby doktor5000 » May 15th, '18, 08:06

jiml8 wrote:ulimit returns unlimited, and I have set vm.overcommit_memory to 2. Did that a long time ago.

See https://bugs.webkit.org/show_bug.cgi?id=183329#c30
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14432
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: drakconf segfaults.

Postby jiml8 » May 15th, '18, 08:47

yes that appears to be it.

My reasons for keeping overcommit =2 are very similar to Daniel Kondor's, and I don't plan to change it. I'll just have to find another way.
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby martinw » May 15th, '18, 09:44

Try the workaround in https://bugs.webkit.org/show_bug.cgi?id=183329#c38:
Setting the environment variable GIGACAGE_ENABLED=0 is a good workaround.

I suggest filing a bug in the Mageia Bugzilla, in case other users hit this problem, and also to alert the Mageia maintainer that an update is needed when the bug is fixed upstream.
martinw
 
Posts: 411
Joined: May 14th, '11, 10:59

Re: drakconf segfaults.

Postby jiml8 » May 15th, '18, 17:05

Doesn't work.
Code: Select all
root@dadsbox:samba> printenv | grep GIGACAGE
GIGACAGE_ENABLED=0
root@dadsbox:samba> drakconf
Too late to run INIT block at /usr/lib/perl5/vendor_perl/5.22.2/x86_64-linux-thread-multi/Glib/Object/Introspection.pm line 257.
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.22.3/Gtk3.pm line 525.
FATAL: Could not allocate gigacage memory with maxAlignment = 34359738368, totalSize = 103079215104.
(Make sure you have not set a virtual memory limit.)
Ignore the following Glib::Object::Introspection & Gtk3 warnings
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.22.3/Gtk3.pm line 525.
Last edited by doktor5000 on May 16th, '18, 18:33, edited 1 time in total.
Reason: removed fullquote
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby doktor5000 » May 16th, '18, 18:33

martinw wrote:I suggest filing a bug in the Mageia Bugzilla, in case other users hit this problem, and also to alert the Mageia maintainer that an update is needed when the bug is fixed upstream.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14432
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: drakconf segfaults.

Postby jiml8 » May 25th, '18, 20:23

I am sufficiently fed up with kmail that I am determined to migrate away from it. Too bad; I have been using it for 20 years now, but it has become a troublesome POS for the last few years. I'm through with it. Cannot deal with this any more.

So, I have to get evolution working.

So, I looked again at this GIGACAGE_ENABLED=0 workaround, and with evolution it works. I have now set that environment variable in my KDE startup and, when I restart KDE, I can invoke evolution within KDE. I also set it in my .bashrc file, and I can invoke evolution that way.

Drakconf still won't start, though, even though I put that export within my /root/.bashrc file as well.
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby jiml8 » May 25th, '18, 20:50

Sorry, I guess my previous comment would be unclear to most people.

Along about the time I was filing a bug at bugzilla, I was trying to get evolution to start and was encountering the identical error in evolution. So I appended to my bugzilla report that I had just discovered that evolution did the same thing.

Now, a few days later, I have fiddled with this some more and discovered that I can get evolution to start.

So, for those reading this, this is why the references to evolution appeared. It was not really just out of thin air. :D
jiml8
 
Posts: 971
Joined: Jul 7th, '13, 18:09

Re: drakconf segfaults.

Postby martinw » May 25th, '18, 21:31

The reason setting GIGACACHE=0 doesn't work with drakconf is that /usr/bin/drakconf is a wrapper that runs the main drakconf program via pkexec. From the pkexec man page:
The environment that PROGRAM will run it[sic], will be set to a minimal known and safe environment in order to avoid injecting code through LD_LIBRARY_PATH or similar mechanisms.

You can work around this by running the main drakconf program via su:
Code: Select all
su -c /usr/libexec/drakconf
martinw
 
Posts: 411
Joined: May 14th, '11, 10:59


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest