[SOLVED] Update seems to have broken KDE

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] Update seems to have broken KDE

Postby mark9117 » May 13th, '18, 20:25

I found the update icon in my tray this morning and attempted to update my system (mageia 6) from the command line (urpmi --update --auto-select) and found about 680 or so updates ready. They looked mostly related to kde. I attempted the update and it failed with some odd content. I tried to step through the updates by manually installing some of the packages mentioned and hit a wall at kcodecs. At this point, all sorts of things have stopped working. Notably, rpmdrake no longer opens and I no longer have access to systemsettings:
Code: Select all
# systemsettings5
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)


I have no idea how to install that plugin.

Errors that I'm getting seem reasonably familiar at the end of the process but it starts of with a recurssion error of some sort. I issue the command "urpmi --update --auto-select" and get the list. Thanks to manually installing some of the updates, I'm down to about 529 packages. On the downside, this has also resulted in the failures I'm dealing with.

Code: Select all
 libqt5widgets5                 5.9.4        1.1.mga6      i586   
  libqt5x11extras5               5.9.4        1.mga6        i586   
  libqt5xcbqpa5                  5.9.4        1.1.mga6      i586   
  libqt5xml5                     5.9.4        1.1.mga6      i586   
  libsyntaxhighlighting5         5.42.0       1.mga6        i586   
380MB of disk space will be freed.
401MB of packages will be retrieved.
Proceed with the installation of the 529 packages? (Y/n)


Hitting enter to proceed yields this:

Code: Select all
Deep recursion on anonymous subroutine at /usr/lib/perl5/vendor_perl/5.22.2/x86_64-linux-thread-multi/URPM/Resolve.pm line 2160, <STDIN> line 1.
Deep recursion on anonymous subroutine at /usr/lib/perl5/vendor_perl/5.22.2/x86_64-linux-thread-multi/URPM/Resolve.pm line 2160, <STDIN> line 1.


installing lib64kconfigGui5-5.42.0-1.mga6.x86_64.rpm lib64kf5widgetsaddons5-5.42.0-1.mga6.x86_64.rpm ktextwidgets-5.42.0-1.mga6.x86_64.rpm lib64kitemviews5-5.42.0-1.mga6.x86_64.rpm lib64qt5widgets5-5.9.4-1.1.mga6.x86_64.rpm libkf5textwidgets5-5.42.0-1.mga6.i586.rpm lib64kf5sonnetcore5-5.42.0-1.mga6.x86_64.rpm lib64kf5dbusaddons5-5.42.0-1.mga6.x86_64.rpm lib64kf5globalaccel5-5.42.0-1.mga6.x86_64.rpm flac-1.3.2-1.1.mga6.x86_64.rpm lib64kf5coreaddons5-5.42.0-1.mga6.x86_64.rpm lib64uchardet0-0.0.6-1.mga6.x86_64.rpm kwidgetsaddons-5.42.0-1.mga6.x86_64.rpm lib64kf5service5-5.42.0-1.mga6.x86_64.rpm lib64kf5kiocore5-5.42.0-1.mga6.x86_64.rpm kcodecs-5.42.0-1.1.mga6.x86_64.rpm lib64qtav1-1.12.0-1.mga6.x86_64.rpm lib64kf5codecs5-5.42.0-1.1.mga6.x86_64.rpm python-attrs-15.2.0-1.mga6.noarch.rpm lib64kf5i18n5-5.42.0-1.mga6.x86_64.rpm lib64qt5qml5-5.9.4-1.mga6.x86_64.rpm lib64kf5configwidgets5-5.42.0-1.1.mga6.x86_64.rpm lib64karchive5-5.42.0-1.mga6.x86_64.rpm lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64.rpm lib64kf5sonnetui5-5.42.0-1.mga6.x86_64.rpm lib64flac8-1.3.2-1.1.mga6.x86_64.rpm lib64tidy0.99_0-20090904-11.mga6.x86_64.rpm lib64qt5x11extras5-5.9.4-1.mga6.x86_64.rpm lib64qt5gui5-5.9.4-1.1.mga6.x86_64.rpm lib64qt5network5-5.9.4-1.1.mga6.x86_64.rpm lib64gio2.0_0-2.54.3-1.1.mga6.x86_64.rpm lib64qt5eglfsdeviceintegration5-5.9.4-1.1.mga6.x86_64.rpm lib64qt5printsupport5-5.9.4-1.1.mga6.x86_64.rpm glib2.0-common-2.54.3-1.1.mga6.x86_64.rpm lib64kf5ldap5-17.12.2-1.mga6.x86_64.rpm lib64qt5eglfskmssupport5-5.9.4-1.1.mga6.x86_64.rpm lib64id3tag0-0.15.1b-17.2.mga6.x86_64.rpm lib64kchart2-2.6.0-1.mga6.x86_64.rpm lib64kf5guiaddons5-5.42.0-1.mga6.x86_64.rpm lib64qt5opengl5-5.9.4-1.1.mga6.x86_64.rpm lib64qt5xml5-5.9.4-1.1.mga6.x86_64.rpm lib64qt5svg5-5.9.4-1.mga6.x86_64.rpm lib64glib2.0-devel-2.54.3-1.1.mga6.x86_64.rpm lib64qtavwidgets1-1.12.0-1.mga6.x86_64.rpm libkf5widgetsaddons5-5.42.0-1.mga6.i586.rpm lib64qt5dbus5-5.9.4-1.1.mga6.x86_64.rpm lib64qt5xcbqpa5-5.9.4-1.1.mga6.x86_64.rpm lib64kconfigCore5-5.42.0-1.mga6.x86_64.rpm wireless-regdb-20171223-1.mga6.noarch.rpm lib64kf5textwidgets5-5.42.0-1.mga6.x86_64.rpm lib64kf5auth5-5.42.0-1.mga6.x86_64.rpm lib64flac++6-1.3.2-1.1.mga6.x86_64.rpm lib64graphicsmagick3-1.3.29-1.mga6.x86_64.rpm lib64glib2.0_0-2.54.3-1.1.mga6.x86_64.rpm kconfigwidgets-5.42.0-1.1.mga6.x86_64.rpm glib-gettextize-2.54.3-1.1.mga6.x86_64.rpm libkf5configwidgets5-5.42.0-1.1.mga6.i586.rpm lib64kf5completion5-5.42.0-1.mga6.x86_64.rpm from /var/cache/urpmi/rpms
Preparing...                     ##########################################################################################################################################


installing lib64kf5texteditor5-5.42.0-1.mga6.x86_64.rpm lib64kf5su5-5.42.0-1.mga6.x86_64.rpm lib64kf5pty5-5.42.0-1.mga6.x86_64.rpm lib64kf5js5-5.42.0-1.mga6.x86_64.rpm lib64editorconfig0-0.12.1-1.mga6.x86_64.rpm kitemmodels-5.42.0-1.mga6.x86_64.rpm lib64syntaxhighlighting5-5.42.0-1.mga6.x86_64.rpm lib64kf5akonadiagentbase5-17.12.2-1.mga6.x86_64.rpm lib64kf5wallet5-5.42.0-1.mga6.x86_64.rpm kwallet-5.42.0-1.mga6.x86_64.rpm lib64kf5xmlgui5-5.42.0-1.mga6.x86_64.rpm lib64kf5bookmarks5-5.42.0-1.mga6.x86_64.rpm lib64qt5quick5-5.9.4-1.mga6.x86_64.rpm libkf5kcmutils5-5.42.0-1.mga6.i586.rpm lib64phonon4qt5_4-4.10.0-1.mga6.x86_64.rpm lib64kf5notifications5-5.42.0-1.mga6.x86_64.rpm lib64kf5khtml5-5.42.0-1.mga6.x86_64.rpm lib64kf5declarative5-5.42.0-1.mga6.x86_64.rpm kauth-5.42.0-1.mga6.x86_64.rpm lib64kf5kcmutils5-5.42.0-1.mga6.x86_64.rpm lib64kf5akonadixml5-17.12.2-1.mga6.x86_64.rpm khtml-5.42.0-1.mga6.x86_64.rpm lib64qt5quickwidgets5-5.9.4-1.mga6.x86_64.rpm kxmlgui-5.42.0-1.mga6.x86_64.rpm lib64attica5-5.42.0-1.mga6.x86_64.rpm lib64kf5akonadiwidgets5-17.12.2-1.mga6.x86_64.rpm lib64qt5-database-plugin-mysql-5.9.4-1.1.mga6.x86_64.rpm lib64kf5activities5-5.42.0-1.mga6.x86_64.rpm lib64kitemmodels5-5.42.0-1.mga6.x86_64.rpm lib64kf5kiowidgets5-5.42.0-1.mga6.x86_64.rpm lib64akonadiprivate5-17.12.2-1.mga6.x86_64.rpm lib64kf5parts5-5.42.0-1.mga6.x86_64.rpm phonon4qt5-4.10.0-1.mga6.x86_64.rpm lib64kf5iconthemes5-5.42.0-1.mga6.x86_64.rpm lib64kf5quickaddons5-5.42.0-1.mga6.x86_64.rpm lib64phonon4qt5experimental4-4.10.0-1.mga6.x86_64.rpm lib64kf5windowsystem5-5.42.0-1.mga6.x86_64.rpm lib64kf5crash5-5.42.0-1.mga6.x86_64.rpm kcmutils-5.42.0-1.mga6.x86_64.rpm kde-cli-tools-5.12.2-1.mga6.x86_64.rpm kcrash-5.42.0-1.mga6.x86_64.rpm lib64kf5walletbackend55-5.42.0-1.mga6.x86_64.rpm lib64kf5package5-5.42.0-1.mga6.x86_64.rpm lib64kf5notifyconfig5-5.42.0-1.mga6.x86_64.rpm lib64kf5akonadicore5-17.12.2-1.mga6.x86_64.rpm lib64qt5sql5-5.9.4-1.1.mga6.x86_64.rpm lib64konsoleprivate17-17.12.2-1.mga6.x86_64.rpm lib64kf5mailtransport5-17.12.2-1.mga6.x86_64.rpm ktexteditor-5.42.0-1.mga6.x86_64.rpm lib64kf5solid5-5.42.0-1.mga6.x86_64.rpm libkf5xmlgui5-5.42.0-1.mga6.i586.rpm libphonon4qt5_4-4.10.0-1.mga6.i586.rpm from /var/cache/urpmi/rpms
Preparing...                     ##########################################################################################################################################


And more huge blocks of package names until we get to:

Code: Select all
installing libkontactprivate5-17.12.2-1.mga6.i586.rpm libkf5akonadicontact5-17.12.2-1.mga6.i586.rpm libkf5notifyconfig5-5.42.0-1.mga6.i586.rpm from /var/cache/urpmi/rpms
Installation failed:    file /usr/share/locale/eu/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586
        file /usr/share/locale/hy/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586
        file /usr/share/locale/id/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586
        file /usr/share/locale/tt/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586
        file /usr/share/locale/ca/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586
        file /usr/share/locale/ca@valencia/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586


And a lot more of that because of package conflicts until we get to:

Code: Select all
kcodecs = 5.42.0-1.1.mga6 is needed by libkf5codecs5-5.42.0-1.1.mga6.i586
        libOkular5Core.so.8()(64bit) is needed by okular-2:17.12.2-1.mga6.x86_64
        libkonsoleprivate.so.17()(64bit) is needed by konsole-1:17.12.2-1.mga6.x86_64
        kcron >= 2:17.12.2-1.mga6 is needed by kcron-handbook-2:17.12.2-1.mga6.noarch
        konqueror is needed by konq-plugins-1:17.12.2-1.mga6.x86_64
        libtidy-0.99.so.0()(64bit) is needed by konq-plugins-1:17.12.2-1.mga6.x86_64
        libQtAV.so.1()(64bit) is needed by lib64digikamcore5-1:5.9.0-1.mga6.x86_64
        libQtAVWidgets.so.1()(64bit) is needed by lib64digikamcore5-1:5.9.0-1.mga6.x86_64
        kate-l10n-common = 2:17.12.2-1.mga6 is needed by ktexteditor-plugins-2:17.12.2-1.mga6.x86_64
        gwenview >= 2:17.12.2-1.mga6 is needed by gwenview-handbook-2:17.12.2-1.mga6.noarch
        kirigami is needed by systemsettings-5.12.2-1.mga6.x86_64
        libalkimia5.so.7()(64bit) is needed by lib64kmm_plugin5-5.0.1-1.mga6.x86_64
        libkmm_mymoney.so.5()(64bit) is needed by lib64kmm_plugin5-5.0.1-1.mga6.x86_64
        kolourpaint >= 2:17.12.2-1.mga6 is needed by kolourpaint-handbook-2:17.12.2-1.mga6.noarch
        pythonegg(2)(attrs) is needed by python2-automat-0.6.0-1.mga6.noarch
        libalkimia5.so.7()(64bit) is needed by lib64kmm_csvimportercore5-5.0.1-1.mga6.x86_64
        libkmm_mymoney.so.5()(64bit) is needed by lib64kmm_csvimportercore5-5.0.1-1.mga6.x86_64
        konsole >= 1:17.12.2-1.mga6 is needed by konsole-doc-1:17.12.2-1.mga6.noarch
        libvlccore.so.9()(64bit) is needed by phonon4qt5-vlc-0.10.0-1.mga6.x86_64
        libkmm_payeeidentifier.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64
        libkmm_widgets.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64
        libpayeeidentifier_iban_bic.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64
        dragon >= 3:17.12.2-1.mga6 is needed by dragon-handbook-3:17.12.2-1.mga6.noarch
        kmail >= 2:17.12.2-1.mga6 is needed by kmail-handbook-2:17.12.2-1.mga6.noarch
        kruler >= 2:17.12.2-1.mga6 is needed by kruler-handbook-2:17.12.2-1.mga6.noarch
        libKChart.so.2()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libalkimia5.so.7()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libaqbanking.so.35()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_csvimportercore.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_icons.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_mymoney.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_payeeidentifier.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_plugin.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libkmm_widgets.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libpayeeidentifier_iban_bic.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        libpayeeidentifier_nationalAccount.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64
        kmime-common = 17.12.2-1.1.mga6 is needed by libkf5mime5-17.12.2-1.1.mga6.i586
        libvlccore.so.9()(64bit) is needed by vlc-plugin-pulse-3.0.2-0.1.mga6.tainted.x86_64
        akonadi-notes-common = 17.12.2-1.mga6 is needed by libkf5akonadinotes5-17.12.2-1.mga6.i586
        kcrash = 5.42.0-1.mga6 is needed by libkf5crash5-5.42.0-1.mga6.i586
        kitemmodels = 5.42.0-1.mga6 is needed by libkitemmodels5-5.42.0-1.mga6.i586
        kpimtextedit = 17.12.2-1.mga6 is needed by libkf5pimtextedit5-17.12.2-1.mga6.i586
        libKF5ContactEditor.so.5 is needed by libkf5akonadicontact5-17.12.2-1.mga6.i586


So, here I sit in dependency hell.

Any ideas as to how I can salvage this before having to reinstall the whole kit and kaboodle in about 8 hours?

Thanks much and happy Mothers Day.

Mark

Quick update. I tried updating from the mgaapplet updater utility and got this:

Code: Select all
9 installation transactions failed

There was a problem during the installation:

file /usr/share/locale/eu/LC_MESSAGES/kitemviews5_qt.qm from install of lib64kitemviews5-5.42.0-1.mga6.x86_64 conflicts with file from package libkitemviews5-5.32.0-1.mga6.i586

file /usr/share/locale/hy/LC_MESSAGES/kitemviews5_qt.qm from install of lib64kitemviews5-5.42.0-1.mga6.x86_64 conflicts with file from package libkitemviews5-5.32.0-1.mga6.i586

file /usr/share/locale/tt/LC_MESSAGES/kitemviews5_qt.qm from install of lib64kitemviews5-5.42.0-1.mga6.x86_64 conflicts with file from package libkitemviews5-5.32.0-1.mga6.i586

file /usr/share/locale/eu/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586

file /usr/share/locale/hy/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586

file /usr/share/locale/id/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586

file /usr/share/locale/tt/LC_MESSAGES/kcompletion5_qt.qm from install of lib64kf5completion5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5completion5-5.32.0-1.mga6.i586

file /usr/share/locale/en_GB/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/eu/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/fr/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/gl/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/hy/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/tt/LC_MESSAGES/kjobwidgets5_qt.qm from install of lib64kf5jobwidgets5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5jobwidgets5-5.32.0-1.mga6.i586

file /usr/share/locale/ca/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

file /usr/share/locale/ca@valencia/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

file /usr/share/locale/eu/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

file /usr/share/locale/gl/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

file /usr/share/locale/hy/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

file /usr/share/locale/tt/LC_MESSAGES/kcodecs5_qt.qm from install of kcodecs-5.42.0-1.1.mga6.x86_64 conflicts with file from package libkcodecs5-5.32.0-1.mga6.i586

libQtAV.so.1()(64bit) is needed by lib64digikamcore5-1:5.9.0-1.mga6.x86_64

libQtAVWidgets.so.1()(64bit) is needed by lib64digikamcore5-1:5.9.0-1.mga6.x86_64

file /usr/share/locale/ca/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/ca@valencia/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/cs/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/da/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/de/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/es/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/eu/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/fi/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/fr/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/gl/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/it/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/ko/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/nl/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/nn/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/pl/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/pt/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/pt_BR/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/ru/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sl/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sr/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sr@ijekavian/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sr@ijekavianlatin/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sr@latin/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/sv/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/tr/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/uk/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/zh_CN/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/zh_TW/LC_MESSAGES/kbookmarks5_qt.qm from install of lib64kf5bookmarks5-5.42.0-1.mga6.x86_64 conflicts with file from package libkf5bookmarks5-5.32.0-1.mga6.i586

file /usr/share/locale/eu/LC_MESSAGES/kdnssd5_qt.qm from install of lib64kf5kdnssd5-3:5.42.0-1.mga6.x86_64 conflicts with file from package libkf5kdnssd5-3:5.32.0-1.mga6.i586

file /usr/share/locale/hy/LC_MESSAGES/kdnssd5_qt.qm from install of lib64kf5kdnssd5-3:5.42.0-1.mga6.x86_64 conflicts with file from package libkf5kdnssd5-3:5.32.0-1.mga6.i586

file /usr/share/locale/tt/LC_MESSAGES/kdnssd5_qt.qm from install of lib64kf5kdnssd5-3:5.42.0-1.mga6.x86_64 conflicts with file from package libkf5kdnssd5-3:5.32.0-1.mga6.i586

libalkimia5.so.7()(64bit) is needed by lib64kmm_csvimportercore5-5.0.1-1.mga6.x86_64

libkmm_mymoney.so.5()(64bit) is needed by lib64kmm_csvimportercore5-5.0.1-1.mga6.x86_64

pythonegg(2)(attrs) is needed by python2-automat-0.6.0-1.mga6.noarch

libvlccore.so.9()(64bit) is needed by vlc-plugin-common-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-flac-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by lib64vlc5-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-speex-3.0.2-0.1.mga6.tainted.x86_64

libalkimia5.so.7()(64bit) is needed by lib64kmm_plugin5-5.0.1-1.mga6.x86_64

libkmm_mymoney.so.5()(64bit) is needed by lib64kmm_plugin5-5.0.1-1.mga6.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-vdpau-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-theora-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-lua-3.0.2-0.1.mga6.tainted.x86_64

libvlccore.so.9()(64bit) is needed by phonon-vlc-0.10.0-1.mga6.x86_64

libvlccore.so.9()(64bit) is needed by phonon4qt5-vlc-0.10.0-1.mga6.x86_64

libkmm_payeeidentifier.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64

libkmm_widgets.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64

libpayeeidentifier_iban_bic.so.5()(64bit) is needed by lib64payeeidentifier_iban_bic_widgets5-5.0.1-1.mga6.x86_64

libvlccore.so.9()(64bit) is needed by vlc-plugin-pulse-3.0.2-0.1.mga6.tainted.x86_64

kcodecs = 5.42.0-1.1.mga6 is needed by libkf5codecs5-5.42.0-1.1.mga6.i586

libKChart.so.2()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libalkimia5.so.7()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libgwengui-qt5.so.0()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_csvimportercore.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_icons.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_mymoney.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_payeeidentifier.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_plugin.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libkmm_widgets.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libpayeeidentifier_iban_bic.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libpayeeidentifier_iban_bic_widgets.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

libpayeeidentifier_nationalAccount.so.5()(64bit) is needed by kmymoney-5.0.1-1.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/kcompletion5_qt.qm from install of libkf5completion5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5completion5-5.32.0-1.mga6.x86_64

file /usr/share/locale/hy/LC_MESSAGES/kcompletion5_qt.qm from install of libkf5completion5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5completion5-5.32.0-1.mga6.x86_64

file /usr/share/locale/id/LC_MESSAGES/kcompletion5_qt.qm from install of libkf5completion5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5completion5-5.32.0-1.mga6.x86_64

file /usr/share/locale/tt/LC_MESSAGES/kcompletion5_qt.qm from install of libkf5completion5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5completion5-5.32.0-1.mga6.x86_64

file /usr/share/locale/en_GB/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/fr/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/gl/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/hy/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/tt/LC_MESSAGES/kjobwidgets5_qt.qm from install of libkf5jobwidgets5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5jobwidgets5-5.32.0-1.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/kitemviews5_qt.qm from install of libkitemviews5-5.42.0-1.mga6.i586 conflicts with file from package lib64kitemviews5-5.32.0-1.mga6.x86_64

file /usr/share/locale/hy/LC_MESSAGES/kitemviews5_qt.qm from install of libkitemviews5-5.42.0-1.mga6.i586 conflicts with file from package lib64kitemviews5-5.32.0-1.mga6.x86_64

file /usr/share/locale/tt/LC_MESSAGES/kitemviews5_qt.qm from install of libkitemviews5-5.42.0-1.mga6.i586 conflicts with file from package lib64kitemviews5-5.32.0-1.mga6.x86_64

file /usr/share/locale/ca/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/ca@valencia/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/cs/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/da/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/de/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/es/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/fi/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/fr/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/gl/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/it/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/ko/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/nl/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/nn/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/pl/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/pt/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/pt_BR/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/ru/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sl/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sr/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sr@ijekavian/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sr@ijekavianlatin/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sr@latin/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/sv/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/tr/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/uk/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/zh_CN/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/zh_TW/LC_MESSAGES/kbookmarks5_qt.qm from install of libkf5bookmarks5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5bookmarks5-5.32.0-1.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/kdnssd5_qt.qm from install of libkf5kdnssd5-3:5.42.0-1.mga6.i586 conflicts with file from package lib64kf5kdnssd5-3:5.32.0-1.mga6.x86_64

file /usr/share/locale/hy/LC_MESSAGES/kdnssd5_qt.qm from install of libkf5kdnssd5-3:5.42.0-1.mga6.i586 conflicts with file from package lib64kf5kdnssd5-3:5.32.0-1.mga6.x86_64

file /usr/share/locale/tt/LC_MESSAGES/kdnssd5_qt.qm from install of libkf5kdnssd5-3:5.42.0-1.mga6.i586 conflicts with file from package lib64kf5kdnssd5-3:5.32.0-1.mga6.x86_64

file /usr/share/locale/cs/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/eu/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/gl/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/he/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/id/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/ja/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/pl/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/sr/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/sr@ijekavian/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/sr@ijekavianlatin/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/sr@latin/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64

file /usr/share/locale/zh_CN/LC_MESSAGES/knotifyconfig5.mo from install of libkf5notifyconfig5-5.42.0-1.mga6.i586 conflicts with file from package lib64kf5notifyconfig5-5.32.0-2.mga6.x86_64


Still trying to salvage this.
Last edited by mark9117 on May 14th, '18, 02:08, edited 1 time in total.
Let's just reboot everything all the time.
User avatar
mark9117
 
Posts: 383
Joined: Sep 12th, '11, 20:32
Location: Eastern New Mexico -- Not Hell, but you can see it from here.

Re: Update seems to have broken KDE

Postby benmc » May 13th, '18, 22:25

kmoney seems to be causing quite a few conflicts so remove it

Code: Select all
urpme kmymoney


take a copy of the list of dependencies as well (copy/paste to kwrite or good old pen and paper)

then do your
Code: Select all
urpmi --auto-update
again.
shouldnt download any new packages as they should still be in temp.

if no new packages are installed, try
Code: Select all
urpmi kmymoney
and all those dependencies

likewise both of the above for vlc (for libvlccore) and also for libkf5bookmarks5-5... and any others.
it is likely only one package is causing the issue, but is resulting in a cascade effect.
just do one at a time to whittle down the numbers.

during an upgrade from Mga5-Mga6 I needed to remove 6 sets of packages until the system completed its upgraded, then re-installed those six sets of packages to complete the upgrade.

best of luck

tip: instead of typing "urpmi --auto-update", just tap the "up" or "down" arrow on your keyboard. it will auto-fill from your last entries
benmc
 
Posts: 657
Joined: Sep 2nd, '11, 12:45
Location: Pirongia, New Zealand

Re: Update seems to have broken KDE

Postby martinw » May 14th, '18, 00:01

Also there seems to be a problem with mixed 32-bit and 64-bit installations which hasn't been resolved yet:
https://bugs.mageia.org/show_bug.cgi?id=23016
The workaround is to remove any 32-bit libraries that show up as conflicts, e.g.
Code: Select all
urpme libkitemviews5-5.32.0-1.mga6.i586

If this causes a 32-bit application you need to also be removed, you should be able to reinstall it after the main update completes.

It is very important that you let the full update complete automatically rather than manually installing selected packages. The new Plasma+Qt packages are not backwards compatible with the old ones, so if you do a partial update, you can end up with a non-working system (see also the blog post on this subject). This lack of backward compatibility is why the update had to be rolled out in one huge lump, rather than in more manageable chunks.
martinw
 
Posts: 411
Joined: May 14th, '11, 10:59

Re: Update seems to have broken KDE

Postby mark9117 » May 14th, '18, 02:07

Thanks to you gentlemen, I have this desktop back together and functioning as expected. At least that's the case so far.

I had to uninstall a number of packages, lost track of how many, some of which looked really important to kde. Plenty of those things uninstalled were 32-bit code. After getting all the updates installed I reinstalled the important parts and logged out, then logged back in again. At this point, I'm marking this one "solved".

Thanks again.

Mark
Let's just reboot everything all the time.
User avatar
mark9117
 
Posts: 383
Joined: Sep 12th, '11, 20:32
Location: Eastern New Mexico -- Not Hell, but you can see it from here.


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest