Firefox is in Transition

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

Firefox is in Transition

Postby wilcal » Apr 19th, '18, 23:38

I don't have all the facts on this so please contribute if you have something. There appears to be quite an amount of stress over our present Firefox 52.x ESR. The are upcoming releases of Firefox both the regular editon and the ESR due soon. Part of the problem here involves an increasing number of website operators who either probibit or strongly insist that you be using the latest version of Firefox.

Example:

I am a long time customer of BankofAmerica.com. And for the last year or so every time I go to review my accounts there is a banner across the top of the page warning me that I am not using a certified Browser. This is the case for 52.x.x ESR. I have downloaded, and have transitioned to FF 59.x, the warning is not there.

If you review:

https://wiki.mozilla.org/Release_Management/Calendar

you'll notice that we are just a few weeks away from the release of FF 60 and ESR 52.8; 60.0.

I spent last week at the National Association of Broadcasters Show here in Las Vegas where I visited the Adobe booth and asked a technical person about the status of Flash. His answer was they offer a free "kit" and instructions on how to transition away from Flash to HTML5. He all but said they don't support Flash anymore. Officially Adobe has indicated they will support Flash through the Fall of 2020. I didn't get that feeling from this tech person.

There is at least one report that FF 60.0b13 crashes if Flash 29.0.0.140 is installed. This may be a one off incident, it may really be intentional on Mozillas part.

The Mageia team will continue to test and work to bring you the best version of FF we can. But, IMO, over the next weeks or so that may be a bit of a bumpy road.
"DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER"
is my friend
wilcal
 
Posts: 561
Joined: Jun 20th, '11, 02:01
Location: San Diego CA

Re: Firefox is in Transition

Postby jiml8 » Apr 20th, '18, 08:46

Some months ago I posted that I would be happy if Mageia held off on the update to firefox until the plugin situation worked itself out. At the time I was running the latest FF in a Mint virtual machine, and it was practically unusable.

Since then, the situation has changed dramatically, and the FF 59.01 that I have running in Mint is stable and all the plugins I need (all for security and privacy) work fine. Flash (29.0r0) also runs, for those sites that need it.

So it appears to me that the situation with FF has matured to the point that moving to release 59 or 60 should be fine.

I will note that my OpenSUSE Leap 42.3 VM is still on FF 52 ESR, so Mageia is certainly not alone in not having made the move yet.
jiml8
 
Posts: 974
Joined: Jul 7th, '13, 18:09

Re: Firefox is in Transition

Postby wilcal » Apr 20th, '18, 14:26

Thanks for the update jim
"DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER"
is my friend
wilcal
 
Posts: 561
Joined: Jun 20th, '11, 02:01
Location: San Diego CA

Re: Firefox is in Transition

Postby doktor5000 » Apr 20th, '18, 14:59

Well, usually for ESR release changes, there's a phase of more then a month as we're usually waiting for at least the next ESR .1 minor version.
So I'd say we won't see the next ESR version pushed to users boxes before july, and I don't see anything bumpy there ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14468
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Firefox is in Transition

Postby morgano » Apr 21st, '18, 10:59

The bump is that a few sites demand FF<=52, and a few other sites demand FF>52
So it seem some users need FF52 and also 59 or 60 installed at the same time (or other browser)
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T40 T42p T43 T60 T61 T400. Aspire 7. Fileserver. Workstation using LVM, LUKS, VirtualBox, BOINC, Dropbox, CAD, urpmi-proxy, NextCloud...
morgano
 
Posts: 538
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: Firefox is in Transition

Postby wilcal » Apr 21st, '18, 14:04

morgano wrote:The bump is that a few sites demand FF<=52, and a few other sites demand FF>52
So it seem some users need FF52 and also 59 or 60 installed at the same time (or other browser)


And that's what I'm doing here. Presently I'm using FF 59.0.2 and it works just fine on Mageia 6.0
Flash version 28.0.0, but every time the browser needs it it asks. It's not automatic like it had been.
"DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER"
is my friend
wilcal
 
Posts: 561
Joined: Jun 20th, '11, 02:01
Location: San Diego CA

Re: Firefox is in Transition

Postby doktor5000 » Apr 21st, '18, 15:17

morgano wrote:The bump is that a few sites demand FF<=52, and a few other sites demand FF>52
So it seem some users need FF52 and also 59 or 60 installed at the same time (or other browser)

Or simply use a different user agent, no need to use a different browser for that.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14468
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Firefox is in Transition

Postby Gelsenbury » May 13th, '18, 23:28

Firefox 59.0.1, downloaded directly from Mozilla, works just fine here under Mageia 6 and the current Plasma desktop. I'm very happy with this release, actually. But, of course, I don't visit all the sites that would need testing before you can be confident in including it in Mageia.
User avatar
Gelsenbury
 
Posts: 105
Joined: Jun 1st, '11, 21:00

Re: Firefox is in Transition

Postby wilcal » May 13th, '18, 23:43

Gelsenbury wrote:Firefox 59.0.1, downloaded directly from Mozilla, works just fine here under Mageia 6 and the current Plasma desktop. I'm very happy with this release, actually. But, of course, I don't visit all the sites that would need testing before you can be confident in including it in Mageia.

Note that shortly after your get Firefox going it should automatically update to Ver 60.0. That's what I have here.
"DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER"
is my friend
wilcal
 
Posts: 561
Joined: Jun 20th, '11, 02:01
Location: San Diego CA

Re: Firefox is in Transition

Postby zeebra » Sep 15th, '18, 23:45

doktor5000 wrote:
morgano wrote:The bump is that a few sites demand FF<=52, and a few other sites demand FF>52
So it seem some users need FF52 and also 59 or 60 installed at the same time (or other browser)

Or simply use a different user agent, no need to use a different browser for that.


Enlighten me please. How do you change the user agent in Firefox? I have tried to find out for awhile.

Could you give me some advise on that?
zeebra
 
Posts: 112
Joined: Sep 7th, '13, 21:20

Re: Firefox is in Transition

Postby doktor5000 » Sep 16th, '18, 04:14

zeebra wrote:Enlighten me please. How do you change the user agent in Firefox? I have tried to find out for awhile.

Check e.g. https://addons.mozilla.org/en-US/firefo ... -switcher/
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14468
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 0 guests