Solved: One user has no sound

Solved: One user has no sound

Postby hviaene » Dec 4th, '17, 11:15

I had to reinstall M6 due to replacing my videocard. Sound was perfectly OK out of the box.
I did a clean reinstall (formating /, keeping my separate /home partition) without any glitch. But now my user has no sound at all, not in Plasma, not in ICEWM. But for my wife's user on the same installation, all sound is OK.
i googled and found a workaround: stop as root all pulseaudio, then as my normal user, delete the folder ~/.config/pulse and start pulseaudio afresh. But this lasts just for the current session. When I boot again, I get into the same problem sitiuation. Is there some other config on my user that plays havoc???

TIA

Herman Viaene
Last edited by hviaene on Jan 12th, '18, 10:27, edited 1 time in total.
hviaene
 
Posts: 52
Joined: Oct 11th, '13, 10:41

Re: One user has no sound

Postby zeebra » Jan 10th, '18, 18:14

You have to delete som local settings files...

What is M6?

The settings files should be one of the folders /home/user/.folderXY. Most likely either .plasma or under .local or under .kde. Delete those related to pulseaudio
zeebra
 
Posts: 110
Joined: Sep 7th, '13, 21:20

Re: One user has no sound

Postby zeebra » Jan 10th, '18, 18:16

/home/user/.config/pulse
delete this folder.
zeebra
 
Posts: 110
Joined: Sep 7th, '13, 21:20

Re: One user has no sound

Postby hviaene » Jan 11th, '18, 10:06

zeebra wrote:/home/user/.config/pulse
delete this folder.

That is the one I found, see my first post. But also as stated above, on the next boot, the problem appears again. So there sitll most something else.
hviaene
 
Posts: 52
Joined: Oct 11th, '13, 10:41

Re: Solved: One user has no sound

Postby hviaene » Jan 12th, '18, 10:30

The trick that solved it finally was: delete the ~/.config/pulse and immediately reboot the system. After that the spound devices were recignized for this user, and all I had to do further was unmute the volume.
hviaene
 
Posts: 52
Joined: Oct 11th, '13, 10:41


Return to Sound

Who is online

Users browsing this forum: No registered users and 0 guests