[SOLVED] KDE Mixer Sound on 100% after Reboot

[SOLVED] KDE Mixer Sound on 100% after Reboot

Postby BlueDragon » Mar 6th, '17, 12:17

Hi all,

Litte problem making me nuts. Can be very unpleasant for the ears. Every time I reboot, my KDE Mixer Playback Device Volumes are all back to 100%. This does not happen upon log out and in again, only after a reboot.

I tried to toggle the 'Restore volumes on login' setting in the KMix Configure Panel under Start, but that did not change anything.

Anyone having some idea how to find a solution?

Thanks
Last edited by BlueDragon on Dec 23rd, '17, 03:05, edited 2 times in total.
BlueDragon
 
Posts: 47
Joined: Feb 22nd, '17, 20:47

Re: KDE Mixer Sound on 100% after Reboot

Postby wintpe » Jun 22nd, '17, 13:47

Its a while since i did this, so please use your initiative to locate the detail

use alsamixer a text mode program to setup the initial defaults, then save its config so that
on boot the settings are at a reasonable level.

im not sure its kde itself at fault.

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1168
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: KDE Mixer Sound on 100% after Reboot

Postby eco2geek » Jul 23rd, '17, 21:00

I haven't installed Mageia 6 KDE, but have spent a bunch of time running it from the live DVD. Which is to say, I don't know if this problem goes away after installation.

The problem is that, when KDE plays system sounds (such as the system bell), the volume level spikes to 100%, no matter what it was set at before.

One solution involves editing /etc/pulse/daemon.conf, and uncommenting the "flat-volumes = yes" value (i.e. remove the ";" in front of it) and changing "yes" to "no", so that the entry reads:

flat-volumes = no

Then log out and log back in. That seems to do the trick.
User avatar
eco2geek
 
Posts: 1
Joined: Jul 23rd, '17, 20:41

Re: KDE Mixer Sound on 100% after Reboot

Postby kernow » Jul 27th, '17, 18:36

Founde this on the Errata which may help:
Plasma 5 / KDE Applications
The volume of the sound changes suddenly to 100% during a Plasma session

This is because PulseAudio uses flat volumes by default, instead of relative volumes, relative to an absolute master volume (mga#19377). If this is found to be inconvenient, relative volumes can be enabled by disabling flat volumes in the PulseAudio daemon's configuration file:

edit etc/pulse/daemon.conf
change

;flat-volumes = yes

To

flat-volumes = no

then restart PulseAudio by executing

pulseaudio -k
pulseaudio --start
kernow
 
Posts: 45
Joined: Mar 21st, '13, 22:29

Re: KDE Mixer Sound on 100% after Reboot

Postby roadrunner » Jul 30th, '17, 09:53

eco2geek wrote:I haven't installed Mageia 6 KDE, but have spent a bunch of time running it from the live DVD. Which is to say, I don't know if this problem goes away after installation.

The problem is that, when KDE plays system sounds (such as the system bell), the volume level spikes to 100%, no matter what it was set at before.

One solution involves editing /etc/pulse/daemon.conf, and uncommenting the "flat-volumes = yes" value (i.e. remove the ";" in front of it) and changing "yes" to "no", so that the entry reads:

flat-volumes = no

Then log out and log back in. That seems to do the trick.

Yes, that definitely works.
- Mageia6 - 64-bit - Plasma 5.8.7 -
- AMD A6-6400K APU -
- 8Gb RAM - nVidia 8500GT GPU -
User avatar
roadrunner
 
Posts: 71
Joined: Jun 1st, '11, 16:00
Location: United Kingdom

Re: KDE Mixer Sound on 100% after Reboot

Postby wintpe » Aug 1st, '17, 12:54

isadora missed one, my my he must be slacking....

please set title to resolved please, if you are happy with the solution.

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1168
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK

Re: KDE Mixer Sound on 100% after Reboot

Postby isadora » Aug 1st, '17, 13:24

:)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2375
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: KDE Mixer Sound on 100% after Reboot

Postby BlueDragon » Dec 23rd, '17, 03:02

Thanks for the solution. Seems to work for me too! :D (I just had to log out and in again, stopping and starting again pulseaudio was giving me an error.)
Will mark it as solved.
BlueDragon
 
Posts: 47
Joined: Feb 22nd, '17, 20:47


Return to Sound

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest