MCC / drakconf didn't start

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

MCC / drakconf didn't start

Postby maxperl » Aug 2nd, '16, 10:00

Hello everybody,

On my system (Mageia 6 sta1) drakconf / MCC didn't start anymore.

The following error is outputed:

Ignore the following Glib::Object::Introspection & Gtk3 warnings
Can't locate object method "enable_exceptions" via package "Gtk3" at /usr/lib/libDrakX/mygtk3.pm line 36.
Compilation failed in require at /usr/libexec/drakconf line 40.
BEGIN failed--compilation aborted at /usr/libexec/drakconf line 40.


If I uncomment line 36 in mygtk3.pm, MCC starts again. But a really solution is this not...

I have installed a newer version of the Perl Gtk3 module (0.28). Perhaps this could be the reason of the error?
maxperl
 
Posts: 14
Joined: Jul 1st, '16, 09:19

Re: MCC / drakconf didn't start

Postby etienne1984 » Jun 12th, '18, 17:07

Hello,
I encountered exactly the same problem.
I commented the (and not uncomment as previous message says, supposed it was an error ?) line 36 in mygtk3.pm, then MCC starts again, but it is clearly not an acceptable solution.

I run with that version : Linux mga-pret-fixe 4.14.44-desktop-2.mga6 #1 SMP Mon May 28 22:35:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Maybe it could help : the problem appeared just after installing 32 bits X11 libraries (whereas I work on 64 bits system, and X11 was already present in 64 bits but I needed 32 also), and "/usr/lib" folder to the PATH and ld.so.conf, as 32 bits libraries where not detected by ldconfig until that. A few before it worked, and a few after no more...

If you need more precisions please ask, any help appreciated !
etienne1984
 
Posts: 1
Joined: Jun 12th, '18, 16:58

Re: MCC / drakconf didn't start

Postby doktor5000 » Jun 12th, '18, 23:38

When you can reproduce it then it should be reported as a bug.
But as you mentioned changig LD_LIB path or whatever you did exactly that might affect the problem. I've not seen any other report of that issue other then this thread, which was about a mga6 prerelease version.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14538
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest