How to change VGA for tty [Solved]

How to change VGA for tty [Solved]

Postby gregM » Mar 16th, '21, 04:55

How to change video mode settings in Ctrl->Alt->F(x) tty consoles. ?

With new Mageia8 have decided to tweak my video settings in both X11 and tty's to better suit my display (LCD Sanyo TV).
Supported mode for display 1360x768 was off to the left of screen by 15mm, both X11 & tty's
Fixed that by in X by using xrandr to add newmode line to the /etc/X11/xorg.conf with adjusted Hsync values (found using xvidtune)
X11/KDE screen is now correctly displayed, not off to the left.

Now I need to fix the TTY's to use the adjusted values or change to use 1024x768, as the TTY screens are still set to 1360x768 with Hsync values that display screen 15mm offscreen to the left, when I login to a tty...

In Mageia7 (32bit) when switching to the tty's (CtlAltF2), they were in 1360x768 mode offset to the left.
In Mageia8 the tty's first are in lower resolution 80chrx25line (640x480? offset to the left), and change to 1360x760 offset to left after login.

Have tried to set different Grub2 value, GRUB_GRFXPAYLOAD_LINUX=text changed to GRUB_GFXPAYLOAD_LINUX=1024x768x32
But that does not change the TTY settings after boot and using CtlAltF2 to call a tty.

So how can I get the TTY's to use the new Hsync values for VGA 1360x768 that work for X11/KDE ?
or
Change the TTY video mode to native 1024x768 that may not need adjustments to centre the display.

Suggestions welcome.

Settings that centre the display in X
Code: Select all
xrandr --newmode "1360x768_60_1"     84.72   1360 1396 1560 1800    768  769  772  795 -hsync +vsync
xrandr --addmode VGA1 "1360x768_60_1"
xrandr --output VGA1 --mode "1360x768_60_1"


I added the new Modeline to /etc/X11/xorg.conf, along with adjustments to the Monitor section...
Code: Select all
Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
#    ModelName "Flat Panel 1360x768"
    ModelName "SanyoLCDTv 1360x768"
    HorizSync 31.5-48.0
    VertRefresh 56.0-65.0
#    Option "PreferredMode" "1360x768"
    Option "PreferredMode" "1360x768_60_1"

    # Added new mode for Sanyo LCD TV
    Modeline "1360x768_60_1"   84.75  1360 1380 1560 1776  768 771 781 798 -hsync +hsync


Video card/driver :-
Card:Intel 810 and later: Intel Corporation|82G33/G31 Express Integrated Graphics Controller [DISPLAY_VGA] (vendor:8086 device:29c2 subv:1458 subd:d000) (rev: 10)
Last edited by gregM on Mar 18th, '21, 09:47, edited 1 time in total.
gregM
 
Posts: 30
Joined: Jan 16th, '18, 01:34

Re: How to change VGA for tty

Postby doktor5000 » Mar 16th, '21, 22:19

The tty's are not running under X, hence xrandr won't help you with that.

This is what I used, didn't have time to test this under mga8 yet but the tty's should inherit this as framebuffer resolution.

edit /etc/default/grub, change those two:
Code: Select all
GRUB_GFXMODE=1280x1024x24
GRUB_GFXPAYLOAD_LINUX=keep


Then as root run
Code: Select all
update-grub
and then reboot.

FWIW you can query available resolutions as root via
Code: Select all
hwinfo --framebuffer
although you may have to install hwinfo for that.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16797
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: How to change VGA for tty

Postby gregM » Mar 18th, '21, 09:45

Thanks for the feedback.
Understand Xrandr is for X windows, have not had much luck with the /etc/default/grub edits , tried to get screen set to a another supported mode but TTY still offscreen to the left. Not much of a problem as I mostly use terminals in X, just thought it would be nice to see the first few chars I type in TTY :)
Will mark as [Solved] as the info seems correct, just my LCD-TV is uncooperative!
gregM
 
Posts: 30
Joined: Jan 16th, '18, 01:34


Return to Video

Who is online

Users browsing this forum: No registered users and 0 guests