[SOLVED] URPMI and DNF broke after upgrade

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

Re: [SOLVED] URPMI and DNF broke after upgrade

Postby davidwhodgins » Mar 11th, '21, 00:24

danbuchanan wrote: But can i go from 6 to 8.

It can not be done using mgaapplet. In theory it may work using urpmi directly, but has not
been tested, and is highly likely to need a number of packages removed to avoid file conflicts.
If a file conflict is detected all packages that happen to be in the same rpm transaction fail
to install, not just the one that has the conflict. Depending on what packages do not get
upgraded, it may or may not lead to a non-usable system requiring using a chroot environment
to fix. Any broken installation can always be fixed if you know how. If you are not familiar
with using a chroot and systemd-nspawn environments I would not recommend trying it.
Both chroot and systemd-nspawn require a working boot (either another installation or a live
iso) to be available.

If using the urpmi commands directly, I'd add the new repositories then use
"urpmi --auto-select --test", to find and remove packages with conflicts before actually
upgrading. Note that requires enough disk space in /var to download all of the needed

My current main install started as a clean Mageia 3 install, upgraded each release since then,
one release at a time using mgaapplet.
Posts: 46
Joined: Nov 18th, '11, 05:14


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest