Mageia 8 and nordvpn

Mageia 8 and nordvpn

Postby lloyd » Mar 10th, '21, 23:09

Here's the story so far...I installed Mageia 8 RC. I had also installed NordVPN. Everything was working perfectly. I upgraded to Mageia 8 Final (I use Plasma) when it became available. So far, so good. Everything was working just fine. Over the last couple of days, it's been getting kind of flaky. I use Firefox and Chromium. It all worked fine. Now, we come to the problem. I start up NordVPN (exactly the same version I was using before) NordVPN starts up and says it's connected. All well and good. But now, Chromium and Firefox won't connect to any site at all. Chromium at least starts up...Firefox doesn't even do that. As soon as I disconnect the VPN, Firefox starts working immediately. So does Chromium. I thought it might be my router, but I'm pretty sure it isn't. I did the same test connected directly to my cablemodem. Exactly the same result.

For a test, I booted into Windows 10 and repeated the test. Edge, Firefox, and Chromium all connected with or without the VPN. So it must be Linux-related.
I am lost here. I have no idea what's going on, except that NordVPN and Firefox/Chromium aren't communicating with each other. I have no idea why. What is going on? Any help would be appreciated.

Thank you.
Posts: 97
Joined: Feb 4th, '14, 20:27

Re: Mageia 8 and nordvpn

Postby doktor5000 » Mar 10th, '21, 23:39

Some basic information would be helpful, like the output of
Code: Select all
/sbin/ip a
/sbin/ip r

and your /etc/resolv.conf once the VPN is active.

Did you also already check those browsers in safe mode, ruling out any browser plugins, and also private mode to rule out settings/cache/cookie issues ? Also, did you check your proxy settings in both browsers ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
Posts: 16798
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

[SOLVED] Re: Mageia 8 and nordvpn

Postby lloyd » Mar 11th, '21, 00:22

In my router configuration setting, I changed the DNS servers to NordVPN's nameservers and also in net-applet. Works like a charm now!
Posts: 97
Joined: Feb 4th, '14, 20:27

Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest