[SOLVED] Job for service network failed

[SOLVED] Job for service network failed

Postby albanosdes » Feb 19th, '15, 23:32

Hello there, I just made a virtual Mageia 4 with WMwareWorkstation, in the goal to install a captive portal (Alcasar), after a few days of troubles, everything works fine.

Every packages are updated, i've already installed Openssh, MySQL, Apache2, PhpMyAdmin, and everything works fine.
I can ping my physical machine, my gateway...

However, when i try to execute "service network restart", or "systemctl restart network.service" or "/etc/init.d/network restart", i get a beautiful "FAILED". Same for "service network reload".

(Rebooting do not solve the problem...)

I tried to search everywhere, but no way to find the solution.

There is what i get :

service network restart :
Code: Select all
Restarting network (via systemctl): Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.
[ÉCHEC ]


systemctl restart network.service :
Code: Select all
Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.


/etc/init.d/network restart :
Code: Select all
Restarting network (via systemctl): Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.
[ÉCHEC ]



When I execute "systemctl status network.service" :
Code: Select all
network.service - LSB: Bring up/down networking
Loaded: loaded (/etc/rc.d/init.d/network)
Active: failed (Result: exit-code) since jeu. 2015-02-19 11:19:39 CET; 1min 3s ago
Process: 5637 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)

févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost systemd-sysctl[5916]: Overwriting earlier assignment of kernel/sysrq in file '/etc/sysct...onf'.
févr. 19 11:19:39 localhost systemd[1]: network.service: control process exited, code=exited status=1
févr. 19 11:19:39 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
févr. 19 11:19:39 localhost systemd[1]: Unit network.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.



And "journalctl -xn" :
Code: Select all
-- Logs begin at lun. 2015-02-16 12:41:51 CET, end at jeu. 2015-02-19 11:19:39 CET. --
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost network[5637]: RTNETLINK answers: File exists
févr. 19 11:19:39 localhost systemd-sysctl[5916]: Overwriting earlier assignment of kernel/sysrq in file '/etc/sysctl.d/51-al
févr. 19 11:19:39 localhost systemd[1]: network.service: control process exited, code=exited status=1
févr. 19 11:19:39 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
-- Subject: Unit network.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit network.service has failed.
--
-- The result is failed.
févr. 19 11:19:39 localhost systemd[1]: Unit network.service entered failed state.




This is the content of my config files :

/etc/sysconfig/network-scripts/ifcfg-eno16777736 :
Code: Select all
DEVICE=eno16777736
BOOTPROTO=static
IPADDR=192.168.250.120
NETMASK=255.255.255.0
GATEWAY=192.168.250.2
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=yes
USERCTL=yes
DNS1=192.168.250.2
RESOLV_MODS=no
IPV6INIT=no
IPV6TO4INIT=no
ACCOUNTING=no
NM_CONTROLLED=no


/etc/sysconfig/network :
Code: Select all
NETWORKING=yes
CRDA_DOMAIN=FR
GATEWAY=192.168.250.2


/etc/resolv.conf :
Code: Select all
domain localdomain
nameserver 192.168.250.2
search localdomain


Thanks you for your attention.
Last edited by albanosdes on Feb 20th, '15, 13:28, edited 1 time in total.
albanosdes
 
Posts: 5
Joined: Feb 19th, '15, 21:13

Re: Job for service network failed

Postby jiml8 » Feb 20th, '15, 00:56

So, is your network working? You'll get "failed" often enough for spurious reasons.

What is the output of ifconfig? Of route? Can you ping anything?
jiml8
 
Posts: 994
Joined: Jul 7th, '13, 18:09

Re: Job for service network failed

Postby albanosdes » Feb 20th, '15, 10:22

My network is working fine, as I said.
And as I also said, i can ping everything, my virtual machine, my physical machine, my gateway, google, my virtual machine from my physical machine...

ifconfig :
Code: Select all
eno16777736 Link encap:Ethernet  HWaddr 00:0C:29:EE:B9:13 
          inet adr:192.168.250.120  Bcast:192.168.250.255  Masque:255.255.255.0
          adr inet6: fe80::20c:29ff:feee:b913/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:88 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:8633 (8.4 KiB)  TX bytes:8368 (8.1 KiB)

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:2640 (2.5 KiB)  TX bytes:2640 (2.5 KiB)


route :

Code: Select all
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
default         192.168.250.2   0.0.0.0         UG    10     0        0 eno16777736
link-local      *               255.255.0.0     U     10     0        0 eno16777736
192.168.250.0   *               255.255.255.0   U     10     0        0 eno16777
albanosdes
 
Posts: 5
Joined: Feb 19th, '15, 21:13

Re: Job for service network failed

Postby isadora » Feb 20th, '15, 11:02

Please, next time use code tags as explained in ftp://ftp5.gwdg.de/pub/linux/mandriva/m ... e_tags.ogv

Thanks ahead. ;)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2402
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: Job for service network failed

Postby albanosdes » Feb 20th, '15, 11:05

I will, thanks you :]
albanosdes
 
Posts: 5
Joined: Feb 19th, '15, 21:13

Re: Job for service network failed

Postby doktor5000 » Feb 20th, '15, 12:35

albanosdes wrote:However, when i try to execute "service network restart", or "systemctl restart network.service" or "/etc/init.d/network restart", i get a beautiful "FAILED". Same for "service network reload".

There is usually no problem, if your network is working fine. Cf. https://bugs.mageia.org/show_bug.cgi?id=11102

Although you can check where it thinks network failed via running as root
Code: Select all
journalctl -ab --no-pager -u network
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14573
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Job for service network failed

Postby doktor5000 » Feb 20th, '15, 12:36

doktor5000 wrote:
albanosdes wrote:However, when i try to execute "service network restart", or "systemctl restart network.service" or "/etc/init.d/network restart", i get a beautiful "FAILED". Same for "service network reload".

There is usually no problem, if your network is working fine. Cf. https://bugs.mageia.org/show_bug.cgi?id=11102

Although you can check where it thinks network failed via running as root
Code: Select all
journalctl -ab --no-pager -u network



As a golden rule of thumb: If there is no error visible for a given error message, simply ignore it.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14573
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Job for service network failed

Postby albanosdes » Feb 20th, '15, 12:42

I just tried journalctl -ab --no-pager -u network and he gave me this :

Code: Select all
-- Logs begin at lun. 2015-02-16 12:41:51 CET, end at ven. 2015-02-20 11:39:35 CET. --
févr. 20 10:11:47 localhost systemd[1]: Starting LSB: Bring up/down networking...
févr. 20 10:11:48 localhost systemd-sysctl[902]: Overwriting earlier assignment of kernel/sysrq in file '/etc/sysctl.d/51-alt-sysrq.conf'.
févr. 20 09:11:50 localhost network[816]: Démarrage de l'interface loopback :  [  OK  ]
févr. 20 09:12:09 localhost su[1116]: (to avahi) root on none
févr. 20 09:12:11 localhost network[816]: Activation de l'interface eno16777736 :  [  OK  ]
févr. 20 09:12:11 localhost network[816]: Activation de l'interface eth0 :  ERREUR   : [/etc/sysconfig/network-scripts/ifup-eth] Device  does not seem to be present, delaying initialization.
févr. 20 09:12:12 localhost network[816]: [ÉCHEC ]
févr. 20 09:12:12 localhost systemd-sysctl[1184]: Overwriting earlier assignment of kernel/sysrq in file '/etc/sysctl.d/51-alt-sysrq.conf'.
févr. 20 09:12:12 localhost systemd[1]: network.service: control process exited, code=exited status=1
févr. 20 09:12:12 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
févr. 20 09:12:12 localhost systemd[1]: Unit network.service entered failed state.
févr. 20 09:22:40 localhost systemd[1]: Starting LSB: Bring up/down networking...
févr. 20 09:22:47 localhost network[4353]: Démarrage de l'interface loopback :  [  OK  ]
févr. 20 09:22:48 localhost network[4353]: Activation de l'interface eno16777736 :  NETLINK: Error: File exists
févr. 20 09:22:53 localhost su[4572]: (to avahi) root on none
févr. 20 09:22:59 localhost network[4353]: Failed to create host name resolver: The requested operation is invalid because redundant
févr. 20 09:22:59 localhost systemd[1]: network.service: control process exited, code=exited status=1
févr. 20 09:22:59 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
févr. 20 09:22:59 localhost systemd[1]: Unit network.service entered failed state.
févr. 20 09:23:00 localhost network[4353]: run-parts: /etc/sysconfig/network-scripts/hostname.d/avahi exited with return code 1
févr. 20 09:23:00 localhost network[4353]: [  OK  ]
févr. 20 09:23:00 localhost network[4353]: Activation de l'interface eth0 :  ERREUR   : [/etc/sysconfig/network-scripts/ifup-eth] Device  does not seem to be present, delaying initialization.
févr. 20 09:23:00 localhost network[4353]: [ÉCHEC ]
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:23:00 localhost network[4353]: RTNETLINK answers: File exists
févr. 20 09:33:47 localhost systemd[1]: Stopped LSB: Bring up/down networking.
févr. 20 11:39:24 localhost systemd[1]: Starting LSB: Bring up/down networking...
févr. 20 11:39:32 localhost network[5099]: Démarrage de l'interface loopback :  [  OK  ]
févr. 20 11:39:32 localhost network[5099]: Activation de l'interface eno16777736 :  NETLINK: Error: File exists
févr. 20 11:39:32 localhost su[5314]: (to avahi) root on none
févr. 20 11:39:33 localhost network[5099]: Failed to create host name resolver: The requested operation is invalid because redundant
févr. 20 11:39:33 localhost network[5099]: run-parts: /etc/sysconfig/network-scripts/hostname.d/avahi exited with return code 1
févr. 20 11:39:33 localhost network[5099]: [  OK  ]
févr. 20 11:39:34 localhost network[5099]: Activation de l'interface eth0 :  ERREUR   : [/etc/sysconfig/network-scripts/ifup-eth] Device  does not seem to be present, delaying initialization.
févr. 20 11:39:34 localhost network[5099]: [ÉCHEC ]
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost network[5099]: RTNETLINK answers: File exists
févr. 20 11:39:34 localhost systemd[1]: network.service: control process exited, code=exited status=1
févr. 20 11:39:34 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
févr. 20 11:39:34 localhost systemd[1]: Unit network.service entered failed state.


As you see, there is errors.
albanosdes
 
Posts: 5
Joined: Feb 19th, '15, 21:13

Re: Job for service network failed

Postby albanosdes » Feb 20th, '15, 13:10

Ah ! I just resolved the problem by myself !
I deleted the ifcfg-eth0 script after i saw that he was making troubles in the "journalctl -ab --no-pager -u network", then i tried to restart the network.service, and then he said OK !

Thanks everyone for your attention : ]
albanosdes
 
Posts: 5
Joined: Feb 19th, '15, 21:13

Re: Job for service network failed

Postby doktor5000 » Feb 20th, '15, 13:14

Please mark the thread accordingly by editing the topic of the first post and prefix it by [SOLVED], thanks
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14573
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Job for service network failed

Postby nwa » Aug 5th, '16, 13:31

I had the same problem with my Mageia 5 and i had a ifcfg-eno1 (i don't know relly why, i don't have a real device called like this) i deleted it, and no problem ! Thanks
nwa
 
Posts: 1
Joined: Aug 5th, '16, 13:29


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest