[Invalid]mgaapplet icon no longer displays when updates avai

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

[Invalid]mgaapplet icon no longer displays when updates avai

Postby andre999 » Mar 2nd, '21, 21:53

When I clicked on the update icon in the system tray area, it didn't invoke the update.
It had worked successfully earlier the same day.
I checked, and more updates were available (for mga7).
Using a minor clic on the update icon, some other things didn't seem to work, so I clicked on the exit option (quitter in french).
This removed the icon, as expected.
I then logged off/on, the icon did not reappear.
I then rebooted, once logged on, the icon did not reappear.
I tried going directly into rpmdrake and selecting show all updates, selecting and updating a few but not all.
Still after trying loggoff/logon and reboot, the update icon in the system try is not displayed.
How to recover the update icon ?

Problem caused by updates-testing activated in rpmdrake.
Once deactivated, rpmdrake shows no updates available when mgaapplet is not displayed.
The initial problème (constantly displaying update icon) was a temporary glitch.
Last edited by andre999 on Mar 3rd, '21, 04:51, edited 1 time in total.
andre999
 
Posts: 17
Joined: Jun 7th, '11, 08:11

Re: mgaapplet icon no longer displays when updates available

Postby doktor5000 » Mar 3rd, '21, 00:39

Hi there, check if you have ~/.Mgaonline/mgaonline and move it away / rename it.

Also, what happens when you run mgaapplet manually from a terminal ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [Invalid]mgaapplet icon no longer displays when updates

Postby andre999 » Mar 3rd, '21, 05:21

Sorry doktor5000, didn't see your reply before modifying my post. (Added last paragraph +[invalid] in title.)
~/.Mgaonline/ was empty,
and running mgaapplet from terminal showed everything up to date.

I didn't suspect update-testing showing updates available in rpmdrake but not seen by mgaapplet.
An appropriate configuration, since packages in update-testing should not be installed automatically.
It is only when I saw new updates via mgaapplet that I thought of checking further.
andre999
 
Posts: 17
Joined: Jun 7th, '11, 08:11


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest

cron