Page 1 of 1

Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 26th, '20, 13:03
by artee
tl;dr version: weird video artefacts when using mplayer/vlc with GL driver, not with xv driver, but who accepts tearing in 2020...

Motherboard: Socket AM4 Gigabyte AB350N-Gaming-Wifi, latest BIOS w/ latest Agesa, 32GB RAM
CPU: AMD Ryzen APU 2400G
Silverstone thin case
Noctua low profile HSF combo
Full HD Monitor with HDMI to DVI converter or DP to DVI converter, 720p Sanyo PLV-Z4 HDMI to HDMI connection

OS: Mageia, quite updated, kernel 5.7.19-desktop-3.mga7

This system was used as a headless server for almost 3 years (my remote desktop in a vnc session, music playback desktop in another vnc session with mpd for local music plus internet radio, plus cantata plus optionally firefox with youtube, fileserver, backup to remote file server, ...), now it's additionally used for the home cinema.
It had been running with 250 days uptime, no problems. (When I just built it, it had max uptime of several hours. After the second BIOS update, it got uptimes of several days, running without any graphics; it was only after the third or fourth BIOS update where it would run stable, by then it was rock solid. I never used the graphics though.)
After moving it to the other corner, there were some issues to get it to talk to the projector, it wouldn't always get the EDID info, I swapped monitors/connections, ctrl-alt-Fn for cli, ctrl-alt-backspace to restart the X server, etc.
I learnt a lot more than I wanted to know about pulseaudio and systemd in the process, plus bluetooth sink to play from smartphones,...

Playing video, there is a slight tearing effect, which can only be clearly discerned in scenes with strong contrast plus movement.
I use mplayer, so I checked and found it used the xv driver for video.
On the system where the projector used to be connected, I found it had always been using the gl driver. No tearing, no artefacts, fault-free so to speak.

That one works fine for video playback without any tearing, but with time (minutes, not seconds, also not hours), it will develop hideous artefacts.
I went through the various drivers, xv, gl, gl nomanyglyphs/nomanyfmts, x11, xshm, vdpau (installed the extra driver for that one), except for the xv driver all have weird artefacts to a greater or lesser degree.

Artefacts: outside the video window, the text on the Konsole may be garbled, there's all kinds of messed up stuff on GUI parts of VLC, etc.

The xv driver is okay except for the tearing effects.
The gl driver has the least problematic artefacts, but is unusable all the same.
Please see these images:
"Slight" artefacts, horizontal stripes:
GL nomanyfmts artefacts
Screenshot_20201225_233441gl-nomanyfmts.png (694.9 KiB) Viewed 358 times

Huge artefacts and mess, upside down parts:
Huge mess upside down
Screenshot_20201225_232411.png (865.57 KiB) Viewed 358 times

Since I can grab the effects in screenshots, it's clear that it's not due to the cable connection.

Another thing: hplip had 2 cores (out of 8 logical cores) pegged at 100% for hours, and the cpu temp monitor was close to/around 100°C.
I found at the next boot that the fan had also stopped, no idea how long it had been dysfunctional...
(I never got the fan speed readout to work with lm-sensors, do get the temps...)
I deinstalled hplip, have no HP printers, don't know why that was installed...

So the questions are:
anything else I can try? Has anyone else experienced this type of issues?
I installed the extra VDPAU drivers, are there other drivers that may be worthwhile? Other settings?
Though I think it's safe to rule out the cable connection, could it be a buffer in the chipset?
If it's hardware related, I'm wondering if my APU is borked or if is the motherboard...

Re: Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 27th, '20, 02:25
by JoesCat
To test the motherboard and memory - I would suggest running a memtest program.
There seem to be a few of them to choose from - memtest86, memtest86+, memtest64, some have their pluses and minuses.

Re: Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 28th, '20, 13:03
by artee
Good hint, I'll run a memory test. I always run memtest for at least half a day when building a new system, looping through all the tests several times. This system completed 5 full runs in that time if memory serves...

However, in my experience, with faulty memory / problematic memory connections, the system tends to lock hard.

Re: Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 28th, '20, 18:07
by artee
I ran Memtest86, no issues detected.

Re: Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 29th, '20, 00:56
by JoesCat
In terms of concern about chipsets - see if you can run VESA, see what happens.
I think it pretty much means the CPU is going to be brute-forcing pixels.

If you have some "old" DVDs, see what happens.
Some movie studios encode harder than others.
However - as you mention above - it worked before with other drivers and players - the problem may come back to drivers and players.

With the new motherboard - you add a lot of new variables.
See if the 32bit version of Mageia has issues (codeset is smaller), and it also may show some "int32/int64" bugs that remain to be looked at too.

The HP printer drivers were likely bundled with Cups.

Re: Driver or hardware problem: AMD Ryzen 2400G APU system

PostPosted: Dec 31st, '20, 13:57
by artee
Vesa is not an option (mplayer -vo help doesn't list it).

Since I only change the driver between gl, x11 and xv, and not the decoder, I'm not sure how much it matters what source material I use and what the encoding is.

But, as they say, "the plot thickens"...

I received my new projector, FHD/pseudo 4k (Epson TW9400), and strangely the gl driver has way fewer intermittent problems (saw some artefacts after maybe 20 to 30 minutes of playback) on 4k 2160p resolution (on hdmi) compared to the old projector (Sanyo plv-z4) at 720p resolution (hdmi) or on the monitor (dvi from dp or hdmi port) (artefacts would show up every few minutes).
It even seems like 720p is worse than 1080p...
It's really mysterious.

Also, the motherboard is officially stated to support 4k@60Hz only on the DP port, just 4k@30Hz on the HDMI port, but I clearly get 4k@60Hz on the HDMI port. Yay Linux, I guess!