[SOLVED] How to install mga6 package on Mageia 7? (GIMP 2.8)

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

[SOLVED] How to install mga6 package on Mageia 7? (GIMP 2.8)

Postby MagicD3VIL » Feb 24th, '20, 09:19

Greetings,
I need to install Gimp 2.8.22 (few features frequently use were removed in 2.10) on Mageia 7 but it is only available as Mageia 6 package (gimp-2.8.22-1.mga6.x86_64.rpm). Is there any way how to install the older version?
Last edited by MagicD3VIL on Oct 2nd, '20, 17:44, edited 1 time in total.
User avatar
MagicD3VIL
 
Posts: 40
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby doktor5000 » Feb 24th, '20, 18:56

From mageia packages, not easily, no. You could temporarily add a set of mga6 repos, and check if urpmi would resolve all dependencies when doing
Code: Select all
urpmi --downgrade gimp



Sadly older gimp versions don't seem to be available as AppImage
And for flatpak you might need to tinker around.
Have a look at https://github.com/flatpak/flatpak/wiki ... owngrading or maybe https://github.com/flatpak/flatpak/issues/3097
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16225
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby benmc » Feb 24th, '20, 21:53

alternative would be to run Mga-6 in a virtual box just for this version of GIMP.

(space and hardware specs allowing)
benmc
 
Posts: 937
Joined: Sep 2nd, '11, 12:45
Location: Pirongia, New Zealand

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby jiml8 » Feb 25th, '20, 18:13

It might work to download the gimp package and install it, ignoring dependencies. You might have to symlink some libraries to satisfy exactly what gimp looks for.

I have done such things on many occasions. Usually (but now always) it works. You are also vulnerable to issues that crop up when you update the rest of your system.
jiml8
 
Posts: 1148
Joined: Jul 7th, '13, 18:09

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby martinw » Feb 25th, '20, 21:12

You could also try rebuilding the mga6 version for mga7. Follow the instructions at https://wiki.mageia.org/en/How_to_do_your_own_backports but download the mga6 SRPM, not the Cauldron one.
martinw
 
Posts: 608
Joined: May 14th, '11, 10:59

Gimp 2.8.22 on Mageia 7

Postby MagicD3VIL » Oct 2nd, '20, 15:02

To get back to this issue, I was not able to rebuild the package for mga7, due to unsatisfied gegl-3.0. Mageia 7 already has gegl-4 and there are some patch files in the GIMP 2.8 package meant to patch gegl-3.0 so I have no idea how that would have worked.

Also, I didn't found out how to install a package with urpmi ignoring dependencies, as jiml8 suggested.

If someone would be able to rebuild this package somehow I would be really grateful.
User avatar
MagicD3VIL
 
Posts: 40
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Gimp 2.8.22 on Mageia 7

Postby doktor5000 » Oct 2nd, '20, 16:23

MagicD3VIL wrote:Also, I didn't found out how to install a package with urpmi ignoring dependencies, as jiml8 suggested.

urpmi --allow-nodeps --allow-force
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16225
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Gimp 2.8.22 on Mageia 7

Postby MagicD3VIL » Oct 2nd, '20, 16:39

Thank you so much! I had to also download the older lib64gimp2.0_0-2.8.22-1.mga6.x86_64.rpm but after that, the Gimp 2.8.22 installs with no problems and is fully usable :)

EDIT: I don't know why but I couldn't find either --allow-nodeps or --allow-force on the Mageia URPMI wiki page... hmm
User avatar
MagicD3VIL
 
Posts: 40
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby doktor5000 » Oct 2nd, '20, 16:58

The urpmi wiki page is pretty old, and is more intended to show some use cases and show the other urpm* commands.
But both --allow-nodeps and --allow-force are shown in the actual --help output from urpmi and also in the man page.

man urpmi wrote: --allow-nodeps
With this option, urpmi will ask the user on error whether it should continue the installation without checking dependencies. By default, urpmi exits immediately in this case.

--allow-force
With this option, urpmi will ask the user on error whether it should proceed to a forced installation. By default, urpmi exits immediately in this case.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16225
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby isadora » Oct 2nd, '20, 17:41

Please MagicD3VIL, don't forget to mark the topic [SOLVED].
You can do so, by editing the subject/title in the first message in this topic.
Write [SOLVED] to the left of subject/title, thanks ahead. ;)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2621
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: Any way to install mga6 package on Mageia? (GIMP)

Postby MagicD3VIL » Oct 2nd, '20, 17:47

Yeah I actually forgot to do that :lol: Thanks for reminding me! I also edited the title a bit so people could find it better if someone would eventually have the same question ;)
User avatar
MagicD3VIL
 
Posts: 40
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest