[CLOSED] Codeblocks problems on Mageia 7

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

[CLOSED] Codeblocks problems on Mageia 7

Postby hardrock » Nov 19th, '19, 17:21

Hi all:
I am beginning to move all my C programs over to my Mageia 7.1 system. I have installed
Codeblocks and allegro5.2 and solved some of the problems. But this one I need help on:
/home/iurt/rpmbuild/BUILD/glibc-2.29/csu/../sysdeps/x86_64/start.s undefined reference to main

I have already installed the glibc library but still get this message on all my programs.
None will compile. Any programmers out there that can give me some help on this?
I am using the 64 bit application. Any idea how long the 32 bit will continue to be supported?
Thanks for your time. I believe I will have more problems after this one is solved.

This version of Linux is impossible to load software. Always something missing!
I have spent hours trying to compile a simple program with codeblocks.
I think it is a lost cause. I think this is a beautiful system but things just don't work!
Going back to Ubuntu!
Last edited by doktor5000 on Nov 19th, '19, 23:54, edited 1 time in total.
Reason: adjusted subject
Posts: 12
Joined: Nov 9th, '19, 17:06

Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest