PhpMyAdmin login page - Object Not Found

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

PhpMyAdmin login page - Object Not Found

Postby cyril » Apr 30th, '19, 19:37

I am posting this solution for anyone else who may have had a similar problem. I had problems loading the "Welcome to phpMyAdmin" login page.
I expected it to be displayed when I pointed my browser to
Code: Select all
 http://localhost/myphpadmin

That page should display when the config.inc.php file has auth-type = cookie

I was getting an error that said "Object not found" or "Access denied per /etc/httpd/conf/webapps.d/phpmyadmin.conf"

I had the same versions of Apache, MariaDB , php and PhpMyAdmin on another machine and it worked properly and I could not find any differences when I compared the config files for Apache, php and PhpMyAdmin
MariaDB worked from the command line.
Code: Select all
http://localhost
showed the default web page.
Code: Select all
http://localhost/phpinfo.php
showed the PHP info page

I compared installed packages on both machines and found that Mageia has many Apache modules in separate packages and one of them is apache-mod-usedir for user specific directories.
that was installed on the good machine and not on the one with problems displaying the login page.

When I installed that package login worked as expected right away, I did not even have to restart Apache.
cyril
 
Posts: 4
Joined: Feb 5th, '14, 19:35

Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest

cron