Nvidia disable MSI interrupts?

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

Nvidia disable MSI interrupts?

Postby ncarver » Feb 19th, '18, 00:31

I have a Dell Optilex system with Nvidia GeForce GTX745 card, running Mageia 5. Proprietary Nvidia driver has not started properly at boot, dropping me to CLI, but a quick startx has gotten GUI/desktop working, and since machine is only rarely rebooted, I have not spent time working on the issue.

Nvidia documents cause as a known issue: Driver fails to initialize when MSI interrupts are enabled. (Xorg.0.log contains: The NVIDIA kernel module does not appear to be receiving interrupts generated by the NVIDIA graphics device.)

Suggested fix is to disable MSI interrupts with following option for Nvidia kernel module:
Code: Select all
NVreg_EnableMSI=0


My question is then: what is the best way to set this option for the nvidia module? I would like to make any changes manually since I have had to SSH into machine a couple of times to deal with these nvidia/GUI hangs at boot, so need to be able to remotely undo whatever I try.

I see that there is a file /etc/modprobe.d/display-driver.conf linked to /etc/alternatives/display-driver.conf, which appears to load the nvidia module:
Code: Select all
install nvidia /sbin/modprobe nvidia-current $CMDLINE_OPTS


Not sure where CMDLINE_OPTS is coming from, and whether I should just add my option to this line?

Thanks for suggestions!
ncarver
 
Posts: 18
Joined: May 25th, '11, 18:23

Re: Nvidia disable MSI interrupts?

Postby wintpe » Feb 19th, '18, 17:38

i think its done in two files now

modprobe.d/ modules-load.d/

and when i disable msi for the bnx cards i add the following to the modprobe.d/disable_msi.conf

options bnx2 disable_msi=1

i think in modules-load.d/ you just have to add the module to load

regards peter
Redhat 6 Certified Engineer (RHCE)
Sometimes my posts will sound short, or snappy, however its realy not my intention to offend, so accept my apologies in advance.
wintpe
 
Posts: 1168
Joined: May 22nd, '11, 17:08
Location: Rayleigh,, Essex , UK


Return to Advanced support

Who is online

Users browsing this forum: Google [Bot] and 1 guest