How to solve upgrade issue? [Solved]

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

How to solve upgrade issue? [Solved]

Postby mns » Jan 10th, '22, 01:51

I recently upgraded an old computer from Mageia 5 to Mageia 8. Long overdue, I know.
When I started Gramps, my genealogical research program, it had been upgraded from version 4.1.3 to 5.1.3 and the underlying database had changed too,
so I was strongly suggested to backup the database using the old version before doing anything else.

I tried to run a live version of Mageia 5 but Gramps is not included by default and I didn't succeed to install it.
My question is therefore: Can I install the old Gramps version (4.1.3) on Mageia 8? If so, do I need to uninstall the new version first?
Or is there a better solution?

Thanks in advance and Best regards,
Michael Steen
Last edited by mns on Jan 12th, '22, 03:47, edited 1 time in total.
mns
 
Posts: 10
Joined: Nov 27th, '14, 04:46

Re: How to solve upgrade issue?

Postby JoesCat » Jan 10th, '22, 02:36

If the database has changed, your best course of direction is probably to backup your data, and restore it under the most recent version of gramps unless there's aspects of the old software that you miss in the new software. You also may run into some incompatibilities when trying to run older software on a newer OS if some libraries, GTK or other things have changed enough to cause possible problems.

You mentioned that you succeeded in running Mageia5 live distro.
This would probable give you good oportunity to back your data, and then let you restore it under a recent version of gramps.

When you run mageia5, you can go to the home website here:
https://sourceforge.net/projects/gramps/files/
What you'll notice is that they have moved their source code to github, so let's look there for 4.1.3 in "releases" here:
https://github.com/gramps-project/gramp ... ses?page=3
See if you have success loading 4.1.3 version from here. fetch your database, then back it up so that you can move-up to 5.1.3

Looking at tagpoint: https://github.com/gramps-project/gramps/tree/v4.1.3 file setup.py it appears it can run under python 2.7 or 3.0 or later. Mageia8 uses python3, so it might be possible, but if you look at the releases list, https://github.com/gramps-project/gramps/releases there are usually many bugfixes and improvements that would suggest an upgrade is likely the better direction to go.
User avatar
JoesCat
 
Posts: 159
Joined: Sep 15th, '11, 04:27
Location: Richmond, BC, Canada

Re: How to solve upgrade issue?

Postby papoteur » Jan 10th, '22, 10:31

Hello,
Within a Live session, you have the opportunity to install a program. The actual problem is that the mirrors doesn't have Mageia 5 anymore.
But you can still configure the archive mirror on distrib-coffee :
https://distrib-coffee.ipsl.jussieu.fr/ ... distrib/5/
Through MCC, you have to add a medium in configuring a custom mirror: https://doc.mageia.org/mcc/8/en/content ... edit-media
Use the above link adding /x86_64 or /i586 at end according to your arch.
papoteur
 
Posts: 69
Joined: Oct 27th, '11, 22:28

Re: How to solve upgrade issue?

Postby mns » Jan 10th, '22, 14:27

Thank you both for your replies.
I think I'll go with the live session approach as a first. It was my first try, now I just need to set it up properly. It's a one-off, so no need to risk messing up my Mageia 8 installation.

BR
mns
 
Posts: 10
Joined: Nov 27th, '14, 04:46

Re: How to solve upgrade issue?

Postby mns » Jan 11th, '22, 19:05

Hi,
I've tried to run a Mageia 5 Live Session but I haven't been able to install anything. When trying to install new media it keep saying: Failed. Couldn't find any media.cfg, even though I could see media.cfg beeing present using http or ftp.
What am I doing wrong?
mns
 
Posts: 10
Joined: Nov 27th, '14, 04:46

Re: How to solve upgrade issue?

Postby doktor5000 » Jan 12th, '22, 00:09

How did you actually try to install new media? You would need to do it as suggested, because the repositories are not present anymore on mirrors.

You can add a full set of repositories as root like this:
Code: Select all
urpmi.addmedia --distrib 'http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia-archive/distrib/5/$ARCH'
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16936
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: How to solve upgrade issue?

Postby mns » Jan 12th, '22, 03:46

Thank you doctor5000. That did it - almost.
I did use that server but I think, that I had been too specific. Your code did it and I got the old Gramps version installed.
To get it to work I had to make a link from the .gramps directory in my old home to the live session home and start Gramps as root, because my old uid is different from the live user's uid.
The output is now owned by root but that is easily fixed.

Thank you all for your help.

BR
mns
 
Posts: 10
Joined: Nov 27th, '14, 04:46


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest