WINE without sound

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

WINE without sound

Postby TheoSchmidt » May 23rd, '20, 11:09

Hi All,

I'm facing an odd situation after having installed Mageia's packages for wine:
WINE works as far as loading and playing games but all without sound. The weird thing is that winecfg plays the test sound OK (I can hear it thru my laptop's speakers), but when I launch any game the sound would not work. The screenshot attached shows winecfg having pulseaudio as the default for all devices.

Winecfg_Audio_Tab.png
Winecfg_Audio_Tab.png (53.26 KiB) Viewed 74 times


I've tried everything:
- Installed 64 and 32 wine libs from Mageia's repos using drakrpm
- Tried messing around with winecfg (got Word of Warcraft to launch and play ok but with no sound....of course :? )
- Tried messing around with Q4Wine. At this point I tried installing MediaPlayerClassic thru the apps installer tool in Q4Wine ending with a very weird message when executing the application. This issue got me to try installing DirectX 9.0c (more on this later)
- Tried using winetricks to install DirectX 9.0c, ending with a nasty error window.
- Tried manual installation of DirectX 9.0c as sugested in some forums....BTW, failing miserably again... (more on this below)

As mentioned above, after having installed MediaPlayerClassic thru Q4Wine, MPC starts ok but if you try playing an MP3 file I get the following message: "Failed to query the needed interfaces for playback". According to some forums this was due to some DirectX 9.0c libs missing. Therefore, installing DirectX was my next move. For that I tried two methods (manually and also thru Q4Wine) with exactly the same results: an error window saying there was an internal error (screenshot attached).

Error_Installing_DirectX_9.0c_.png
Error_Installing_DirectX_9.0c_.png (46.28 KiB) Viewed 74 times


Inspecting DirectX.log revealed the line "Current DirectX may be a older version which does not have the version value in the registry", that according to some forums was due to a missing key in the registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX]
"InstalledVersion"=hex:00,00,00,09,00,00,00,00
"Version"="4.09.00.0904"

But I verified my registry with regedit and the above values were "shining" right there thus not missing as some folks from a linux help forum had suggested (screenshot attached). At this point frustration had overtaken my spirit :(

Registry_ok_and_MPC_error.png
Registry_ok_and_MPC_error.png (71.25 KiB) Viewed 74 times


As a final test I tried launching dxdiag.exe but got a nasty error. I'll paste it at the end of this post.

Last, below are some details of my current distro, laptop, wine libs installed, error logs when installing DirectX 9.0c

ANY HELP will be GREATLY appreciated!

Thanx!
Theo

Distro:
Mageia 7.1 (x64)

Wine-related Mageia packages installed:
lib64kwineffects5
q4wine
wine-gecko
wine-mono
wine32
wine64
wine64-gecko

Error while trying dxdiag.exe:
003e:err:ole:CoGetClassObject class {a65b8071-3bfe-4213-9a5b-491da4461ca7} not registered
003e:err:ole:CoGetClassObject no class object {a65b8071-3bfe-4213-9a5b-491da4461ca7} could be created for context 0x1
003e:err:dxdiag:collect_dxdiag_information IDxDiagProvider instance creation failed with 0x80040154
003e:err:dxdiag:wWinMain DxDiag information collection failed

Below are the tails of DirectX.log and DXError.log:

[theo@localhost logs]$ tail -n 13 DirectX.log
Code: Select all
05/23/20 04:00:17: dxupdate: DirectXUpdateInstallPlugIn(): Installing dxdllreg_x86.cab...
05/23/20 04:00:17: dxupdate: DXCheckTrust(): C:\Temp\dxdllreg_x86.cab is trusted.
05/23/20 04:00:17: dxupdate: Extracted file C:\users\theo\Temp\DX8c30.tmp\dxdllreg_x86.inf from cab
05/23/20 04:00:17: dxupdate: GetDXVersion(): RegQueryValueEx() failed, error = 2.
05/23/20 04:00:17: dxupdate: GetDXVersion(): Current DirectX may be a older version which does not have the version value in the registry.
05/23/20 04:00:17: dxupdate: DirectXUpdateGetSetupInformation(): GetDXVersion() failed.
05/23/20 04:00:17: dsetup32: CSetup::InstallPlugIn(): DirectXUpdateInstallPlugIn() failed.
05/23/20 04:00:17: dsetup32: CSetup::SetupForDirectX(): InstallPlugIn() failed.
05/23/20 04:00:17: dsetup32: start finalizing: phase: 202 - 202, total: 0 - 0
05/23/20 04:00:17: DXSetup: DSetupCallback(): Phase = 3, Steps = 0
05/23/20 04:00:17: dsetup32: Installation ended with value -9 = Internal or unsupported error
05/23/20 04:02:09: DXSetup: WM_APP_ENDINSTALL
05/23/20 04:02:09: DXSetup: ~CDXWSetup()


[theo@localhost logs]$ tail -n 25 DXError.log

Code: Select all
--------------------
[05/23/20 04:00:17] module: dxupdate(Mar 30 2011), file: dxupdate.cpp, line: 192, function: GetDXVersion

    Failed API:         RegQueryValueEx()
    Error:              (2) - File not found.


    Current DirectX may be a older version which does not have the version value in the registry.

--------------------
[05/23/20 04:00:17] module: dxupdate(Mar 30 2011), file: dxupdate.cpp, line: 4764, function: DirectXUpdateGetSetupInformation

    GetDXVersion() failed.

--------------------
[05/23/20 04:00:17] module: dsetup32(Mar 30 2011), file: dxupdate.cpp, line: 280, function: CSetup::InstallPlugIn

    DirectXUpdateInstallPlugIn() failed.

--------------------
[05/23/20 04:00:17] module: dsetup32(Mar 30 2011), file: setup.cpp, line: 1727, function: CSetup::SetupForDirectX

    InstallPlugIn() failed.
Last edited by isadora on May 23rd, '20, 11:13, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
TheoSchmidt
 
Posts: 1
Joined: May 23rd, '20, 09:33

Re: WINE without sound

Postby doktor5000 » May 23rd, '20, 11:28

A regular wine install should not have the wine64 packages, those are for win64 only. Have a look at https://wiki.winehq.org/FAQ#Is_there_a_64_bit_Wine.3F

So you should have these installed:

wine wine32 wine-gecko wine-mono

Please remove the wine64 packages, then remove your ~/.wine prefix and then try again. Also, how did you install DirectX in particular? Usually that's done via winetricks, as that also takes care about necessary registry settings and wine DLL overrides.
Have a look at https://wiki.winehq.org/Winetricks
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15670
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest