[SOLVED] Upgrading to Mageia 7, ERROR transactions failed

This forum is dedicated to advanced help and support :

Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users.

[SOLVED] Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 22nd, '19, 13:04

Hello! I have problems upgrading from Mageia 6 to Mageia 7.1. I'm using classic install DVD and I didn't select any supplemental media, yet I'm still getting "47 installation transactions failed". Wiki does not cover what to do if the conflicting rpms are included on the DVD itself.
Last edited by MagicD3VIL on Sep 28th, '19, 12:19, edited 1 time in total.
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby benmc » Sep 22nd, '19, 22:19

does the system boot to a working system afterwards?
dirty / fingerprints on disk?

to remove the possibility of medium issues and reader issues, if you have the downloaded .iso on your HDD, you can boot to it and start your upgrade from there.
the .isos do have a modified net-install to start them, so if you interrupt the DVD disk installer boot-up when it is looking for USB devices (just eject the disk) you can point the installer to the .iso you have stored on your HDD. should be ok as you are not formatting / or /home.

next time you attempt the upgrade, have handy a small USB stick.
when the installation error occurs, insert the usb stick, wait a few seconds and then "Ctrl+Alt+ F2" should bring up a tty.
enter
Code: Select all
bug
and you will be asked where to write the file to /sdb, /sdc etc (your usb stick).

then file a bug report and attach the contents of the bug report.
you may need to compress it first with xz
file usually ends up with a name like: report.bug.xz

have a look here => https://wiki.mageia.org/en/How_to_report_a_bug_properly
benmc
 
Posts: 815
Joined: Sep 2nd, '11, 12:45
Location: Pirongia, New Zealand

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 22nd, '19, 22:37

Thanks for your reply.

After the DVD upgrade not working, I tried upgrading using the method on the wiki as "Upgrading online, using urpmi (CLI)". That worked to a certain point where the upgrade was finished but there were some conflicts with RPMs. After rebooting the system hanged while the last message was "Starting command Scheduler". After that, I tried upgrading via DVD again and that finally worked.

But that's not all... so far I am able to boot into the system normally and have Thunderbird loaded BUT I have a black desktop with an error message stating that "Plasma Cannot Start" due to "All shell packages missing".
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby doktor5000 » Sep 22nd, '19, 23:06

MagicD3VIL wrote:After the DVD upgrade not working, I tried upgrading using the method on the wiki as "Upgrading online, using urpmi (CLI)". That worked to a certain point where the upgrade was finished but there were some conflicts with RPMs.
Do you by any chance have of the list of those conflicts?

For the plasma issue, can you create a new user, login as that user - does the issue persist there as well ?

And please also show the output of the following commands, ran as root:

Code: Select all
urpmq --list-media active --list-url
urpmi --auto-update --auto --force --test
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15112
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 22nd, '19, 23:19

UPDATE: I've run "urpmi plasma-desktop" and it fixed the issue. So far everything is in working order (except search-bar in "start" menu) so I'm glad at least for that. I also realize that this was a very chaotic approach in terms of upgrading to rls 7 :D

About the conflict issues, I just remember that first entry was about something ending on "autosuspend.rules" and like 98% of rest were ".so" files listed as required by other applications. Sorry for not providing more accurate description but I didn't think this might be a bug.

EDIT: Requested output:
urpmq --list-media active --list-url:
Code: Select all
[magicd3vil@localhost ~]$ urpmq --list-media active --list-url
Core Release ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/core/release
Core Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/core/updates
Nonfree Release ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/nonfree/release
Nonfree Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/nonfree/updates
Tainted Release ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/tainted/release
Tainted Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/x86_64/media/tainted/updates
Core 32bit Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates
Nonfree 32bit Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/nonfree/updates
Tainted 32bit Updates ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/tainted/updates
[magicd3vil@localhost ~]$


urpmi --auto-update --auto --force --test:
Code: Select all
[magicd3vil@localhost ~]$ su
Password:
[root@localhost magicd3vil]# urpmi --auto-update --auto --force --test
medium "Core Release" is up-to-date
medium "Core Updates" is up-to-date
medium "Nonfree Release" is up-to-date
medium "Nonfree Updates" is up-to-date
medium "Tainted Release" is up-to-date
medium "Tainted Updates" is up-to-date
medium "Core 32bit Updates" is up-to-date
medium "Nonfree 32bit Updates" is up-to-date
medium "Tainted 32bit Updates" is up-to-date
A requested package cannot be installed:
libsystemd0-241-8.2.mga7.i586 (due to unsatisfied liblz4.so.1)


    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libexpat1-2.2.7-1.mga7.i586.rpm
    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libnspr4-4.22-1.mga7.i586.rpm
    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libnss3-3.46.0-1.mga7.i586.rpm
    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libgcrypt20-1.8.5-1.mga7.i586.rpm
    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libudev1-241-8.2.mga7.i586.rpm
    ftp://ftp.fi.muni.cz/pub/linux/mageia/distrib/7/i586/media/core/updates/libglapi0-19.1.5-2.mga7.i586.rpm
installing libnss3-3.46.0-1.mga7.i586.rpm libnspr4-4.22-1.mga7.i586.rpm libexpat1-2.2.7-1.mga7.i586.rpm libglapi0-19.1.5-2.mga7.i586.rpm libudev1-241-8.2.mga7.i586.rpm libgcrypt20-1.8.5-1.mga7.i586.rpm from /var/cache/urpmi/rpms
Preparing...                     ##############################################################
Installation is possible
While some packages may have been installed, there were failures.
A requested package cannot be installed:
libsystemd0-241-8.2.mga7.i586 (due to unsatisfied liblz4.so.1)
[root@localhost magicd3vil]#
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby doktor5000 » Sep 22nd, '19, 23:54

MagicD3VIL wrote:Sorry for not providing more accurate description but I didn't think this might be a bug.

Well, that might very well be the case but unless we know exactly what the conflicts are we cannot really fix those :|

For the remaining issues, you're bitten by a different bug. i586 repos are not enabled anymore by default which leads to several dependency issues if you had i586 packages installed,
and if you don't manually enable i586 repos before continuing with the update.

You should enable the following:

Core 32bit Release
Nonfree 32bit Release
Tainted 32bit Release

You can enable those via http://doc.mageia.org/mcc/7/en/content/ ... edit-media

Afterwards, you can finalise your update with urpmi --auto-update --auto --force
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15112
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 23rd, '19, 08:32

Good thing is, that I have exactly the same copy of the system that was on my notebook, on my desktop . So I'm pretty sure that there will be same problems if not more. I will try proceeding the same way this afternoon and I will post log of DVD upgrade and then URPMI upgrade here.

Edit: Only difference is that it's AMD/Radeon setup and not Intel/Nvidia.
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 23rd, '19, 19:17

Ok so these were the steps I took on my desktop. Part 1 takes inside of Mageia 6 and Part 2 inside of installation DVD.

So I did:
1. Updated everything using "urpmi --auto-update --force". After everything has updated I removed all old media using "urpmi.removemedia -a" (just in case).
2. Rebooted to install DVD. Selected "Upgrade Mageia (Official) 6". Selected no supplementary media. Kept ticked both Core and Nonfree installers. After long waiting time while the installer was just saying next to time "(estimating)" I finally got the same error screen as last time. I couldn't figure out how to copy everything into the terminal in ctrl+alt+F2 that I could save it into a file so I took few pictures of the screen with my phone (*facepalm*). Pictures can be seen via this link: https://imgur.com/a/zS9wSsX

I hope it helps!
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby doktor5000 » Sep 23rd, '19, 23:12

I'd say it's the exact same cause as described above. You had at least wine installed, which requires i586 repos, which the installer does not enable anymore by default - so this causes a long chain of dependency issues.
You'd probably be better off upgrading via urpmi directly, and making sure that i586 repos are enabled before you start the upgrade.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15112
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 23rd, '19, 23:29

Okay, I will try that tomorrow and will report if any other problems arise while upgrading via urpmi (following this guide: https://wiki.mageia.org/en/Mageia_7_Rel ... _.28CLI.29).
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby MagicD3VIL » Sep 24th, '19, 16:31

After I've ran "urpmi.removemedia -a", then I've ran "rpmi.addmedia --distrib --mirrorlist 'http://mirrors.mageia.org/api/mageia.7.$ARCH.list'" and after that I enabled Core 32bit Release, Nonfree 32bit Release and Tainted 32bit Release as you suggested + Update media. Yet I still got this error while running "urpmi --auto-update --auto --force":

Code: Select all
[root@localhost magicd3vil]# urpmi --auto-update --auto --force             
medium "Core Release" is up-to-date
medium "Core Updates" is up-to-date
medium "Nonfree Release" is up-to-date
medium "Nonfree Updates" is up-to-date
medium "Tainted Release" is up-to-date
medium "Tainted Updates" is up-to-date
medium "Core 32bit Release" is up-to-date
medium "Core 32bit Updates" is up-to-date
medium "Nonfree 32bit Release" is up-to-date
medium "Nonfree 32bit Updates" is up-to-date
medium "Tainted 32bit Release" is up-to-date
medium "Tainted 32bit Updates" is up-to-date
The following packages have to be removed for others to be upgraded:
gstreamer0.10-faad-0.10.23-35.1.mga6.tainted.x86_64
 (due to missing libgstbase-0.10.so.0()(64bit),
  due to missing libgstaudio-0.10.so.0()(64bit),
  due to missing libgstreamer-0.10.so.0()(64bit),
  due to unsatisfied gstreamer0.10-plugins >= 0.10.23)
gstreamer0.10-xvid-0.10.23-35.1.mga6.tainted.x86_64
 (due to missing libgstreamer-0.10.so.0()(64bit))
lib64net-snmp30-5.7.3-4.1.mga6.x86_64
 (due to missing libperl.so.5.22()(64bit))
lib64python3.5-3.5.7-1.mga6.x86_64
 (due to unsatisfied lib64python3.5-stdlib == 3.5.7-1.mga6)
lib64python3.5-stdlib-3.5.7-1.mga6.x86_64
 (due to unsatisfied python(abi) == 3.5,
  due to missing libpython3.5m.so.1.0()(64bit))
libgfortran3-5.5.0-1.mga6.x86_64
 (due to unsatisfied libquadmath0 == 5.5.0-1.mga6)
python-lcms-1.19-15.mga6.x86_64
 (due to missing liblcms.so.1()(64bit))

Code: Select all
installing lib64peas1.0_0-loader-python2-1.22.0-4.mga7.x86_64.rpm lib64xcrypt1-4.4.6-1.mga7.x86_64.rpm lib64solv1-0.7.4-1.mga7.x86_64.rpm python3-smbc-1.0.15.8-5.mga7.x86_64.rpm python3-3.7.3-1.mga7.x86_64.rpm python3-sip-4.19.16-1.mga7.x86_64.rpm libunixODBC2-2.3.7-2.mga7.i586.rpm javapackages-tools-5.3.0-6.mga7.noarch.rpm python3-rpm-4.14.2.1-12.mga7.x86_64.rpm lib64uuid1-2.33.2-1.mga7.x86_64.rpm python3-pkg-resources-41.0.0-1.mga7.noarch.rpm perl-Pango-1.227.0-9.mga7.x86_64.rpm lib64hunspell1.7_0-1.7.0-1.mga7.x86_64.rpm libreoffice-wiki-publisher-6.2.3.2-3.mga7.x86_64.rpm drakx-kbd-mouse-x11-1.29-1.mga7.x86_64.rpm lib64unbound8-1.9.1-1.1.mga7.x86_64.rpm perl-FFI-CheckLib-0.230.0-1.mga7.noarch.rpm lib64peas-gtk1.0_0-1.22.0-4.mga7.x86_64.rpm python3-dbus-1.2.8-3.mga7.x86_64.rpm lib64svn0-1.10.6-1.mga7.x86_64.rpm perl-Time-HiRes-1.976.0-1.mga7.x86_64.rpm python2-numpy-1.16.2-1.mga7.x86_64.rpm perl-Glib-1.329.0-1.mga7.x86_64.rpm python3-dateutil-2.8.0-1.mga7.noarch.rpm harddrake-ui-18.21-1.mga7.x86_64.rpm lib64secret-gir1-0.18.8-1.mga7.x86_64.rpm lib64blkid-devel-2.33.2-1.mga7.x86_64.rpm perl-XML-Parser-2.440.0-14.mga7.x86_64.rpm libreoffice-ure-6.2.3.2-3.mga7.x86_64.rpm perl-Net-DBus-1.1.0-10.mga7.x86_64.rpm locales-cs-2.29-3.mga7.x86_64.rpm python3-requests-2.21.0-2.mga7.noarch.rpm lib64assuan0-2.5.3-1.mga7.x86_64.rpm lib64wx_baseu3.0_0-3.0.4-7.mga7.x86_64.rpm libpeas-data-1.22.0-4.mga7.x86_64.rpm lib64gpgme11-1.13.0-1.mga7.x86_64.rpm vim-enhanced-8.1.1048-1.mga7.x86_64.rpm libreoffice-pyuno-6.2.3.2-3.mga7.x86_64.rpm libreoffice-help-en-6.2.3.2-3.mga7.x86_64.rpm lib64dnf2-0.33.0-1.mga7.x86_64.rpm net_monitor-0.25-1.mga7.x86_64.rpm lib64ilmimf2_3_24-2.3.0-2.mga7.x86_64.rpm perl-List-MoreUtils-0.428.0-4.mga7.noarch.rpm python3-distro-1.4.0-1.mga7.noarch.rpm lib64modulemd1-1.8.11-1.mga7.x86_64.rpm mageiawelcome-2.01-1.mga7.noarch.rpm python3-iniparse-0.4-18.mga7.noarch.rpm urpmi-8.118-1.mga7.noarch.rpm lib64hdf5_103-1.10.5-1.mga7.x86_64.rpm wxgtk-3.0.4-7.mga7.x86_64.rpm lib64xcrypt-devel-4.4.6-1.mga7.x86_64.rpm glibc-2.29-13.mga7.x86_64.rpm python3-gpg-1.13.0-1.mga7.x86_64.rpm lib64openssl1.1-1.1.0j-1.mga7.x86_64.rpm cairo-dock-dbus-3.4.1-12.mga7.x86_64.rpm python3-numpy-1.16.2-1.mga7.x86_64.rpm python2-pkg-resources-41.0.0-1.mga7.noarch.rpm python3-chardet-3.0.4-6.mga7.noarch.rpm bash-completion-2.8-2.mga7.noarch.rpm libgfortran5-8.3.1-0.20190802.1.mga7.x86_64.rpm perl-Cairo-GObject-1.4.0-18.mga7.x86_64.rpm lib64mount-devel-2.33.2-1.mga7.x86_64.rpm lensfun-0.3.2-8.mga7.x86_64.rpm lib64tcb0-1.1-9.mga7.x86_64.rpm libreoffice-gtk3-6.2.3.2-3.mga7.x86_64.rpm libsecret-tools-0.18.8-1.mga7.x86_64.rpm lib64gtk2-hc-engine-2.20.2-10.mga7.x86_64.rpm perl-base-5.28.2-1.mga7.x86_64.rpm qtbase5-common-devel-5.12.2-2.1.mga7.x86_64.rpm lib64assuan-devel-2.5.3-1.mga7.x86_64.rpm lib64qt5core5-5.12.2-2.1.mga7.x86_64.rpm perl-Alien-Libxml2-0.70.0-1.mga7.x86_64.rpm lib64gpg-error-devel-1.36-1.mga7.x86_64.rpm lib64boost_filesystem1.68.0-1.68.0-4.mga7.x86_64.rpm perl-USER-2.19-1.mga7.x86_64.rpm lib64magick-7Q16HDRI_6-7.0.8.44-1.mga7.tainted.x86_64.rpm gcc-cpp-8.3.1-0.20190802.1.mga7.x86_64.rpm perl-Term-ReadKey-2.380.0-1.mga7.x86_64.rpm libxcrypt1-4.4.6-1.mga7.i586.rpm lib64uuid-devel-2.33.2-1.mga7.x86_64.rpm libgpg-error-common-1.36-1.mga7.noarch.rpm libreoffice-langpack-en-6.2.3.2-3.mga7.x86_64.rpm lib64qt5eglfsdeviceintegration5-5.12.2-2.1.mga7.x86_64.rpm lib64glew2.1-2.1.0-4.mga7.x86_64.rpm subversion-1.10.6-1.mga7.x86_64.rpm perl-Glib-Object-Introspection-0.47.0-1.mga7.x86_64.rpm libreadline7-7.0-3.mga7.i586.rpm libsecret-i18n-0.18.8-1.mga7.noarch.rpm python3-rpm-generators-4.14.2-6.mga7.noarch.rpm perl-Crypt-SSLeay-0.720.0-15.mga7.x86_64.rpm lib64python3.7-stdlib-3.7.3-1.mga7.x86_64.rpm lib64wx_gtk2u_xrc3.0_0-3.0.4-7.mga7.x86_64.rpm perl-doc-5.28.2-1.mga7.noarch.rpm perl-Authen-PAM-0.160.0-22.mga7.x86_64.rpm gnome-themes-extra-3.28-4.mga7.x86_64.rpm perl-Math-Int64-0.540.0-10.mga7.x86_64.rpm lib64lua5.3-5.3.5-2.mga7.x86_64.rpm python3-unbound-1.9.1-1.1.mga7.x86_64.rpm lib64mpfr6-4.0.2-1.mga7.x86_64.rpm python3-libdnf-0.33.0-1.mga7.x86_64.rpm lib64smartcols1-2.33.2-1.mga7.x86_64.rpm libgdbm6-1.18.1-1.mga7.i586.rpm aria2-1.34.0-3.mga7.x86_64.rpm binutils-2.32-14.mga7.x86_64.rpm lib64boost_thread1.68.0-1.68.0-4.mga7.x86_64.rpm tkinter-2.7.16-2.mga7.x86_64.rpm perl-Filesys-Df-0.920.0-26.mga7.x86_64.rpm python3-lxml-4.3.0-1.mga7.x86_64.rpm meson-0.50.1-1.mga7.noarch.rpm perl-Path-Tiny-0.108.0-2.mga7.noarch.rpm lib64gpg-error0-1.36-1.mga7.x86_64.rpm ldetect-lst-0.6.4-1.mga7.x86_64.rpm lib64vigra11-1.11.1-10.mga7.x86_64.rpm python3-gobject3-3.32.1-1.mga7.x86_64.rpm lib64ilmbase24-2.3.0-1.mga7.x86_64.rpm lib64net-snmp35-5.8-2.mga7.x86_64.rpm lib64python2.7-stdlib-2.7.16-2.mga7.x86_64.rpm libpython2.7-2.7.16-2.mga7.i586.rpm lib64boost_locale1.68.0-1.68.0-4.mga7.x86_64.rpm drakxtools-18.21-1.mga7.x86_64.rpm lib64secret1_0-0.18.8-1.mga7.x86_64.rpm tslib-common-1.19-1.mga7.noarch.rpm lib64ts0-1.19-1.mga7.x86_64.rpm python2-setuptools-41.0.0-1.mga7.noarch.rpm dnf-4.2.6-1.mga7.noarch.rpm lib64readline7-7.0-3.mga7.x86_64.rpm lib64repo0-1.10.3-1.mga7.x86_64.rpm python3-pyqt5-sip-4.19.16-1.mga7.x86_64.rpm lib64hdf5_10-1.8.21-5.mga7.x86_64.rpm perl-DBI-1.642.0-1.mga7.x86_64.rpm python3-libcomps-0.1.11-1.mga7.x86_64.rpm python3-setuptools-41.0.0-1.mga7.noarch.rpm lib64ruby2.5-2.5.3-20.mga7.x86_64.rpm lib64glib2.0-devel-2.60.2-1.mga7.x86_64.rpm lib64peas1.0_0-loader-python3-1.22.0-4.mga7.x86_64.rpm uniconvertor-2.0-0.1.rc3_20171226.2.mga7.x86_64.rpm lib64python2.7-2.7.16-2.mga7.x86_64.rpm perl-SVN-1.10.6-1.mga7.x86_64.rpm lib64rpmsign8-4.14.2.1-12.mga7.x86_64.rpm lib64rpm8-4.14.2.1-12.mga7.x86_64.rpm libreoffice-emailmerge-6.2.3.2-3.mga7.x86_64.rpm python-2.7.16-2.mga7.x86_64.rpm debconf-1.5.71-1.mga7.noarch.rpm perl-File-chdir-0.101.100-2.mga7.noarch.rpm python3-curl-7.43.0.2-1.mga7.x86_64.rpm meta-task-7-1.1.mga7.noarch.rpm util-linux-2.33.2-1.mga7.x86_64.rpm libreoffice-impress-6.2.3.2-3.mga7.x86_64.rpm gtk2-hc-engine-2.20.2-10.mga7.x86_64.rpm system-config-printer-udev-1.5.11-2.mga7.x86_64.rpm lib64python3.7-3.7.3-1.mga7.x86_64.rpm python3-dnf-plugins-core-4.0.7-1.mga7.noarch.rpm lib64wx_gtk2u_adv3.0_0-3.0.4-7.mga7.x86_64.rpm perl-Capture-Tiny-0.480.0-2.mga7.noarch.rpm perl-HTML-Parser-3.720.0-7.mga7.x86_64.rpm perl-Curses-1.360.0-5.mga7.x86_64.rpm libreoffice-writer-6.2.3.2-3.mga7.x86_64.rpm lib64icu63-63.1-1.mga7.x86_64.rpm perl-Locale-gettext-1.70.0-8.mga7.x86_64.rpm libreoffice-opensymbol-fonts-6.2.3.2-3.mga7.noarch.rpm glibc-devel-2.29-13.mga7.x86_64.rpm python3-cairo-1.17.0-2.mga7.x86_64.rpm python3-qt5-core-5.12.1-2.mga7.x86_64.rpm perl-Alien-Build-1.670.0-1.mga7.noarch.rpm dnf-data-4.2.6-1.mga7.noarch.rpm lib64boost_system1.68.0-1.68.0-4.mga7.x86_64.rpm locales-2.29-3.mga7.x86_64.rpm python3-pip-19.0.3-1.mga7.noarch.rpm python2-rpm-4.14.2.1-12.mga7.x86_64.rpm rpm-plugin-systemd-inhibit-4.14.2.1-12.mga7.x86_64.rpm python3-dnf-4.2.6-1.mga7.noarch.rpm lib64db5.3-5.3.28-17.mga7.x86_64.rpm qtbase5-common-5.12.2-2.1.mga7.x86_64.rpm lib64mariadb3-10.3.17-1.mga7.x86_64.rpm lib64zck1-1.1.1-1.mga7.x86_64.rpm dnf-yum-4.2.6-1.mga7.noarch.rpm lib64utf8proc2-2.3.0-1.mga7.x86_64.rpm rpm-plugin-syslog-4.14.2.1-12.mga7.x86_64.rpm glib2.0-common-2.60.2-1.mga7.x86_64.rpm cairo-dock-plugins-3.4.1-12.mga7.x86_64.rpm perl-MDV-Distribconf-4.101.0-2.mga7.noarch.rpm python3-qt5-network-5.12.1-2.mga7.x86_64.rpm hugin-2019.0.0-2.mga7.x86_64.rpm lib64hdf5_hl100-1.10.5-1.mga7.x86_64.rpm system-config-printer-libs-1.5.11-2.mga7.noarch.rpm icu63-data-63.1-1.mga7.noarch.rpm libreoffice-calc-6.2.3.2-3.mga7.x86_64.rpm lib64rpmbuild8-4.14.2.1-12.mga7.x86_64.rpm cairo-dock-plugins-i18n-3.4.1-12.mga7.x86_64.rpm perl-Gtk2-1.249.920-4.mga7.x86_64.rpm libreoffice-xsltfilter-6.2.3.2-3.mga7.x86_64.rpm libpython2.7-stdlib-2.7.16-2.mga7.i586.rpm libdnf-lang-0.33.0-1.mga7.noarch.rpm zstd-1.4.0-1.mga7.x86_64.rpm libreoffice-data-6.2.3.2-3.mga7.noarch.rpm python3-qt5-qml-5.12.1-2.mga7.x86_64.rpm python3-cups-1.9.74-2.mga7.x86_64.rpm lib64gpgmepp6-1.13.0-1.mga7.x86_64.rpm python3-hawkey-0.33.0-1.mga7.x86_64.rpm gtk+2.0-2.24.32-5.mga7.x86_64.rpm task-obsolete-7-198.mga7.noarch.rpm libreoffice-pdfimport-6.2.3.2-3.mga7.x86_64.rpm python3-urllib3-1.24.3-1.mga7.noarch.rpm fonts-ttf-urw-1-1.git20170804.mga7.noarch.rpm gcc-8.3.1-0.20190802.1.mga7.x86_64.rpm perl-MIME-Base64-3.150.0-10.mga7.x86_64.rpm dnf-plugins-core-4.0.7-1.mga7.noarch.rpm drakxtools-curses-18.21-1.mga7.x86_64.rpm lib64qt5core-devel-5.12.2-2.1.mga7.x86_64.rpm adwaita-gtk2-theme-3.28-4.mga7.x86_64.rpm lib64lapack3-3.8.0-4.mga7.x86_64.rpm rpm-plugin-ima-4.14.2.1-12.mga7.x86_64.rpm lib64gtk+2.0_0-2.24.32-5.mga7.x86_64.rpm lib64wx_baseu_net3.0_0-3.0.4-7.mga7.x86_64.rpm rpm-4.14.2.1-12.mga7.x86_64.rpm lib64boost_date_time1.68.0-1.68.0-4.mga7.x86_64.rpm lib64blkid1-2.33.2-1.mga7.x86_64.rpm libopenssl1.1-1.1.0j-1.mga7.i586.rpm lib64hpip0-3.19.5-1.mga7.x86_64.rpm lib64gtk+-x11-2.0_0-2.24.32-5.mga7.x86_64.rpm perl-Cairo-1.106.0-11.mga7.x86_64.rpm python3-javapackages-5.3.0-6.mga7.noarch.rpm perl-URPM-5.21-1.mga7.x86_64.rpm libreoffice-base-6.2.3.2-3.mga7.x86_64.rpm lib64poppler85-0.74.0-3.2.mga7.x86_64.rpm python3-six-1.12.0-3.mga7.noarch.rpm lib64wx_gtk2u_qa3.0_0-3.0.4-7.mga7.x86_64.rpm libreoffice-core-6.2.3.2-3.mga7.x86_64.rpm perl-XML-LibXML-2.20.0-1.mga7.x86_64.rpm perl-5.28.2-1.mga7.x86_64.rpm lib64mount1-2.33.2-1.mga7.x86_64.rpm lib64wx_gtk2u_html3.0_0-3.0.4-7.mga7.x86_64.rpm perl-Digest-SHA1-2.130.0-25.mga7.x86_64.rpm javapackages-filesystem-5.3.0-6.mga7.noarch.rpm lib64comps0-0.1.11-1.mga7.x86_64.rpm lib64hdf5_hl10-1.8.21-5.mga7.x86_64.rpm lib64gio2.0_0-2.60.2-1.mga7.x86_64.rpm python3-opengl-3.1.3b2-1.mga7.x86_64.rpm libreoffice-graphicfilter-6.2.3.2-3.mga7.x86_64.rpm harddrake-18.21-1.mga7.x86_64.rpm locales-en-2.29-3.mga7.x86_64.rpm libreoffice-draw-6.2.3.2-3.mga7.x86_64.rpm perl-File-Sync-0.110.0-26.mga7.x86_64.rpm lib64blas3-3.8.0-4.mga7.x86_64.rpm lib64lm_sensors5-3.5.0-2.1.mga7.x86_64.rpm system-config-printer-1.5.11-2.mga7.x86_64.rpm python-pip-wheel-19.0.3-1.mga7.noarch.rpm lib64boost_chrono1.68.0-1.68.0-4.mga7.x86_64.rpm python3-librepo-1.10.3-1.mga7.x86_64.rpm perl-List-MoreUtils-XS-0.428-1.mga7.x86_64.rpm lib64glib2.0_0-2.60.2-1.mga7.x86_64.rpm lib64gpgme-devel-1.13.0-1.mga7.x86_64.rpm lib64peas1.0_0-1.22.0-4.mga7.x86_64.rpm libquadmath0-8.3.1-0.20190802.1.mga7.x86_64.rpm perl-File-FnMatch-0.20.0-26.mga7.x86_64.rpm python3-qt5-gui-5.12.1-2.mga7.x86_64.rpm gcc-c++-8.3.1-0.20190802.1.mga7.x86_64.rpm glib-gettextize-2.60.2-1.mga7.x86_64.rpm libreoffice-ure-common-6.2.3.2-3.mga7.noarch.rpm libstdc++-devel-8.3.1-0.20190802.1.mga7.x86_64.rpm libdrakx-kbd-mouse-x11-1.29-1.mga7.x86_64.rpm lib64wx_gtk2u_core3.0_0-3.0.4-7.mga7.x86_64.rpm python-setuptools-wheel-41.0.0-1.mga7.noarch.rpm rpm-build-4.14.2.1-12.mga7.x86_64.rpm libstdc++6-8.3.1-0.20190802.1.mga7.x86_64.rpm libreoffice-math-6.2.3.2-3.mga7.x86_64.rpm lib64exiv2_27-0.27.1-3.mga7.x86_64.rpm crypto-policies-20170606-2.mga7.noarch.rpm python3-qt5-quick-5.12.1-2.mga7.x86_64.rpm lib64wx_baseu_xml3.0_0-3.0.4-7.mga7.x86_64.rpm perl-Net-SSLeay-1.850.0-3.mga7.x86_64.rpm libreoffice-x11-6.2.3.2-3.mga7.x86_64.rpm lib64json-c4-0.13.1-2.mga7.x86_64.rpm vim-common-8.1.1048-1.mga7.x86_64.rpm lib64qt5gui5-5.12.2-2.1.mga7.x86_64.rpm python2-pip-19.0.3-1.mga7.noarch.rpm lib64fdisk1-2.33.2-1.mga7.x86_64.rpm lib64wx_gtk2u_aui3.0_0-3.0.4-7.mga7.x86_64.rpm lib64qgpgme7-1.13.0-1.mga7.x86_64.rpm perl-File-Which-1.230.0-1.mga7.noarch.rpm drakxtools-backend-18.21-1.mga7.x86_64.rpm python3-idna-2.7-2.mga7.noarch.rpm lib64gdbm6-1.18.1-1.mga7.x86_64.rpm from /var/cache/urpmi/rpms
Preparing...   

Code: Select all
Installation failed:    file /usr/include/uuid/uuid.h from install of lib64uuid-devel-2.33.2-1.mga7.x86_64 conflicts with file from package libuuid-devel-2.28.2-2.1.mga6.i586
        file /usr/include/blkid/blkid.h from install of lib64blkid-devel-2.33.2-1.mga7.x86_64 conflicts with file from package libblkid-devel-2.28.2-2.1.mga6.i586
        file /etc/X11/xinit.d/qt5-check-opengl2.sh from install of lib64qt5gui5-5.12.2-2.1.mga7.x86_64 conflicts with file from package libqt5gui5-5.9.4-1.2.mga6.i586


I think that on notebook I've also added --replacepkgs and that it helped but no idea if I was supposed to do that
User avatar
MagicD3VIL
 
Posts: 21
Joined: Jun 2nd, '19, 00:25
Location: Ostrava, Czech Republic

Re: Upgrading to Mageia 7, ERROR transactions failed

Postby doktor5000 » Sep 26th, '19, 00:09

Well, the first one is normal, as some packages will be removed during the upgrade.

In the last one, that is also normal - you installed both the i586 and the x86_64 versions of libuuid-devel. That doesn't really make any sense, you only need one or the other.
As both contain the same files (usually all -devel packages contain headers located below /usr/include ) those conflict with each other.
You need to remove one or the other package, there's nothing that can be done about that - you probably want to remove libuuid-devel-2.28.2-2.1.mga6.i586 and libblkid-devel-2.28.2-2.1.mga6.i586

Code: Select all
file /etc/X11/xinit.d/qt5-check-opengl2.sh from install of lib64qt5gui5-5.12.2-2.1.mga7.x86_64 conflicts with file from package libqt5gui5-5.9.4-1.2.mga6.i586

This one is a corner case, as usually the point for multilib library packages themselves is that you can install the i586 and x86_64 versions alongside each other, but here they contain a helper script.
Which should probably not be in the library package in the first place. This has already been reported as https://bugs.mageia.org/show_bug.cgi?id=25418
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15112
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Advanced support

Who is online

Users browsing this forum: No registered users and 1 guest