[SOLVED] dolphin instead of gwenview as default file manager

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] dolphin instead of gwenview as default file manager

Postby andersond » May 2nd, '12, 02:22

hello

when I click some folder icon on the desktop (using gnome),like for example, "home folder" or 'downloads", mageia opens it using GwenView.

but i dont like GwenView. I prefer Dolphin. How to chage this?

thanks in advance!

anderson
Last edited by doktor5000 on Jun 19th, '12, 21:43, edited 1 time in total.
Reason: adjusted thread title
andersond
 
Posts: 7
Joined: Mar 28th, '12, 04:25
Location: São Paulo - Brasil

Re: how to set DOLPHIN instead GWENVIEW as standard explorer

Postby doktor5000 » May 2nd, '12, 21:10

In systemsettings -> file associations -> check the order which is set for inode/directory, what does it say?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15683
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: how to set DOLPHIN instead GWENVIEW as standard explorer

Postby mailedfist » May 8th, '12, 15:10

I think this was inadvertently changed in a recent update, as I have had the same behaviour appear in the last couple of weeks. It is particularly annoying with respect to Firefox downloads "Open containing folder".

The order in file associations has Dolphin first, but /usr/share/applications/mimeinfo.cache says:

Code: Select all
inode/directory=kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;kde4-filelight.desktop;kde4-dolphin.desktop;


Changing the order of this works temporarily, but it reverts on the next reboot.
Mandrake->Mandriva->Mageia starting in 2003. I really dislike another well-known distro starting with U.
mailedfist
 
Posts: 91
Joined: Sep 11th, '11, 21:28

Re: how to set DOLPHIN instead GWENVIEW as standard explorer

Postby andersond » May 11th, '12, 16:52

well I did not find such option

I am on gnome,not kde.. I entered system tools -> system settings --> (under system tab)details

Inside, there is 4 tabs:
- general view, which says gnome v3.4.1
- standard applications, with options for Web,Mail, Calendar, Music, Vídeo and Fotos,but nothing for folder links, and none with the dolphin option
- removable mediawith optionslike audio cd, DVD, etc.
- graphics
andersond
 
Posts: 7
Joined: Mar 28th, '12, 04:25
Location: São Paulo - Brasil

Re: how to set DOLPHIN instead GWENVIEW as standard explorer

Postby doktor5000 » May 14th, '12, 19:39

mailedfist wrote:The order in file associations has Dolphin first, but /usr/share/applications/mimeinfo.cache says:

Code: Select all
inode/directory=kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;kde4-filelight.desktop;kde4-dolphin.desktop;


Changing the order of this works temporarily, but it reverts on the next reboot.


Sure, as you only modify a cache file, which gets recreated.

This may be influenced due to gwenview's desktop file /usr/share/applications/kde4/gwenview.desktop carrying an InitialPreference key.
For more information what this does, maybe have a look at this thread starting at viewtopic.php?p=3525#p3525

Sorry, but currently i can't help you further, i simply miss the spare time to do so :(
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15683
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: how to set DOLPHIN instead GWENVIEW as standard explorer

Postby laurentb » Jun 16th, '12, 10:18

I found a workaround (?) found here http://ubuntu.5.n6.nabble.com/Firefox-utilise-par-defaut-Nautilus-sous-Kubuntu-td4976023.html for this problem:
I added these lines:
Code: Select all
[Added Associations]
x-directory/normal=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;
inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-gwenview.desktop;kde4-filelight.desktop;kde4-cervisia.desktop;

[Default Applications]
inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-gwenview.desktop;kde4-filelight.desktop;kde4-cervisia.desktop;
x-directory/normal=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;

in the file /home/$USER/.local/share/applications/mimeapps.list

Works fine for me.
laurentb
 
Posts: 4
Joined: Sep 11th, '11, 16:09

Re: [SOLVED] dolphin instead of gwenview as default file man

Postby doktor5000 » Jul 4th, '12, 18:50

For the record, this also happened to me, when i tried to open a folder from within Transmission. Gwenview opened up :/
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15683
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] dolphin instead of gwenview as default file man

Postby fereydouni » Jun 19th, '14, 13:05

A simpler workaround would be to just remove "Gwenview" from application preference order of "File Associations -> inode -> directory"
User avatar
fereydouni
 
Posts: 2
Joined: Jun 19th, '14, 12:58


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest