[Solved] kicad: Could not use OpenGL on Mageia 8

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[Solved] kicad: Could not use OpenGL on Mageia 8

Postby DiBosco » May 23rd, '21, 17:34

When running kicad on Mageia 8 I am having the problem that is says on boot:

Could not use OpenGL, falling back to software rendering

And it is laggy. If you tried to switch to modern toolset (accelerated) it won''t let you.

Anyone know why this would be please? Never had this problem before.

Am using nvidia driver. xord.conf is as follows:

Code: Select all
cat xorg.conf
# File generated by XFdrake (rev 262502)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "v4l" # Video for Linux
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
   
    # Apple iMac modes
    ModeLine "1024x768"   78.525 1024 1049 1145 1312   768  769  772  800 +hsync +vsync
    ModeLine "800x600"    62.357  800  821  901 1040   600  601  604  632 +hsync +vsync
    ModeLine "640x480"    49.886  640  661  725  832   480  481  484  514 +hsync +vsync
   
    # Apple monitors tend to do 832x624
    ModeLine "832x624"    57      832  876  940 1152   624  625  628  667 -hsync -vsync
   
    # Apple PowerBook G3
    ModeLine "800x600"    100     800  816  824  840   600  616  624  640 -hsync -vsync
   
    # Apple TI Powerbook
    ModeLine "1152x768"   78.741 1152 1173 1269 1440   768  769  772  800 +vsync +vsync
   
    # Pismo Firewire G3
    ModeLine "1024x768"   65     1024 1032 1176 1344   768  771  777  806 -hsync -vsync
   
    # iBook2
    ModeLine "1024x768"   65     1024 1048 1184 1344   768  771  777  806 -hsync -vsync
   
    # 17" Apple Studio Display
    ModeLine "1024x768"   112.62 1024 1076 1248 1420 768 768 780 808 +hsync +vsync
   
    # HiRes Apple Studio Display
    ModeLine "1280x1024"  135    1280 1288 1392 1664  1024 1027 1030 1064
   
    # Another variation
    ModeLine "1280x1024"  134.989 1280 1317 1429 1688  1024 1025 1028 1066 +hsync +vsync
   
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "NVIDIA Corporation"
    BoardName "NVIDIA GeForce 635 series and later"
    Driver "nvidia"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection


Thanks.
Last edited by DiBosco on May 24th, '21, 08:37, edited 1 time in total.
DiBosco
 
Posts: 307
Joined: Aug 31st, '11, 10:22

Re: kicad: Could not use OpenGL on Mageia 8

Postby doktor5000 » May 23rd, '21, 21:47

xorg.conf does not matter that much, question is which driver got loaded ?

Code: Select all
lspcidrake -v|grep VGA
cat /var/log/Xorg.0.log
glxinfo
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: kicad: Could not use OpenGL on Mageia 8

Postby morgano » May 24th, '21, 00:02

Known problem, see Errata.
Try KiCAD in testing, or use Flatpak
https://bugs.mageia.org/show_bug.cgi?id=28352
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 794
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: kicad: Could not use OpenGL on Mageia 8

Postby DiBosco » May 24th, '21, 08:37

morgano wrote:Known problem, see Errata.
Try KiCAD in testing, or use Flatpak
https://bugs.mageia.org/show_bug.cgi?id=28352


OK, many thanks. The Flatpak install looks interesting. Mageia is always ages behind the latest kicad release and I had to build from source to try v5 before it was finally in our repositories. Means it might be easy to try v6 when it lands (which is hopefully soon!).

I did Google this problem and found no hits.
DiBosco
 
Posts: 307
Joined: Aug 31st, '11, 10:22

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby morgano » May 24th, '21, 08:50

One way to keep it more updated and problem free in Mageia is to help QA note to packager when new is available, and then test it ;)
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 794
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby DiBosco » May 24th, '21, 08:58

OK :)

Do you mean test it with Flatpak or compile it? Or something else?

It wasn't massively difficult to compile it when I did so for V5 and I did think at the time, as I have many times, that it would be great to contribute and be the package manager for kicad (I have a vested interest as I use it a lot). If I could get some lessons on how to create RPMs and have someone hand hold me through the process the first time I would be more than happy to do so. I think people are too busy to train up new people though!
DiBosco
 
Posts: 307
Joined: Aug 31st, '11, 10:22

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby morgano » May 24th, '21, 20:20

For current status:

1) Enable testing repo and install packages listed in https://bugs.mageia.org/show_bug.cgi?id=28352#c31; and see it it works for you. Some have already responded it works well, but another one chiming it can be good too, at least we know we are more users using it :) Also, the more users that runs the wxgtk update the better;

2) This update is unusually heavy as it includes wxgtk update that a lot of packages depend on, and it would be great if you could test and report on some of the packages listed in https://bugs.mageia.org/show_bug.cgi?id=28352#c30 .
I asked packager about packaging next version (5.1.10), but still the wxgtk stuff need be tested, and having tested that OK ASAP is good style as we ask next step... ;)

3) Whenever that next version is packaged, test it, use it :)


In future, when V6 is out and you find no update nor bug request asking for update, issue that request.

And YES !! If you have the steam you are more than welcome to package KiCAD for Mageia.
We have training procedures, and now when the dust of releasing Mageia 8 have settled, i think is a great point in time.
See https://wiki.mageia.org/en/Packaging#Jo ... aging_team
Join dev mailing list and say there you would like to learn to package KiCAD for MAgeia :)
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 794
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby DiBosco » May 24th, '21, 20:36

OK, I have one question though. How do you enable the testing repo?!
DiBosco
 
Posts: 307
Joined: Aug 31st, '11, 10:22

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby doktor5000 » May 24th, '21, 21:57

Same as any other repository. Have a look at https://doc.mageia.org/mcc/8/en/content ... edit-media
or you can also do it via
Code: Select all
urpmi.update --no-ignore "testing" && urpmi.update -a
although pay attention to disable it afterwards again.

Usually it's safer to not enable it but simply use urpmi to search updates within disabled repositories via e.g.
Code: Select all
urpmi --searchmedia "testing" kicad
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby doktor5000 » May 24th, '21, 21:58

DiBosco wrote:If I could get some lessons on how to create RPMs and have someone hand hold me through the process the first time I would be more than happy to do so. I think people are too busy to train up new people though!


You can also consolidate your questions in a thread in the packaging subforum viewforum.php?f=10 where I'd be happy to answer them.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [Solved] kicad: Could not use OpenGL on Mageia 8

Postby morgano » May 25th, '21, 10:53

At the link i gave there are some links to related pages such as this primer: https://wiki.mageia.org/en/Packaging_for_beginners
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 794
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest