grub did not show windows

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

grub did not show windows

Postby Spinnifex » Apr 8th, '21, 12:48

Hello again

After I installed a new Mageia 8 installation on a Solid State Disk (nvme) with a previously installed mageia 7 on
a other Solid State Disk (sata) the grup entries are placed on the old mageia 7 distro. So I had both
mageia 7, 8 and windows on the grup menu.
After installing some updates and rebooting
I get a grub rescue screen
which tell me that It can not found a file system with a long id ( I guess UUID).
Only when I open Bios boot again I can see again the old grub menu,
So I decide do remove the mageia 7 Solid State Disk and make a new install on my
second nvme disk.
This approach worked but mageia did not add windows to grub.
I have probe foreign OS checked.
When I run as root
Code: Select all

Nothing happend.
Some infos
Code: Select all
cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet noiswmd resume=UUID=fcc710a1-b82e-4c74-b16c-de49c9706307 audit=0 vga=794"

Code: Select all
sda           8:0    0 931,5G  0 disk
├─sda1        8:1    0    16M  0 part
├─sda2        8:2    0   931G  0 part /media/windows
└─sda3        8:3    0   531M  0 part
nvme0n1     259:0    0 465,8G  0 disk
├─nvme0n1p1 259:1    0   299M  0 part /boot/EFI
├─nvme0n1p2 259:2    0  50,3G  0 part /
├─nvme0n1p3 259:3    0     4G  0 part [SWAP]
└─nvme0n1p4 259:4    0 411,2G  0 part /home

any Ideas?


Posts: 56
Joined: Nov 25th, '19, 12:38
Location: Europe / Potsdam

Re: grub did not show windows

Postby Spinnifex » Apr 8th, '21, 13:51

What maybe happened is that
all boot entries are stored on that Solid State Disk I removed.
So will it be enough to just copy the Windows EFI entry from that disk to
my new created Magaie boot/efi path?

Posts: 56
Joined: Nov 25th, '19, 12:38
Location: Europe / Potsdam

Re: grub did not show windows

Postby Spinnifex » Apr 8th, '21, 14:57

Here my old windows grub.cfg entry
Code: Select all
menuentry 'Windows Boot Manager (auf /dev/sdb1)' --class windows --class os $menuentry_id_option 'osprober-efi-699E-AC3B' {
   insmod part_gpt
   insmod fat
   set root='hd1,gpt1'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt1 --hint-efi=hd1,gpt1 --hint-baremetal=ahci1,gpt1  699E-AC3B
     search --no-floppy --fs-uuid --set=root 699E-AC3B
   chainloader /EFI/Microsoft/Boot/bootmgfw.efi

I guess it will not work to simply copy this to my new grub.cfg ?


Posts: 56
Joined: Nov 25th, '19, 12:38
Location: Europe / Potsdam

Re: grub did not show windows

Postby Spinnifex » Apr 13th, '21, 16:47


Since no one answered anything I give again a explanation what happend.

I started with a working system with
1) a Windows 10 OS on
Code: Select all
2) a Mageia 7 OS on
Code: Select all
-> M.2 SATA Solid State Disk

Both OS where installed via EFI.

After updating mageia 7 ca. one week ago I can not login into.
the reason I don't follow but I first thought the newly build nvidia kernel module
was the reason.

Since I have a not used PCIe Solid State Disk on my board I choosed to make a fresh
install of Mageia 8 on this.

This worked. But unfortunately After the first login and some updates I reboot
and get a black screen with grub rescue telling me that he can not find
a device.
I look into my bios and found only the option to boot from my old mageia7 ESP
or the windows boot manager who are both stored on
M.2 Disk.
I did not see the option in BIOS to boot from my PCIe solid state disk.

What I thought at this point is that the new created mageia 8 used the mageia 7 ESP
to append Megaia 8 to it. And therefore some problems arise since the PCIe disk did not occur
in BIOS menu.

My first idea was to remove the M.2 disk and start a new installation of mageia 8.
This worked again.
Now I have only the option to boot from my PCIe solid state disk via BIOS.
Since Windows and Mageia stored their efi files on the m.2 disk.

But grub did not found Windows.
When I run
Code: Select all

Nothing happened.

Which is no wonder since the windows EFI file was on the removed M.2 disk.
What I assumed was that grub was able to recover the information needed to
create the Windows EFI information. That was maybe a little bit naive.

After searching the net and making some false assumptions I reinstalled the M.2 disk.
After doing so I used
Code: Select all

And this found again my old mageia7 and windows.
So far so good.

Because I was scared that maybe something went wrong in the future with this I deleted the
m.2 ESP partition. Which was a bad idea.

What I want to get is a stable mageia 8 OS with a ESP on the NVMe disk.
and a windows with it's own ESP reside on it's HD.

Now I maybe have no other choice then make a new installation of Windows without
any of the solid state disks inserterted to prevent windows from installing
the EFI part on one of the solid state disk which was the case bevore. Then installing
one of the Solid State disks and again install mageia 8 on it. With check for foreign OS
and hoping that everyhting went okay.

Then reason I installed mageia 8 was like I stated above that after a update of Mageia 7 I can not
login anymore. No GUI login screen appear.
Posts: 56
Joined: Nov 25th, '19, 12:38
Location: Europe / Potsdam

Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest