[WORKAROUND] suspend after ugrade to mga8 - Dell XPS15 9550

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[WORKAROUND] suspend after ugrade to mga8 - Dell XPS15 9550

Postby Palin » Apr 7th, '21, 10:26

I upgraded the OS via command line urpmi, I got the update right, everyting is working fine, except suspend.

I used to suspend nicely with mga7, either via closing the lid or by suspending via the Gnome menu, but now it appears to do everything right including shutting off networking, but the notebook stays on (and after a while it resumes everything back, including network).

I'm currently using proprietary nvidia drivers back from the old installation (this is a system I installed on mga6).

I got some trace from the log but it seems related to TPM, but I'm unaware of some security configuration requiring the use of TPM in my system (maybe it's something on by default in mga8).

Is there any other thing I may look at to try to pinpoint the issue? I'm no expert in kernel internals...

Edit: outside of the trace I detected this error:

Code: Select all
Apr  7 10:12:46 palinxps15 kernel: [ 1111.143372] brcmfmac 0000:02:00.0: brcmf_pcie_pm_enter_D3: Timeout on response for entering D3 substate
Apr  7 10:12:46 palinxps15 kernel: [ 1111.143382] PM: pci_pm_suspend(): brcmf_pcie_pm_enter_D3+0x0/0x140 [brcmfmac] returns -5
Apr  7 10:12:46 palinxps15 kernel: [ 1111.143385] PM: dpm_run_callback(): pci_pm_suspend+0x0/0x160 returns -5
Apr  7 10:12:46 palinxps15 kernel: [ 1111.143387] PM: Device 0000:02:00.0 failed to suspend async: error -5
Apr  7 10:12:46 palinxps15 kernel: [ 1111.143581] PM: Some devices failed to suspend, or early wake event detected
Apr  7 10:12:46 palinxps15 kernel: [ 1111.468994] ata2: SATA link down (SStatus 4 SControl 300)
Apr  7 10:12:46 palinxps15 kernel: [ 1113.148157] tpm tpm0: tpm_try_transmit: send(): error -62


If I understand this well, the 0000:02:00.0 seems to be the Intel card or the broadcom card:

Code: Select all
# lspci
[...]
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
[...]
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)
[...]
Attachments
sleeptrace.txt
trace from logs
(6.86 KiB) Not downloaded yet
Last edited by doktor5000 on Apr 7th, '21, 19:02, edited 1 time in total.
Reason: adjusted thread title
Palin
 
Posts: 33
Joined: Sep 6th, '16, 13:36

Re: Suspend do not work after ugrade to mga8 - Dell XPS15 95

Postby Palin » Apr 7th, '21, 12:13

I've actually found a workaround from here: https://askubuntu.com/questions/935672/ ... ally-fails

Expecially adding this:

Code: Select all
#!/bin/sh

case $1 in
    pre)  modprobe -r brcmfmac ;;
    post) modprobe brcmfmac  ;;
esac


to /usr/lib/systemd/system-sleep (I've called the file 10-brcmfmac-suspend.sh).

This basically removes the module before suspending and insert it again after resume.
Palin
 
Posts: 33
Joined: Sep 6th, '16, 13:36

Re: Suspend do not work after ugrade to mga8 - Dell XPS15 95

Postby Palin » Apr 7th, '21, 12:15

Just a little bit, I'm unable to add a [WORKAROUND] tag in the subject of the post, probably due to character limits, are there any convention to do it properly?
Palin
 
Posts: 33
Joined: Sep 6th, '16, 13:36

Re: Suspend do not work after ugrade to mga8 - Dell XPS15 95

Postby isadora » Apr 7th, '21, 14:31

You could skip the "Dell...etc"-part in your title, that will give back space. ;)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2648
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: [WORKAROUND] suspend after ugrade to mga8 - Dell XPS15 9

Postby Palin » Apr 7th, '21, 20:26

Yes but also provide less information to people searching for a solution. I see someone else inserted the tag
Palin
 
Posts: 33
Joined: Sep 6th, '16, 13:36

Re: [WORKAROUND] suspend after ugrade to mga8 - Dell XPS15 9

Postby doktor5000 » Apr 7th, '21, 21:13

"do not work" does not provide any valuable information for someone searching. Usually people use these forums *because* something does not work.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16463
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron