[SOLVED] Mageia 8 and google-earth-pro - error message

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] Mageia 8 and google-earth-pro - error message

Postby bbfuller » Mar 8th, '21, 12:50

I've successfully upgraded three installations of Mageia 7 to Mageia 8 now.

All three of those version 7 installations had the google-earth-pro rpm installed from the Google website and were working well.

After the upgrade, none of the google earths will run.

So far, the most I've done is to uninstall, re-download, remove the ".googleearth" folder and reinstall with no change in what happens.

Issuing the command "google-earth-pro" from the command line gives the following error message:

Code: Select all
google-earth-pro
/usr/bin/google-earth-pro: line 21: 373650 Segmentation fault      (core dumped) "$(dirname "$(readlink -f "$0")")/googleearth-bin" "$@"


Is anybody else having the same problem?

If it's of interest, the basis of the machines is;

Code: Select all
Intel(R) Core(TM) i3-4160 CPU @ 3.60GHz
Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller


Any suggestions as to what an ordinary user might try to get it working again?

Thanks for any interest shown.
Last edited by bbfuller on Mar 26th, '21, 11:11, edited 1 time in total.
bbfuller
 
Posts: 27
Joined: Nov 17th, '15, 19:28

Re: Mageia 8 and google-earth-pro - error message

Postby doktor5000 » Mar 8th, '21, 19:02

Do you use 32bit or 64bit google earth ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Mageia 8 and google-earth-pro - error message

Postby bbfuller » Mar 8th, '21, 19:16

Thanks for the interest.

It's the 64 bit Google Earth download. It was a 64 bit Earth installed on Mageia 7 that appeared to fail after the upgrade to Mageia 8.

I've since downloaded a new 64 bit version from Google which behaves the same.

Today there was a new Kernel for the installations, I've updated that with the same result.
bbfuller
 
Posts: 27
Joined: Nov 17th, '15, 19:28

Re: Mageia 8 and google-earth-pro - error message

Postby doktor5000 » Mar 8th, '21, 19:52

Just tested, fails the same way here on a fresh installation. strace shows it fails after reading /etc/crypto-policies/back-ends/opensslcnf.config
Some recent reports about similar segfaults mention that his might be because it is incompatible with newer curl versions (which was updated due to security vulnerabilities)
See https://support.google.com/earth/thread/99717203?hl=en
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Mageia 8 and google-earth-pro - error message

Postby bbfuller » Mar 8th, '21, 19:57

Reading between the lines, I guess we're at the mercy of Google to release an updated version.

I've added my "upvote" to the link you supplied.

Thanks for the information.
bbfuller
 
Posts: 27
Joined: Nov 17th, '15, 19:28

Re: Mageia 8 and google-earth-pro - error message

Postby doktor5000 » Mar 8th, '21, 20:48

I'm not sure that'll happen soon. Peeking a bit at the archlinux package, seems you can workaround it partially like this in the meantime:

Code: Select all
ln -sf /usr/lib64/libcrypto.so /opt/google/earth/pro/libcrypto.so.1.0.0
ln -sf /usr/lib64/libssl.so /opt/google/earth/pro/libssl.so.1.0.0


That at least allows it to load, but then it crashes, seems it still has issues loading some certificates.

I've tried replacing all the Qt5 bundled libraries with symlinks to the system ones, then it loads and hangs at "initializing" - or maybe I just didn't wait long enough ...

Code: Select all
ln -sf /usr/lib64/libQt5Core.so.5 /opt/google/earth/pro/libQt5Core.so.5
ln -sf /usr/lib64/libQt5DBus.so.5 /opt/google/earth/pro/libQt5DBus.so.5
ln -sf /usr/lib64/libQt5Gui.so.5 /opt/google/earth/pro/libQt5Gui.so.5
ln -sf /usr/lib64/libQt5Multimedia.so.5 /opt/google/earth/pro/libQt5Multimedia.so.5
ln -sf /usr/lib64/libQt5MultimediaWidgets.so.5 /opt/google/earth/pro/libQt5MultimediaWidgets.so.5
ln -sf /usr/lib64/libQt5Network.so.5 /opt/google/earth/pro/libQt5Network.so.5
ln -sf /usr/lib64/libQt5OpenGL.so.5 /opt/google/earth/pro/libQt5OpenGL.so.5
ln -sf /usr/lib64/libQt5Positioning.so.5 /opt/google/earth/pro/libQt5Positioning.so.5
ln -sf /usr/lib64/libQt5PrintSupport.so.5 /opt/google/earth/pro/libQt5PrintSupport.so.5
ln -sf /usr/lib64/libQt5Qml.so.5 /opt/google/earth/pro/libQt5Qml.so.5
ln -sf /usr/lib64/libQt5Quick.so.5 /opt/google/earth/pro/libQt5Quick.so.5
ln -sf /usr/lib64/libQt5Script.so.5 /opt/google/earth/pro/libQt5Script.so.5
ln -sf /usr/lib64/libQt5ScriptTools.so.5 /opt/google/earth/pro/libQt5ScriptTools.so.5
ln -sf /usr/lib64/libQt5Sensors.so.5 /opt/google/earth/pro/libQt5Sensors.so.5
ln -sf /usr/lib64/libQt5Sql.so.5 /opt/google/earth/pro/libQt5Sql.so.5
ln -sf /usr/lib64/libQt5Svg.so.5 /opt/google/earth/pro/libQt5Svg.so.5
ln -sf /usr/lib64/libQt5WebChannel.so.5 /opt/google/earth/pro/libQt5WebChannel.so.5
ln -sf /usr/lib64/libQt5WebKit.so.5 /opt/google/earth/pro/libQt5WebKit.so.5
ln -sf /usr/lib64/libQt5WebKitWidgets.so.5 /opt/google/earth/pro/libQt5WebKitWidgets.so.5
ln -sf /usr/lib64/libQt5Widgets.so.5 /opt/google/earth/pro/libQt5Widgets.so.5
ln -sf /usr/lib64/libQt5X11Extras.so.5 /opt/google/earth/pro/libQt5X11Extras.so.5
ln -sf /usr/lib64/libQt5XcbQpa.so.5 /opt/google/earth/pro/libQt5XcbQpa.so.5
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Mageia 8 and google-earth-pro - error message

Postby doktor5000 » Mar 25th, '21, 18:42

FWIW, somebody in the german forum mentioned simply moving away /opt/google/earth/pro/libcrypto.so.1.0.0 worked for them and got google earth to start normally, maybe you want to try that.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Mageia 8 and google-earth-pro - error message

Postby bbfuller » Mar 26th, '21, 02:16

And it does indeed work. I'll give it a longer workout tomorrow morning and mark the thread "Solved" if it stays fixed.

In the meantime, my thanks to you and to whoever in the German Forum worked that out.
bbfuller
 
Posts: 27
Joined: Nov 17th, '15, 19:28

Re: [SOLVED] Mageia 8 and google-earth-pro - error message

Postby bbfuller » Mar 26th, '21, 11:13

Still working fine this morning as far as I can tell. I wonder what purpose it originally served if it can be discarded so easily.
bbfuller
 
Posts: 27
Joined: Nov 17th, '15, 19:28

Re: [SOLVED] Mageia 8 and google-earth-pro - error message

Postby morgano » Mar 26th, '21, 12:16

I guess the version of that file was incompatible with Mageia, but when it is removed the corresponding file in Mageia gets used.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 794
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [SOLVED] Mageia 8 and google-earth-pro - error message

Postby doktor5000 » Mar 26th, '21, 20:18

Strange thing is why symlinking to the Mageia library is different then completely removing the library ... but anyways, at least it's working again.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Mageia 8 and google-earth-pro - error message

Postby akbrian » Jun 11th, '21, 21:36

Running;
Code: Select all
touch /opt/google/earth/pro/libcurl.so.4

as root also appears to solve the problem.
akbrian
 
Posts: 46
Joined: Sep 10th, '11, 01:56


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest