x2go connection issue

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

x2go connection issue

Postby cmorning » Dec 24th, '20, 17:21

I'm not sure if this is the correct forum to use, but I have tried searching others with no luck. Any suggestions where to turn to for help would be appreciated.

I just installed x2goclient and server on my mageia 7 systems. When I try to start a connection, I get an error message such as:

Connection failed. Cannot create remote file ~colin/.x2go/ssh/key.ttBlvN - SCP: Warning: status code 1 received: scp: ~colin/.x2go/ssh: No such file or directory


I feel there must be a simple solution to this. It is not a file permission problem, etc. as far as I can tell. The version I have installed (for the client) is
x2goclient-4.1.2.1-2.mga7
The server machine has the following installed
x2goserver-4.0.1.20-3.mga7
Last edited by isadora on Dec 24th, '20, 21:11, edited 1 time in total.
Reason: Topic moved into appropriate sub-forum
cmorning
 
Posts: 14
Joined: Feb 18th, '14, 22:48

Re: x2go connection issue

Postby doktor5000 » Dec 24th, '20, 22:24

Is x2go actually running on the system where you installed the server ? The output as root of
Code: Select all
systemctl status x2goserver.service -al -n250
would be helpful.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16224
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: x2go connection issue

Postby cmorning » Dec 25th, '20, 00:06

The output on the server system is as follows:

Code: Select all
x2goserver.service - X2Go session cleanup
   Loaded: loaded (/usr/lib/systemd/system/x2goserver.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2020-12-24 16:56:56 EST; 40s ago
  Process: 17285 ExecStart=/usr/sbin/x2gocleansessions (code=exited, status=0/SUCCESS)
 Main PID: 17290 (x2gocleansessio)
    Tasks: 1 (limit: 4915)
   Memory: 13.2M
   CGroup: /system.slice/x2goserver.service
           ââ17290 /usr/bin/perl /usr/sbin/x2gocleansessions
Last edited by isadora on Dec 25th, '20, 09:54, edited 1 time in total.
Reason: Please place command-output between [CODE]-tags, to improve readability, thanks ahead!!! ;)
cmorning
 
Posts: 14
Joined: Feb 18th, '14, 22:48

Re: x2go connection issue

Postby doktor5000 » Dec 25th, '20, 18:31

Can you check the same again for the ssh server? As root
Code: Select all
systemctl status sshd.service -al -n250

And can you try to manually to connect to the x2go server box as a regular ssh client ?

From what I can tell, this might be occuring since a security update to ssh earlier this year.
Others mentioned that this should be fixed with x2go 4.1.2.2 although I don't know if this also needs an update of the server portion.
You might need to wait for someone else who's using x2go to see if they can confirm this issue.

See also https://bugs.debian.org/cgi-bin/bugrepo ... bug=947129
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16224
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest