Page 1 of 1

Sessions spontaneously closing with multiple DM users

PostPosted: Nov 3rd, '20, 18:06
by mailedfist
Is anyone else seeing this?

My wife and I are both running Mageia 7 64-bit with latest updates. She first started seeing the issue a month or so ago and I started seeing it a bit later (suspect I was later installing an update).

If multiple users are logged in via the display manager (using the Switch Users capability), a session will spontaneously close with nothing apparent via dmesg or journalctl (the logs suggest the user just logged out, but there are not the usual PAM logout messages until after the display server has already stopped). It may be the first session or a later one.

I was getting SMART errors on the primary disk on my machine so had suspected that may be related. However, the same problem is occurring having replaced the disk.

The only possible clue I can see in the logs is that acpid seems to always run in the same second the problem occurs and just before it, but it runs most of the time with no issue so this may be a red herring.

One machine is a Dell Wyse using Xfce and the other an HP EliteBook using Plasma. Both are using SDDM as display manager. Both have 8G of RAM and there is no evidence of being anywhere near full memory use when the problem occurs. All very puzzling!

Log snippet:
Code: Select all
Nov 03 15:19:34 wyse3.d-bshome.org acpid[902]: client 15731[0:0] has disconnected
Nov 03 15:19:34 wyse3.d-bshome.org acpid[902]: client connected from 3448[0:0]
Nov 03 15:19:34 wyse3.d-bshome.org acpid[902]: 1 client rule loaded
Nov 03 15:19:34 wyse3.d-bshome.org pulseaudio[16320]: X connection to :1.0 broken (explicit kill or server shutdown).
Nov 03 15:19:34 wyse3.d-bshome.org polkitd[4103]: Unregistered Authentication Agent for unix-session:c8 (system bus name :1.1755, object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8) (disconnected from bus)
Nov 03 15:19:34 wyse3.d-bshome.org at-spi-bus-launcher[2151]: X connection to :1 broken (explicit kill or server shutdown).
Nov 03 15:19:34 wyse3.d-bshome.org sddm[3412]: Display server stopped.
Nov 03 15:19:34 wyse3.d-bshome.org sddm[3412]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
Nov 03 15:19:34 wyse3.d-bshome.org bluetoothd[912]: Endpoint unregistered: sender=:1.1751 path=/MediaEndpoint/A2DPSource
Nov 03 15:19:34 wyse3.d-bshome.org bluetoothd[912]: Endpoint unregistered: sender=:1.1751 path=/MediaEndpoint/A2DPSink
Nov 03 15:19:34 wyse3.d-bshome.org systemd[1683]: pulseaudio.service: Main process exited, code=exited, status=1/FAILURE
Nov 03 15:19:34 wyse3.d-bshome.org systemd[1683]: pulseaudio.service: Failed with result 'exit-code'.
Nov 03 15:19:34 wyse3.d-bshome.org sddm-helper[15846]: [PAM] Closing session
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: Socket server stopping...
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: Socket server stopped.
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: Removing display ":1" ...
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: Jumping to VT 1
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: VT mode didn't need to be fixed
Nov 03 15:19:35 wyse3.d-bshome.org sddm[3412]: QProcess: Destroyed while process ("/usr/libexec/sddm-helper") is still running.

Re: Sessions spontaneously closing with multiple DM users

PostPosted: Nov 3rd, '20, 18:17
by doktor5000
What desktop session are you running inside those session? And did you check energy settings if there are any inactivity timers for auto-shutdown, suspend or something like that ?

You may want to look at the logs before that point in time to see what's triggering this, in your log snippet you only see the result which is pretty much irrelevant.

Re: Sessions spontaneously closing with multiple DM users

PostPosted: Nov 3rd, '20, 18:41
by mailedfist
Unfortunately there is nothing in the log for several minutes before this. That's what is baffling me - no evidence of why the session suddenly dies when I switch to it.

The previous entry is
Code: Select all
Nov 03 15:14:38 wyse3.d-bshome.org rtkit-daemon[904]: Supervising 12 threads of 8 processes of 2 users.


There doesn't seem to be anything in the Xfce power manager which would affect just an inactive session. I'm busy working in the other one so you'd hope the "put to sleep after" timer doesn't come into play.

Sorry for being slow here but what do you mean by "What desktop session are you running inside those session?"

Re: Sessions spontaneously closing with multiple DM users

PostPosted: Nov 3rd, '20, 23:40
by doktor5000
mailedfist wrote:Sorry for being slow here but what do you mean by "What desktop session are you running inside those session?"

So both X sessions are running XFCE ?

Re: Sessions spontaneously closing with multiple DM users

PostPosted: Nov 4th, '20, 12:51
by mailedfist
The Dell is running Xfce and the HP Plasma. I did mention that in the original post :)

Re: Sessions spontaneously closing with multiple DM users

PostPosted: Nov 16th, '20, 16:51
by mailedfist
It is too soon to be conclusive but this issue seems to have gone away by itself, suggesting a recent update has rectified whatever was causing it.