(SOLVED) Unknown Video issue

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

(SOLVED) Unknown Video issue

Postby kajosim » Apr 5th, '20, 15:39

My main PC has an SSD and an 3GB HD. / is mounted on the SSD and /var (5GB) and a big partition with my "home" files on the HD .
Because it also acts as a DHCP server on an local network it is powered on 24/7 .
Today I could no longer print so I decided to reboot. During boot it stops after "started OpenSSH server damon" so I could no longer boot up.

So I booted up my old MAG6 on the same PC (sharing the big partition but each having their own /var) . I could then see that the M7 /var was completely filled and eg syslog bigger then 500MB .
Most of syslog contained the line :

Code: Select all
 Apr  2 11:05:34 localhost /usr/libexec/gdm-x-session[5101]: [mov,mp4,m4a,3gp,3g2,mj2 @ 0xfb3dc0] STSC entry 148200 is invalid (first=1 count=1 id=1)


I had to maually mount M7 /var and the deleted syslog.1 ans similarly for user.log.1 and messages.1 which contains similar errors.
I then shut down M6 and could then boot M7 and it is working completely as normal.

For video playback I used to use Videos (Totem) but on M7 there is some "GUI" issue when I want to shift time - so I have in Plasma - System Settings - File Associations specified VLC as the preferred player.
Whether this has anything to do with the syslog error I do not know.

What could be the reason for the syslog error ?

Regards.
Kajosim
Last edited by kajosim on Apr 6th, '20, 13:28, edited 1 time in total.
kajosim
 
Posts: 19
Joined: Feb 22nd, '17, 00:55

Re: Unknown Video issue

Postby doktor5000 » Apr 5th, '20, 18:12

The syslog error comes from ffmpeg/vlc, see e.g. https://trac.ffmpeg.org/ticket/7165 for more details.
What vlc/avformat versions do you have installed, and might it be possible that the videos you're watching might be slightly corrupted or have corrupted indexes? Maybe also this "time shift" you referred to could contribute to this issue.

Please post the output of
Code: Select all
rpm -qa|grep -iE "vlc|ffmpeg|avformat"|sort
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15673
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Unknown Video issue

Postby kajosim » Apr 6th, '20, 13:28

The output is :

    ffmpeg2theora-0.30-6.mga7
    ffmpeg-4.1.5-1.mga7.tainted
    ffmpegthumbs-19.04.0-1.mga7
    lib64avformat58-4.1.5-1.mga7.tainted
    lib64vlc5-3.0.8-1.mga7.tainted
    lib64vlccore9-3.0.8-1.mga7.tainted
    libvlccore9-3.0.8-1.mga7.tainted
    vlc-3.0.8-1.mga7.tainted
    vlc-plugin-common-3.0.8-1.mga7.tainted
    vlc-plugin-dv-3.0.8-1.mga7.tainted
    vlc-plugin-fdkaac-3.0.8-1.mga7.tainted
    vlc-plugin-flac-3.0.8-1.mga7.tainted
    vlc-plugin-gnutls-3.0.8-1.mga7.tainted
    vlc-plugin-kate-3.0.8-1.mga7.tainted
    vlc-plugin-libass-3.0.8-1.mga7.tainted
    vlc-plugin-libnotify-3.0.8-1.mga7.tainted
    vlc-plugin-lirc-3.0.8-1.mga7.tainted
    vlc-plugin-pulse-3.0.8-1.mga7.tainted
    vlc-plugin-speex-3.0.8-1.mga7.tainted
    vlc-plugin-theora-3.0.8-1.mga7.tainted
    vlc-plugin-vdpau-3.0.8-1.mga7.tainted
    vlc-plugin-zvbi-3.0.8-1.mga7.tainted

In my search for the error I tried to play some (other) videos and also playing online videos in Firefox but I was not able to reproduce the error. I looked in the /var/log/syslog.1 to get some hint of what started the many error messages.
Finally I found a video I yesterday downloaded using Firefox + DownLoadHelper plug-in . When played using VLC it gave the same problem. Playing for about a minute syslog increased from about 1MB to 44MB.
Playing the same video with MPlayer, Xine or Videos/Totem gave no problems.
Then I tried again to download the same video and now VLC can play it without problems. The size of the download is exactly the same so it can only be a bit-error the caused the problem.
So problem solved.
kajosim
 
Posts: 19
Joined: Feb 22nd, '17, 00:55


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest