Re: [m7.1] [8] Problem with nfs

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Re: [m7.1] [8] Problem with nfs

Postby bitit » Dec 10th, '19, 18:07

when try to mount a nfs form a Mageia7.1 to other Mageia7.1 and mageia 6. whit MCC i can see the host server but not the folder to mount, MCC give me this error :
Code: Select all
Message : 22:55:07 diskdrake[8503]: running: showmount --no-headers -e 192.168.1.220
Last edited by bitit on May 29th, '21, 18:16, edited 1 time in total.
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby doktor5000 » Dec 11th, '19, 20:29

Could you please post the output from running that command as root?
Code: Select all
showmount --no-headers -e 192.168.1.220
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 12:49

From ps server or from pc client?
Enrico
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 15:37

form pc Client
Code: Select all
showmount --no-headers -e 192.168.1.220
rpc mount export: RPC: Timed out
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 15:58

from pc server

Code: Select all
showmount --no-headers -e 192.168.1.220
/home/enrico/condivisioni *
/home/enrico              *.

bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 16:09

Code: Select all
 nmap 192.168.1.220

Starting Nmap 7.40 ( https://nmap.org ) at 2019-12-12 15:06 CET
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 3.04 seconds
[enrico@localhost ~]$ nmap -Pn 192.168.1.220

Starting Nmap 7.40 ( https://nmap.org ) at 2019-12-12 15:07 CET
Nmap scan report for 192.168.1.220
Host is up (0.0039s latency).
Not shown: 993 filtered ports
PORT     STATE  SERVICE
111/tcp  open   rpcbind
2049/tcp open   nfs
4001/tcp closed newoak
4002/tcp open   mlchat-proxy
4003/tcp closed pxc-splr-ft
4004/tcp closed pxc-roid
5900/tcp open   vnc

Nmap done: 1 IP address (1 host up) scanned in 6.25 seconds

Last edited by doktor5000 on Dec 12th, '19, 19:10, edited 1 time in total.
Reason: added code tags
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby doktor5000 » Dec 12th, '19, 19:12

bitit wrote:form pc Client
showmount --no-headers -e 192.168.1.220
rpc mount export: RPC: Timed out

This seems to be your problem, rpcbind/portmapper does not seem to be running properly on the client.

On the client, please show the output as root of

Code: Select all
systemctl status rpcbind.service
rpcinfo -p
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 19:21

one client is in Mageia 6, that with mageia 6 server it work fine, it work fine also for samba , ftp folder in plasma desktop etc.

what i must check step

Enrico
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby doktor5000 » Dec 12th, '19, 19:29

doktor5000 wrote:This seems to be your problem, rpcbind/portmapper does not seem to be running properly on the client.

On the client, please show the output as root of

Code: Select all
systemctl status rpcbind.service
rpcinfo -p
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [m7.1] Problem with nfs

Postby bitit » Dec 12th, '19, 21:23

Code: Select all
systemctl status rpcbind.service
● rpcbind.service - RPC bind service
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; enabled; vendor preset: enabled)
   Active: active (running) since gio 2019-12-12 14:25:06 CET; 5h 56min ago
  Process: 943 ExecStart=/sbin/rpcbind -w ${RPCBIND_ARGS} (code=exited, status=0/SUCCESS)
 Main PID: 974 (rpcbind)
   CGroup: /system.slice/rpcbind.service
           └─974 /sbin/rpcbind -w

dic 12 14:25:06 localhost systemd[1]: Starting RPC bind service...
dic 12 14:25:06 localhost systemd[1]: Started RPC bind service.

 rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp  20048  mountd
    100005    1   tcp  20048  mountd
    100005    2   udp  20048  mountd
    100005    2   tcp  20048  mountd
    100005    3   udp  20048  mountd
    100005    3   tcp  20048  mountd
    100024    1   udp  52983  status
    100024    1   tcp  40217  status
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100227    3   tcp   2049  nfs_acl
    100003    3   udp   2049  nfs
    100227    3   udp   2049  nfs_acl
    100021    1   udp  46791  nlockmgr
    100021    3   udp  46791  nlockmgr
    100021    4   udp  46791  nlockmgr
    100021    1   tcp  34499  nlockmgr
    100021    3   tcp  34499  nlockmgr
    100021    4   tcp  34499  nlockmgr




client mageia6
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby doktor5000 » Dec 12th, '19, 21:31

Now please the same output when run locally on the server 192.168.1.220
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16734
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [m7.1] Problem with nfs

Postby bitit » Dec 13th, '19, 11:36

i believe is a firewall problem that the configurations by MCC don't work properly
yesterday night i have tried take away the firewall and the connection working on

Code: Select all
# systemctl status rpcbind.service
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-12-12 21:58:12 CET; 2h 1min ago
     Docs: man:rpcbind(8)
 Main PID: 716 (rpcbind)
   Memory: 2.0M
   CGroup: /system.slice/rpcbind.service
           └─716 /usr/bin/rpcbind -w -f

dic 12 21:58:12 localhost.localdomain systemd[1]: Starting RPC Bind...
dic 12 21:58:12 localhost.localdomain systemd[1]: Started RPC Bind.
[root@localhost /]# rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp  20048  mountd
    100005    1   tcp  20048  mountd
    100005    2   udp  20048  mountd
    100005    2   tcp  20048  mountd
    100005    3   udp  20048  mountd
    100005    3   tcp  20048  mountd
    100024    1   udp  58088  status
    100024    1   tcp  33149  status
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100021    1   udp   4002  nlockmgr
    100021    3   udp   4002  nlockmgr
    100021    4   udp   4002  nlockmgr
    100021    1   tcp   4002  nlockmgr
    100021    3   tcp   4002  nlockmgr
    100021    4   tcp   4002  nlockmgr

bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] Problem with nfs

Postby bitit » Dec 21st, '19, 12:46

i have try with other installations, but i have the same problem with nfs

in rules.drakx i have this

ACCEPT net fw icmp 8 -
ACCEPT net fw tcp 22,111,2049,4002,4001,4003,4004,8069,5900 -
ACCEPT net fw udp 111,2049,4002,4001,4003,4004,5353,427 -


whats 111,4002,4001,4003,4004?

enrico
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: [m7.1] [8] Problem with nfs

Postby bitit » May 29th, '21, 18:15

i have the same problem in mageia 8
bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01

Re: Re: [m7.1] [8] Problem with nfs

Postby bitit » May 29th, '21, 20:49

bitit
 
Posts: 113
Joined: Feb 3rd, '16, 14:01


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest