[Solved] Constant Writing To HDD

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[Solved] Constant Writing To HDD

Postby yankee495 » Dec 5th, '19, 05:00

Edit: This appears to be normal and I've never noticed it until I used the plastic dock. It is ext4 "Lazy Initialization" (ext4lazyinit) and you can see it with iotop like below.


I have a brand new Toshiba 8TB HDD and I put it in a USB 3.0 dock, formatted it and everything went well.
Then, because of the plastic dock acting as a echo chamber, I noticed the drive clicking constantly, not like a broken klinking drive but like a normal head moving.

I removed it from the dock and put it in a eSATA/USB 3 Rosewill external case, using the eSATA port. I noticed the drive doesn't do it when it's not mounted so I started tracking down what might be writing to the drive.
The drive is sdh1
Code: Select all
[root@desktop1]# iotop -o -b -d 4
Total DISK READ :       0.00 B/s | Total DISK WRITE :       0.00 B/s
Actual DISK READ:       0.00 B/s | Actual DISK WRITE:       0.00 B/s
Total DISK READ :       0.00 B/s | Total DISK WRITE :      74.09 K/s
Actual DISK READ:       0.00 B/s | Actual DISK WRITE:       6.76 M/s
 5527 be/4 root        0.00 B/s    0.00 B/s  0.00 %  7.99 % [ext4lazyinit]
 1015 be/3 root        0.00 B/s   19.76 K/s  0.00 %  0.95 % [jbd2/nvme0n1p7-]
 5520 be/3 root        0.00 B/s 1011.54 B/s  0.00 %  0.80 % [jbd2/sdh1-8]                          <-------------------- It's that drive.
 6622 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.22 % [kworker/u16:2-flush-259:0]

First I used KSsysGuard to set up a HDD I/O monitor and I spotted the spiked pattern right off. There's about a 4MB/s write repeatedly, about twice per second. The drive is sdh1 [jbd2/sdh1-8] and after a lot of reading I read it may be related to ext4lazyinit.

It is one large ext4 partition and it doesn't do it if it's formatted as NTFS or ext3. It is possible there is a bad sector that other file systems are not trying to use, or maybe it's a bug. But it appears to be journal related. The dock and the external case are both rated for 8TB and I have tried multiple smaller partitions to try and force it to use different sectors for the journal etc.

It's a new drive and if it's defective I need to return it quickly, so I need to get it sorted out if it's a bug, user error or a bad drive.
I've been working on it for hours, and reading everything. I've installed a few drives and it shouldn't be this difficult, so I'm afraid it is defective.

If you've seen this problem before or have a clue, I'd sure appreciate some help.

Thank you.
There are 10 types of people, those who understand binary & those who don't.
Main Desktop
Posts: 425
Joined: May 25th, '12, 13:10
Location: Carthage, Mo. USA

Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest