[SOLVED] Problems to run things since last update

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] Problems to run things since last update

Postby tomane » Sep 10th, '19, 12:55

Hi all,
I updated today my mageia 6 and cannot launch most of the things from the menu or from the status bar ! I can run firefox or thunderbird, but icons seem missing.
When I click on the firefox icon on the bar, I get the firefox.desktop properties, instead of the window.
I can't run the MCC, nor the plasma configuration.
I previously did this, to fix a file association, but I don't think this caused the problem, because I alread did this in the past and didn't break anything, but anyway :
sudo update-mime-database /usr/share/mime

Help me please, because this is my professional laptop and I need it to work !
Thanks a lot

EDIT : pavucontrol , launched from the command line crashes with the message :
Code: Select all
pavucontrol

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:70:34: The style property GtkCheckButton:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:71:36: The style property GtkCheckMenuItem:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:76:30: The style property GtkExpander:expander-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Theme parsing error: gtk.css:83:29: The style property GtkStatusbar:shadow-type is deprecated and shouldn't be used anymore. It will be removed in a future version

(pavucontrol:4932): Gtk-WARNING **: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:493:ensure_surface_for_gicon: assertion failed: (destination)
Abandon (core dumped)


EDIT 2 :
sorry, no problems with plasma modules.
It seems my problems are related to gtk3 / pixbuf
Last edited by doktor5000 on Sep 11th, '19, 03:34, edited 1 time in total.
Reason: marked as solved
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58

Re: (big) Problems to run things since last update

Postby doktor5000 » Sep 10th, '19, 15:04

Are you sure it was a regular update or maybe it was an upgrade to Mageia 7 as indicated by a blue arrow in the systray ?
Please show the output of
Code: Select all
urpmq --list-media active --list-url


tomane wrote:Help me please, because this is my professional laptop and I need it to work !

Well if this is your professional laptop you do have a tested backup/restore concept and can simply rollback to the most recent backup to continue working, no ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15022
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: (big) Problems to run things since last update

Postby tomane » Sep 10th, '19, 15:10

doktor5000 wrote:Are you sure it was a regular update or maybe it was an upgrade to Mageia 7 as indicated by a blue arrow in the systray ?
Please show the output of
Code: Select all
urpmq --list-media active --list-url

Hi !
Code: Select all
urpmq --list-media active --list-url
Core Release (distrib1) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/core/release
Core Updates (distrib3) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/core/updates
Nonfree Release (distrib11) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/nonfree/release
Nonfree Updates (distrib13) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/nonfree/updates
Tainted Release (distrib21) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/tainted/release
Tainted Updates (distrib23) http://ftp.free.fr/mirrors/mageia.org/distrib/6/x86_64/media/tainted/updates
Core 32bit Release (distrib31) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/core/release
Core 32bit Updates (distrib32) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/core/updates
Nonfree 32bit Release (distrib36) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/nonfree/release
Nonfree 32bit Updates (distrib37) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/nonfree/updates
Tainted 32bit Release (distrib41) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/tainted/release
Tainted 32bit Updates (distrib42) http://ftp.free.fr/mirrors/mageia.org/distrib/6/i586/media/tainted/updates

tomane wrote:Help me please, because this is my professional laptop and I need it to work !

Well if this is your professional laptop you do have a tested backup/restore concept and can simply rollback to the most recent backup to continue working, no ?


I do have a backup, done with clonezilla of the full root partition, no online daily backup unfortunately, it's not so recent (a few months ?) and I would like to work today !

Thanks for answering
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58

Re: (big) Problems to run things since last update

Postby doktor5000 » Sep 10th, '19, 15:17

If you run firefox or thunderbird from a terminal, do they run normally? If not, what is the full output ?
If you create a new user and login as that user, do your described problems persist or not ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15022
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: (big) Problems to run things since last update

Postby tomane » Sep 10th, '19, 15:32

doktor5000 wrote:If you run firefox or thunderbird from a terminal, do they run normally? If not, what is the full output ?
If you create a new user and login as that user, do your described problems persist or not ?

Firefox seems to run ok, but thunderbird have missing icons, and if I try to attach or detach a file to a message, it just crashes.
If I run thunderbird from the command line I have this
Code: Select all
thunderbird
(thunderbird:1120): Gtk-WARNING **: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.

(thunderbird:1120): Gtk-WARNING **: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:1120): Gtk-WARNING **: Theme parsing error: <data>:1:77: Expected ')' in color definition

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'folder' for stock: Format d'image non reconnu

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: Format d'image non reconnu

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'folder' for stock: Format d'image non reconnu

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: Format d'image non reconnu

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'text-x-generic' for stock: Format d'image non reconnu

(thunderbird:1120): Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: Format d'image non reconnu

I don't have another user, I can't run mcc (crashes) to create a new one and I don't know how to do it from the cmd line :(
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58

Re: (big) Problems to run things since last update

Postby tomane » Sep 10th, '19, 15:36

EDIT : If I try to open a pdf file, it 's opened with kate !
mime database seems corrupted ?
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58

Re: (big) Problems to run things since last update

Postby tomane » Sep 10th, '19, 16:06

I added a new user (with useradd).
that's worse ! clicking on dolphin opens libreoffice !
I think you should be right, maybe I should just restore a backup this evening, seems really "f**" up.
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58

Re: (big) Problems to run things since last update

Postby doktor5000 » Sep 10th, '19, 16:49

tomane wrote:I previously did this, to fix a file association, but I don't think this caused the problem, because I alread did this in the past and didn't break anything, but anyway :
sudo update-mime-database /usr/share/mime


Maybe next time ask before you mess with any system stuff? Could have avoided this issue with just a quick question ...

Apart from that, you could still try to simply reinstall shared-mime-info
Code: Select all
urpmi --replacepkgs --replacefiles shared-mime-info
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15022
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: (big) Problems to run things since last update

Postby tomane » Sep 10th, '19, 17:03

doktor5000 wrote:
tomane wrote:I previously did this, to fix a file association, but I don't think this caused the problem, because I alread did this in the past and didn't break anything, but anyway :
sudo update-mime-database /usr/share/mime


Maybe next time ask before you mess with any system stuff? Could have avoided this issue with just a quick question ...

You're certainly right, but with linux sometimes you have to try to fix things by yourself, isn't it ? Not all the support we can have is allways so effective, and trying by yourself also is the best way to learn things.
doktor5000 wrote:Apart from that, you could still try to simply reinstall shared-mime-info
Code: Select all
urpmi --replacepkgs --replacefiles shared-mime-info

That fixed it ! It's a big relief
Thanks a lot !

EDIT : BTW I'll have a question later on how to fix my file association problem ;)
tomane
 
Posts: 32
Joined: Jun 30th, '13, 19:58


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron