Seahorse or Gnome Keyring: Systemprompter doesn't show up

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Seahorse or Gnome Keyring: Systemprompter doesn't show up

Postby artee » Aug 19th, '19, 22:25

I had quite some trouble with my setup, which I'd like to share and make available for future use (even if I may be the only one with this kind of setup hence this kind or problem :D ).

My setup:
1 Mageia 7 headless server
1 Mageia 7 desktop

The server and desktop both got upgraded from Mageia 6.

On the server, I run mail client Evolution of UserA within a VNC session of UserB. Been doing that for years (since Mandriva or even Mandrake).

After upgrading to Mageia 7, I couldn't get Evolution to get mails from the various accounts anymore. Upon clicking "send/receive" it would just sit there with all accounts listed, but no connection/downloads going on.

I realized the pop-up hadn't come to get my password to unlock the keyring.
At some point, fiddling around got Evolution to prompt for my passwords for all accounts, it would actually fetch the messages, but upon clicking again, it would show the prompts again, one for each account.
This way, mail won't work...

I did manage to go on the desktop, which has the same account mounted (user data/home folders), and on that system, all was working well: the prompt for the password showed up nicely, evolution would get mails whenever triggered, no further password input required, just the one time at the start.
SInce all user data is identical (same drive, in one case / server: local drive, on the desktop: remote nfs drive), this was all very puzzling.

After several hours of searching, I managed to find what to search for, and what to look for in the system.

I installed seahorse, the gnome key program, and tried to unlock the wallet / keys. The unlock button just wouldn't budge, no popup request, nothing.

Then I checked with journalctl -f as root what was amiss, and obviously I had the 2 ways on the 2 machines to compare.
On the functional and non-functional sides, when starting evolution, I got messages as regular user such as:
Code: Select all
$ evolution

(evolution:21119): dbind-WARNING **: 21:29:39.261: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(evolution-alarm-notify:21154): dbind-WARNING **: 21:29:40.233: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.



But as root, on the functional side I got this type:
Code: Select all
Aug 19 21:47:36 zurich dbus-daemon[20697]: [session uid=501 pid=20695] Activating service name='org.gnome.keyring.SystemPrompter' requested by ':1.1' (uid=501 pid=20724 comm="/usr/bin/gnome-keyring-daemon --start --foreground")
Aug 19 21:47:36 zurich gcr-prompter[21940]: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Aug 19 21:47:36 zurich gcr-prompter[21940]: bus acquired: org.gnome.keyring.SystemPrompter
Aug 19 21:47:36 zurich gcr-prompter[21940]: Gcr: registering prompter
Aug 19 21:47:36 zurich gcr-prompter[21940]: bus acquired: org.gnome.keyring.PrivatePrompter
Aug 19 21:47:36 zurich dbus-daemon[20697]: [session uid=501 pid=20695] Successfully activated service 'org.gnome.keyring.SystemPrompter'
Aug 19 21:47:36 zurich gcr-prompter[21940]: Gcr: received BeginPrompting call from callback /org/gnome/keyring/Prompt/p10@:1.1
Aug 19 21:47:36 zurich gcr-prompter[21940]: Gcr: preparing a prompt for callback /org/gnome/keyring/Prompt/p10@:1.1
Aug 19 21:47:36 zurich gcr-prompter[21940]: Gcr: creating new GcrPromptDialog prompt
Aug 19 21:47:36 zurich gcr-prompter[21940]: GLib-GIO: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs)


Looks like plenty is not right, but it still works.

On the non-functional machine, I saw this:
Code: Select all
Aug 19 21:51:28 neuchatel dbus-daemon[23890]: [session uid=501 pid=23890] Activating service name='org.gnome.keyring.SystemPrompter' requested by ':1.2' (uid=501 pid=23914 comm="/usr/bin/gnome-keyring-daemon --start --foreground")
Aug 19 21:51:28 neuchatel org.gnome.keyring.SystemPrompter[23890]: Unable to init server: Could not connect: Connection refused
Aug 19 21:51:28 neuchatel gcr-prompter[25915]: cannot open display:
Aug 19 21:51:28 neuchatel dbus-daemon[23890]: [session uid=501 pid=23890] Activated service 'org.gnome.keyring.SystemPrompter' failed: Process org.gnome.keyring.SystemPrompter exited with status 1
Aug 19 21:51:28 neuchatel gnome-keyring-daemon[23914]: couldn't create system prompt: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.keyring.SystemPrompter exited with status 1
Aug 19 21:51:28 neuchatel gnome-keyring-d[23914]: couldn't create system prompt: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.keyring.SystemPrompter exited with status 1
Aug 19 21:51:29 neuchatel kwin_x11[4069]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 61390, resource id: 92274692, major code: 15 (QueryTree), minor code: 0


Okay, so there's some Display-setting mismatch going on.
I then found this (had found it before, just not connected the dots):
https://bbs.archlinux.org/viewtopic.php?id=202754

Where I used this, first on the command line:
Code: Select all
dbus-update-activation-environment --systemd DISPLAY


After that, I got the window with the password prompt upon trying to unlock the keyring in seahorse, and as well with evolution.
Finally, I put the command into my .bashrc - since compared to the link of archlinux bbs above, I wasn't sure that any .xinitrc would get read, and in any case, on that account I don't have an .xinitrc file in that home dir.
artee
 
Posts: 27
Joined: Jun 15th, '13, 14:00

Return to Basic support

Who is online

Users browsing this forum: Bequimao and 1 guest

cron