Upgrade: kernel panic not syncing vfs unable to mount root

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Upgrade: kernel panic not syncing vfs unable to mount root

Postby artee » Aug 18th, '19, 00:23

So I upgraded a system (Ryzen 5 2400G RavenRidge) from Mageia 6 to 7.

During the upgrade, done from CLI as per the info on the Mageia pages, I had one hiccup, where I had to restart the upgrade command

Code: Select all
urpmi --auto-update --auto --force

I was upgrading from within a vnc session on a headless server, the vnc-session broke, came back up, but stayed black inside. I did manage to continue from a new ssh connection, then restarted the vnc-session, then continued the command from there.

I'm not sure what lead to the following error after finishing the upgrade, checking all had installed, when I rebooted, I got this (had to connect monitor, keyboard and mouse):

Code: Select all
kernel panic not syncing vfs unable to mount root file system on unknown block(0,0)

The reason I am writing all this, from the now-repaired system, is that all info that I could find on the web hints at something wrong with the initrd.img or bootloader. Stuff like: that error means that support for the file system type is not built into the kernel, and there is no initrd or so.

I spent hours of reading, tried to use an install dvd to use the boot loader rescue function, etcetc.

In my case, the reason the system threw the above error was due to the boot loader (grub without EFI) not getting started correctly.

I can't explain why, but somehow, the BIOS/EFI (Gigabyte GA-AB350N-Gaming-Wifi) wanted to start an EFI bootloader, and the system was set up with a classic (BIOS?) style bootloader (grub legacy?). Note that this system was functional for ages, always headless coming back up after power failures or getting reset (shutdown -r now).

So, grub couldn't properly load/mount the sdd partition that it wanted.

I just really hope that this message can be found in case anyone else runs into the same problem. I only found out because the dvd I burnt to repair the bootloader couldn't properly be read (reading drive and burner+disc not so compatible or so), then I had to check in the boot menu what it tried to do.
It still baffles me, why that setting would have changed, but the fact is, that it was working before (non-EFI style) and now it was trying to boot the system EFI-style.

I actually filmed all the boot kernel panic messages to be able to read all that flashes by and then try to make sense of things, if anyone wants more complete kernel panic info, just let me know.
Posts: 27
Joined: Jun 15th, '13, 14:00

Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest