Small issue after upgrading to Mageia 7

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Small issue after upgrading to Mageia 7

Postby brm » Jul 11th, '19, 04:46

Following an upgrade from Mageia 6 to Mageia 7 the below message appears regularly at the bash prompt

bash: warning: setlocale: LC_TIME: cannot change locale (en_AU.UTF-8)

Any ideas on how to solve this? My upgrade was pretty much faultless but for this small problem.

Mageia 7 continues to work well for me.
brm
 
Posts: 8
Joined: Sep 2nd, '18, 09:45

Re: Small issue after upgrading to Mageia 7

Postby ITA84 » Jul 11th, '19, 09:21

Some locale configuration might've either been overwritten or it didn't carry over correctly. What's the output of the locale command?
ITA84
 
Posts: 195
Joined: Mar 5th, '13, 18:15

Re: Small issue after upgrading to Mageia 7

Postby brm » Aug 26th, '19, 19:40

ITA84 wrote:Some locale configuration might've either been overwritten or it didn't carry over correctly. What's the output of the locale command?


Still going with this one.

Code: Select all
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"                                                                                                                                         
LC_COLLATE="en_GB.UTF-8"                                                                                                                                       
LC_MONETARY="en_GB.UTF-8"                                                                                                                                     
LC_MESSAGES="en_GB.UTF-8"                                                                                                                                     
LC_PAPER="en_GB.UTF-8"                                                                                                                                         
LC_NAME="en_GB.UTF-8"                                                                                                                                         
LC_ADDRESS="en_GB.UTF-8"                                                                                                                                       
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
Last edited by isadora on Aug 27th, '19, 08:40, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
brm
 
Posts: 8
Joined: Sep 2nd, '18, 09:45

Re: Small issue after upgrading to Mageia 7

Postby filip » Aug 31st, '19, 15:08

It seems that you have to install/reinstall locales-en.
filip
 
Posts: 418
Joined: May 4th, '11, 22:10
Location: Kranj, Slovenia


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron