No sound in mp4a audio and mp4 video files

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 13th, '11, 12:05

I am having sound problems in Mageia.
I have tried VLC and it gives me error "Unable to play this format mp4a"

Then i tried smplayer . It doesn't give me error but sound is still not working
I haven't saw these problems in other distros that i had used earlier. Thanks in advance for help
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby oboedad55 » Oct 16th, '11, 08:03

Do you have the gstreamer plugins installed, good, bad, and ugly?
Registered Linux user #436067
-----------------------------------
Linux assumes you know exactly what you are doing.
User avatar
oboedad55
 
Posts: 28
Joined: Apr 28th, '11, 08:19
Location: Amerika

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Oct 16th, '11, 10:46

Please show the output of
Code: Select all
rpm -qa | grep vlc
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 16th, '11, 12:25

Sorry guys I was so much frustrated :x with this sound issue that i changed my distro
but I am keeping an eye on this distro 8-) and will try it once again when Mageia 2 is released.

Anyway thanks for replying
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby saptech » Oct 16th, '11, 19:42

Did you have the gstreamer plugins installed?

Image

Uploaded with ImageShack.us
Each One Teach One
--------------------------------
Mageia 7 & Debian 10
HP Compaq Elite 8300 | Intel Core i5 | 8gb | 120gb SSD
--------------------------
Mageia 7 & Debian 10
Dell Optiplex 760 | Quad Core | 4gb | 250gb HDD
User avatar
saptech
 
Posts: 234
Joined: Apr 5th, '11, 08:36
Location: STL

Re: No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 17th, '11, 04:18

Since I changed my distro. What I know was that my system was up to date . So it must have gstreamer plugins installed
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Oct 17th, '11, 12:56

Up to date does not mean that you have packages installed which need to be installed manually.
It may not have the necessary packages installed, that why you got the error message.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re:No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 17th, '11, 14:50

Thank you all of you

I remember that had not installed gstreamer plugins manually. So that might be the problem.
Now I will try Mageia once again :D
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Oct 17th, '11, 15:47

Always remember: patience is a virtue ;)
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 17th, '11, 17:14

doktor5000 wrote:Always remember: patience is a virtue ;)


But patience doesn't result in knowledge
It is our mistakes that result in knowledge :ugeek:
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby zlatkodesign » Oct 31st, '11, 01:01

I have problem to, with VLC and flash-flv files, the same version of VLC work OK on Win7-64bit,but on my Mageia 1 64bit I got this screen:
No suitable decoder module:
VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.
Current version on my PC is 1.1.12, the same problem was on 1.1.11 version and on 32bit Mageia.
Any idea?
Movie player works fine with flv. files.
zlatkodesign
 
Posts: 11
Joined: Oct 29th, '11, 01:48

Re: No sound in mp4a audio and mp4 video files

Postby willie » Oct 31st, '11, 10:56

you've installed smplayer is mplayer also installed, smplayer is nothing more then a graphical frontend for mplayer.
I had the same problem with mp4 from my digital videocamera, they couldn't be played, gstreamer-plugin didn't work.
With smplayer and mplayer is works. :idea:
Willie

I'm on an endless mission to explore a strange new world
User avatar
willie
 
Posts: 29
Joined: Mar 26th, '11, 13:39

Re: No sound in mp4a audio and mp4 video files

Postby Manuj19 » Oct 31st, '11, 15:46

Do both of you have installed good,bad and ugly versions of gstreamer
rpm -qa | grep vlc
Manuj19
 
Posts: 6
Joined: Oct 13th, '11, 11:56

Re: No sound in mp4a audio and mp4 video files

Postby zlatkodesign » Nov 1st, '11, 00:27

Manuj19 - VLC use its own decoder system dont use gstreamer in Linux or some external codec in Windows. Problem is that same version of VLC on Ubuntu work fine with flv.files. I think its a bug with compiling VLC for Mageia.
zlatkodesign
 
Posts: 11
Joined: Oct 29th, '11, 01:48

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Nov 1st, '11, 10:40

No this is not a bug. You should use the tainted version of VLC player, thats why above i asked for output of rpm -qa | grep vlc.
Simply enable the tainted_release and tainted_updates media which are disabled by default and update to that VLC version.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby zlatkodesign » Nov 3rd, '11, 15:10

Doktor5000 - "You should use the tainted version of VLC player, thats why above i asked for output of rpm -qa | grep vlc." Im not that advance user with Mageia, please step by step, thanks in advance.
zlatkodesign
 
Posts: 11
Joined: Oct 29th, '11, 01:48

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Nov 3rd, '11, 15:59

Please open a terminal, paste the following command there:
Code: Select all
rpm -qa | grep vlc
and post the output of it here.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby zlatkodesign » Nov 4th, '11, 00:16

Thanks Doktor5000, VLC its work fine with flv.files-sound works, I have install via: enable the tainted_release and tainted_updates media.
zlatkodesign
 
Posts: 11
Joined: Oct 29th, '11, 01:48

Re: No sound in mp4a audio and mp4 video files

Postby mrigs » May 13th, '13, 06:27

THANK YOU. :)
mrigs
Mageia on LG Gram 15
mrigs
 
Posts: 40
Joined: Jun 28th, '11, 03:25
Location: California, US

Re: No sound in mp4a audio and mp4 video files

Postby flink » Jun 9th, '13, 17:43

I cannot hear any sound with MP4 files in Mageia 3 x86_64.

GNOME MPlayer does nothing.
Kaffeine gives no sound.
KPlayer shows black screen and no sound.
KMPlayer gives no sound.
VlcPlayer gives error message:
Pas de décodeur approprié pour le format:
VLC ne supporte probablement pas le format audio ou vidéo « mp4a ». Malheureusement il n'y a rien à faire.



Only Dragon Player works. Under Mageia2 I could use GNOME MPlayer without any problems.
How could the other video players be made working?
flink
 
Posts: 72
Joined: Mar 3rd, '12, 19:23

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Jun 9th, '13, 18:08

You did enable tainted repositories and updated all packages?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby flink » Jun 10th, '13, 10:06

doktor5000 wrote:You did enable tainted repositories and updated all packages?

Thanks. Ok. I have now updated the tainted repository.
The result is: :)
Dragon Player, GNOME MPlayer, KPlayer, KMPlayer and VlcPlayer are now working fine.
Even Amarok gives the sound (no video).

Kaffeine has no sound.

Any ideas how to give the sound also to Kaffeine?
flink
 
Posts: 72
Joined: Mar 3rd, '12, 19:23

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Jun 10th, '13, 20:56

Nope, not really - don't even know what Kaffeine uses these days as backend.

Any reason to use that many media players? Do you really need more than 6?
I'm only using 1 and it's working just fine, plays everything and is quite lean and configurable ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No sound in mp4a audio and mp4 video files

Postby flink » Jun 10th, '13, 21:12

doktor5000 wrote:Any reason to use that many media players? Do you really need more than 6?

The reason is because not every player is able to play all media and file formats.
And I have already used a lot Kaffeine in the past. I would prefer to stay with a player to which I am already used to.
flink
 
Posts: 72
Joined: Mar 3rd, '12, 19:23

Re: No sound in mp4a audio and mp4 video files

Postby doktor5000 » Jun 10th, '13, 21:36

Well, for me VLC plays everything i throw at it, and it can even convert videos. For what would i need 5 other media players?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16657
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Next

Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest