[SOLVED] Adventure in WINE

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[SOLVED] Adventure in WINE

Postby hankivy » Dec 29th, '18, 22:39

An Adventure in WINE, Wine Is Not an Emulator.

The previous state of my system. My symptoms. My misunderstanding. The fix.

*** The previous state of my system.

The system is 64-bit Mageia. The patches were up to date, and the x86_64 Architecture of WINE, (WINE64) was installed.

*** My symptoms.

Any windows application launched by clicking on an icon, or menu item; either opened no window, or a blank window that soon closed, or a blank window. Starting a windows application via a command line, showed error messages about missing TrueType fonts. Typical applications were winecfg, winefile, and winemine. :(

*** My misunderstanding.

WINE64 (x86_64 Architecture of WINE) is for running 64-bit windows applications. It does not support 32-bit windows applications. While almost any Windows application could be compiled for 32-bit, or 64-bit executables; 32-bit is the most commonly available version. WINE (i586 Architecture of WINE) is for running 32-bit windows applications, and it runs on my 64-bit Mageia system. :o

*** The fix.

WINE64 was deleted from my system.
~/.wine was deleted (from my home directory). [A less brutal delete, and concern for other users might have been desired.]
WINE was installed on my system.

I ran winecfg, and winefile. They were successful. Later, other applications also worked. :D
hankivy
 
Posts: 103
Joined: May 19th, '14, 20:36

Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron