[FIXED] Excahngeable devices require root password

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[FIXED] Excahngeable devices require root password

Postby mla » Aug 5th, '15, 12:44

Of late (a week or two?) plugging in exchangeable devices, such as a camera or a flashstick, may result in a prompt for the root password. The cause turns out to be the same as the occasional inability to launch MCC from the GUI menu (see https://bugs.mageia.org/show_bug.cgi?id=16319). The workaround is to restart polkit. I.e. as root do "systemctl restart polkit". This fixes the problem until the next (re)boot, when it may or may not occur again.
Last edited by mla on Oct 13th, '15, 21:23, edited 1 time in total.
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10

Re: [WORKAROUND] Excahngeable devices require root password

Postby doktor5000 » Aug 5th, '15, 19:50

Hmmm, the update that triggered this came ~4 weeks ago. If you have restarted polkit afterwards or rebooted, it should not reoccur.
When did you install the update, and when did you reboot afterwards?
Code: Select all
rpm -qa --last | grep polkit
will tell when the update was installed.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14539
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [WORKAROUND] Excahngeable devices require root password

Postby mla » Aug 5th, '15, 20:55

Interesting. The answer is 6th July. The machine is powered off every night. But I swear the problem only started within the last two weeks max! The list of packages with update dates that would fit that is, unfortunately, rather long. Alas, I cannot blame systemd :-) -- that got last updated on 28th of June
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10

Re: [WORKAROUND] Excahngeable devices require root password

Postby doktor5000 » Aug 6th, '15, 10:33

There hasn't been anything that's related to the issue in the updates. FWIW, I've not seen any such polkit issue myself ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14539
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [WORKAROUND] Excahngeable devices require root password

Postby mla » Aug 6th, '15, 12:08

OK... Further investigation shows that I cannot be sure about it starting recently, after all. I have, in fact, two separate issues, which show the same symptoms.

1. There is the issue outlined at the beginning of this topic. It seems much rarer than I thought and hence might indeed go back to the polkit update a month ago, even though I have definitely seen it only once -- yesterday. On that one occasion, restarting polkit cured the problem.

2. I keep all my financial stuff in a truecrypt file system and within the last couple of weeks, mounting it produced a spurious request for the root password (after I supplied the truecrypt key), even though I have sudo set up not to require this. The file system got mounted regardless of whether I supplied the root password. Hence my (correct) interpretation was that truecrypt did the mounting and that in addition, the OS spotted a new device and requested the password in order to mount it. Which looked very much like in (1) above.

I have now recalled a change I made about 10 days ago and have also confirmed by experiment that (2) happens reliably even though (1) does not, if I set exchangeable device policy (a) to mount automatically but (b) only to do so for devices mounted manually at least once. Disabling (b) removes the prompt for the root password, but results in a brief notification that the device cannot be mounted.

I am afraid I have no idea when the system started attempting to mount the truecrypt file system. I might not have noticed those brief "can't mount" notices for quite a while, because the file system did in fact get mounted. All I can be sure about is tat about 10 days ago I changed the exchangeable device policy to mount automatically only devices manually mounted once before -- and have been seeing problem (2) ever since. OTOH problem (1) occurred, to the best of my knowledge only once, and got cured by restarting polkit.
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10

Re: [WORKAROUND] Excahngeable devices require root password

Postby mla » Aug 19th, '15, 18:18

For what it's worth, I have now also seen instances of this problem (MCC does not launch from the GUI menu, exchangeable devices require root password) in which restarting polkit did not help.
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10

Re: [WORKAROUND] Excahngeable devices require root password

Postby doktor5000 » Oct 4th, '15, 16:24

mla wrote:For what it's worth, I have now also seen instances of this problem (MCC does not launch from the GUI menu, exchangeable devices require root password) in which restarting polkit did not help.

In that case, please check viewtopic.php?p=59728#p59728
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14539
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [WORKAROUND] Excahngeable devices require root password

Postby mla » Oct 11th, '15, 18:28

Sorry, I've been away. Will install the updates later today and see what happens (after digging through a mountain of emails :-)). Sounds like it's been resolved though! If all is well, I'll update the thread title accordingly.

Thanks!
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10

Re: [FIXED] Excahngeable devices require root password

Postby mla » Oct 13th, '15, 21:25

Happily, both problems (mcc and mounting exchangeable devices) appear to have been solved!
mla
 
Posts: 255
Joined: Sep 16th, '11, 16:10


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest