(Solved) New users expired on M5 fresh install

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

(Solved) New users expired on M5 fresh install

Postby seanmacsuibhne » Jul 31st, '15, 23:14

While running M4 I renamed all the users by putting a 1 at the end of the username.
I then did a fresh install of M5, / partition was formatted but /home was not.
When I tried to add new users using MCC they are immediately marked as expired.
This is true even if I add a user that wasn't present when machine ran M4.

I cannot edit these users either, any changes I make to the details in MCC are not saved as when I try to edit an account again the old vales are still present.

How can I add users so they are not immediately expired?

Thank you

Seán
Last edited by seanmacsuibhne on Aug 1st, '15, 16:51, edited 1 time in total.
Ná bris nós agus ná tosaigh ceann nua!
seanmacsuibhne
 
Posts: 15
Joined: Feb 11th, '12, 03:33

Re: New users expired on M5 fresh install

Postby jkerr82508 » Aug 1st, '15, 06:16

It seems that you have hit this bug:
https://bugs.mageia.org/show_bug.cgi?id=16467

It is reported that using adduserdrake instead of userdrake will work

Code: Select all
adduserdrake

Jim
jkerr82508
 
Posts: 941
Joined: Mar 26th, '11, 01:34
Location: Fife, Scotland

Re: New users expired on M5 fresh install

Postby seanmacsuibhne » Aug 1st, '15, 12:18

Thank you Jim.
Using your suggestion I was able to add users. However I can't use MCC now.

Looks like my problem is a small part of a bigger one. I pity anyone installing Magia 5 who doesn't have the backup of these support forums. It would put me off Mageia.
In fact I might go back to M4 myself till these problems are sorted.

Beir bua

Seán
Ná bris nós agus ná tosaigh ceann nua!
seanmacsuibhne
 
Posts: 15
Joined: Feb 11th, '12, 03:33

Re: New users expired on M5 fresh install

Postby jkerr82508 » Aug 1st, '15, 13:51

For me, the original version of libuser still seems to work in MCC. Although there is a suggestion in the bug report that there may be a problem with it also.
You could try downgrading libuser to see if the original version works for you:
Code: Select all
urpmi --downgrade libuser-0.60-5.mga5 lib64user1-0.60-5.mga5

or, if you have a 32bit installation:
Code: Select all
urpmi --downgrade libuser-0.60-5.mga5 libuser1-0.60-5.mga5

Jim
jkerr82508
 
Posts: 941
Joined: Mar 26th, '11, 01:34
Location: Fife, Scotland

Re: New users expired on M5 fresh install

Postby ozky » Aug 1st, '15, 14:19

You need to add it too to /etc/urpmi/skip.list that time we get fixed version otherwise it will update it automatically to that buggy version.
Image
Just leave me alone i know what i'm drinking.
User avatar
ozky
 
Posts: 569
Joined: Jul 2nd, '11, 08:48
Location: Ulvila Finland

Re: New users expired on M5 fresh install

Postby seanmacsuibhne » Aug 1st, '15, 16:50

Thank you Jim and Ozky. I made those changes and M5 is behaving properly now. No doubt Mageia is using its mageia to sort this problem out.

Beir bua

Seán
Ná bris nós agus ná tosaigh ceann nua!
seanmacsuibhne
 
Posts: 15
Joined: Feb 11th, '12, 03:33


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest

cron