[CLOSED]After 7.1 re-install VPN won't install - libxkbcommo

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

[CLOSED]After 7.1 re-install VPN won't install - libxkbcommo

Postby Myles » Sep 16th, '20, 10:38

So more problems with this re-install.

I successfully re-installed 7.1 onto a new SSD and upgraded the system with the latest updates.

I have been installing my applications since then.

On trying to install my VPN, I get the error msg "
Code: Select all
(due to unsatisfied libxkbcommon-x11)" Abort or Okay


I tried to install this using
Code: Select all
urpmi libxkbcommon-x11
but an error msg saying no such package name.

So, am I missing a repository? How do I find out where this package is to install??

Any help, always greatly accepted.
Last edited by Myles on Sep 17th, '20, 04:49, edited 1 time in total.
Myles,
Canberra, Australia
User avatar
Myles
 
Posts: 247
Joined: Apr 29th, '12, 10:05

Re: Afer 7.1 re-install VPN won't install - libkbcommon-x-11

Postby doktor5000 » Sep 16th, '20, 18:09

You can query package names via urpmf -f --name some_name_to_search but we don't have a package with that name nor anything that provides this.

Have a look at the later part of viewtopic.php?f=23&t=13485
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16031
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Afer 7.1 re-install VPN won't install - libkbcommon-x-11

Postby Myles » Sep 17th, '20, 04:48

doktor,
Thanks for that, I suspected that might be the case - that Mageia doesn't have the package.

I have raised an issue on the VPN forum (where I found a few other hits on the same topic for other distributions from times past)
Myles,
Canberra, Australia
User avatar
Myles
 
Posts: 247
Joined: Apr 29th, '12, 10:05

Re: [CLOSED]After 7.1 re-install VPN won't install - libxkbc

Postby doktor5000 » Sep 17th, '20, 17:08

Hint: the workaround how to install your VPN package is also in the linked thread.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16031
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [CLOSED]After 7.1 re-install VPN won't install - libxkbc

Postby Myles » Sep 18th, '20, 04:22

doktor,
Okay, reading down through my past disasters I get to this point:
"doktor wrote"
Please reinstall x11-server-common so that the libgl link is not missing anymore. As root:

Code: Select all
urpmi --replacepkgs --replacefiles x11-server-common


So, before I put more holes in my feet, I just wanted to verify if this is the point you are referring to? (So I don't muck things up again)

Then once that is done I follow on and install the VPN like I did in the previous disaster?
Myles,
Canberra, Australia
User avatar
Myles
 
Posts: 247
Joined: Apr 29th, '12, 10:05

Re: [CLOSED]After 7.1 re-install VPN won't install - libxkbc

Postby doktor5000 » Sep 18th, '20, 17:46

Nope.

doktor5000 wrote:No. libxkbcommon-x11 is the package / rpm requires tag that we want to ignore, when installing name_of_your_vpn_client_package_here.rpm - that is what --allow-nodeps does.

urpmi --allow-nodeps name_of_your_vpn_client_package_here.rpm


In the last post of that thread you even posted the command yourself which worked for you ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16031
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [CLOSED]After 7.1 re-install VPN won't install - libxkbc

Postby Myles » Sep 19th, '20, 05:12

doktor,
Sorry, misunderstood yet again!

I had been trying that cmd previously but replying "n" to the error msg thinking that is what I should do. Quite forgetting that replying "y" had worked previously! (In that thread from my previous problems.

Anyway, VPN is all installed but not working for some strange reason - getting an error msg saying it can't connect to VPN port in Firewall - even though as part of the "getting the VPN started procedure" I set the FW to allow everything, then start VPN, and when connected and working, reset FW back to normal settings. So I'll have to open another question in the VPN forum about that one.

Also, just as a side issue, (not important, but annoying), since the re-install, I am getting those "locale" error msgs again, even though I install selecting Australia in the install! Weird.

Anyway, hanks for your help, as always.

I'm going away tomorrow for a week so won't be bothering anyone with problems.
Myles,
Canberra, Australia
User avatar
Myles
 
Posts: 247
Joined: Apr 29th, '12, 10:05


Return to Basic support

Who is online

Users browsing this forum: No registered users and 1 guest