Crossover 18.5 for Mageia 7

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

Crossover 18.5 for Mageia 7

Postby flink » May 15th, '19, 23:55

When I start Crossover Linux 18.5 under Mageia 7 beta, then I get a list of missing package.

Code: Select all
Could not install some Unix packages

Some errors may prevent CrossOver Linux from working correctly:
* Missing 32bit libX11.so.6 library
* Missing 32bit libXext.so.6 library
* Missing 32bit libfreetype.so.6 library
* Missing 32bit libnss_mdns.so.2 library
* Missing 32bit libpng*.so library

You may be able to fix some issues by running one of the following commands as root:
Arch Linux (32 bits)      pacman -Syu freetype2 libpng libx11 libxext nss-mdns
Arch Linux (64 bits)      pacman -Syu lib32-freetype2 lib32-libpng lib32-libx11 lib32-libxext
Debian                    apt-get install libpng16-16:i386
Debian 7 (32 bits)        apt-get install libfreetype6:i386 libnss-mdns libpng12-0:i386 libx11-6:i386 libxext6:i386
Debian 7 (64 bits)        apt-get install lib32nss-mdns libfreetype6:i386 libpng12-0:i386 libx11-6:i386 libxext6:i386
Debian 8                  apt-get install libnss-mdns:i386
Debian <= 6 (32 bits)     apt-get install libfreetype6 libnss-mdns libpng12-0 libx11-6 libxext6
Debian <= 6 (64 bits)     apt-get install ia32-libs lib32nss-mdns
Fedora <= 13 (32 bits)    yum install freetype libX11 libXext libpng nss-mdns
Fedora <= 13 (64 bits)    yum install freetype.i686 freetype.x86_64 libX11.i686 libX11.x86_64 libXext.i686 libXext.x86_64 libpng.i686 libpng.x86_64 nss-mdns.i686 nss-mdns.x86_64
Mandriva                  /usr/sbin/urpmi libfreetype6 libpng3 libx11_6 libxext6 nss_mdns
openSUSE 12.0 to 12.2 (32 bits)   zypper install libX11-6 libXext6
openSUSE 12.0 to 12.2 (64 bits)   zypper install libX11-6-32bit libXext6-32bit


How can I solve this issue?
Last edited by isadora on May 16th, '19, 08:34, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
flink
 
Posts: 56
Joined: Mar 3rd, '12, 19:23

Re: Crossover 18.5 for Mageia 7

Postby ITA84 » May 16th, '19, 10:54

Crossover Linux requires some 32-bit libraries and you're probably running the 64-bit version of Mageia, so, assuming 32-bit support repositories are enabled, all you need to do is install the following packages

libfreetype6
libpng16
libx11_6
libxext6
libnss-mdns2

With URPMI you would run the following command:

Code: Select all
urpmi libfreetype6 libpng16 libx11_6 libxext6 libnss-mdns2


(which is similar to the one the installer suggests for Mandriva, but some packages have different names)
ITA84
 
Posts: 101
Joined: Mar 5th, '13, 18:15

Re: Crossover 18.5 for Mageia 7

Postby flink » May 16th, '19, 13:28

I get this answer:
Code: Select all
[root@localhost ~]#     urpmi libfreetype6 libpng16 libx11_6 libxext6 libnss-mdns2
No package named libpng16



Code: Select all
[root@localhost ~]#     urpmi libpng
Package lib64png16_16-1.6.37-1.mga7.x86_64 is already installed
flink
 
Posts: 56
Joined: Mar 3rd, '12, 19:23

Re: Crossover 18.5 for Mageia 7

Postby doktor5000 » May 16th, '19, 18:57

You're missing information what repos you have configured, maybe you skipped the hint from ITA84 that you need 32-bit repositories enabled? Please provide the output of
Code: Select all
urpmq --list-media active --list-url
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14705
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Crossover 18.5 for Mageia 7

Postby flink » May 16th, '19, 19:43

Code: Select all
[root@localhost ~]#     urpmq --list-media active --list-url
Core Release (Installer) cdrom://x86_64/media/core
Nonfree Release (Installer) cdrom://x86_64/media/nonfree
Core Release (distrib1) http://mirror2.tuxinator.org/mageia/distrib/7/x86_64/media/core/release
Core Updates (distrib3) http://mirror2.tuxinator.org/mageia/distrib/7/x86_64/media/core/updates
Nonfree Release (distrib11) http://mirror2.tuxinator.org/mageia/distrib/7/x86_64/media/nonfree/release
Nonfree Updates (distrib13) http://mirror2.tuxinator.org/mageia/distrib/7/x86_64/media/nonfree/updates
Tainted Release (distrib21) http://mirror2.tuxinator.org/mageia/distrib/7/x86_64/media/tainted/release
Core 32bit Release (distrib31) http://mirror2.tuxinator.org/mageia/distrib/7/i586/media/core/release
Nonfree 32bit Release (distrib36) http://mirror2.tuxinator.org/mageia/distrib/7/i586/media/nonfree/release
Nonfree 32bit Updates (distrib37) http://mirror2.tuxinator.org/mageia/distrib/7/i586/media/nonfree/updates
Tainted 32bit Release (distrib41) http://mirror2.tuxinator.org/mageia/distrib/7/i586/media/tainted/release

flink
 
Posts: 56
Joined: Mar 3rd, '12, 19:23

Re: Crossover 18.5 for Mageia 7

Postby ITA84 » May 17th, '19, 07:43

Sorry, my mistake: the correct package name was libpng16_16, and this one should install the 32-bit version
ITA84
 
Posts: 101
Joined: Mar 5th, '13, 18:15

Re: Crossover 18.5 for Mageia 7

Postby flink » May 18th, '19, 06:38

It is better now. There are still packages missing.

Code: Select all
Could not install some Unix packages

Some errors may prevent CrossOver Linux from working correctly:
* Missing 32bit libnss_mdns.so.2 library

You may be able to fix some issues by running one of the following commands as root:
Arch Linux (32 bits)      pacman -Syu nss-mdns
Debian 7 (32 bits)        apt-get install libnss-mdns
Debian 7 (64 bits)        apt-get install lib32nss-mdns
Debian 8                  apt-get install libnss-mdns:i386
Debian <= 6 (32 bits)     apt-get install libnss-mdns
Debian <= 6 (64 bits)     apt-get install lib32nss-mdns
Fedora <= 13 (32 bits)    yum install nss-mdns
Fedora <= 13 (64 bits)    yum install nss-mdns.i686 nss-mdns.x86_64
Mandriva                  /usr/sbin/urpmi nss_mdns
openSUSE <= 11.2 (32 bits)   zypper install nss-mdns
openSUSE <= 11.2 (64 bits)   zypper install nss-mdns-32bi
flink
 
Posts: 56
Joined: Mar 3rd, '12, 19:23

Re: Crossover 18.5 for Mageia 7

Postby doktor5000 » May 19th, '19, 16:20

And, did you actually try the command suggested for Mandriva? It should work to install libnss-mdns2

Code: Select all
[doktor5000@Mageia6_VM ~]$ urpmq --whatprovides nss_mdns
libnss-mdns2|libnss-mdns2|libnss-mdns2
[doktor5000@Mageia6_VM ~]$

[doktor5000@Mageia6_VM ~]$ sudo urpmi nss_mdns
Package libnss-mdns2-0.10-16.mga6.i586 is already installed
Marking libnss-mdns2 as manually installed, it won't be auto-orphaned
writing /var/lib/rpm/installed-through-deps.list
[doktor5000@Mageia6_VM ~]$
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14705
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Basic support

Who is online

Users browsing this forum: Bequimao and 1 guest