get rid of -nolisten tcp

This forum is dedicated to basic help and support :

Ask here your questions about basic installation and usage of Mageia. For example you may post here all your questions about getting Mageia isos and installing it, configuring your printer, using your word processor etc.

Try to ask your questions in the right sub-forum with as much details as you can gather. the more precise the question will be, the more likely you are to get a useful answer

get rid of -nolisten tcp

Postby mtm » Jan 24th, '18, 23:37

Hi guys,

On Mageia 6. I need to enable the X Server to listen to tcp.
using grep I found the -nolisten tcp option in quite a number of files both in /etc and in various scripts in /usr
I replaced ALL of them with -listen tcp. Yet ... the server still starts with the -nolisten option.

What is going on ? Is some sort of binary file that have hardcoded that option inside or what ?
As a suggestion: Please make that configurable from the management GUI.

Thank you,
MTM
mtm
 
Posts: 4
Joined: May 26th, '12, 15:46

Re: get rid of -nolisten tcp

Postby markwk » Jan 25th, '18, 18:34

I've never been able to get this to work with any distro using sddm. Putting ServerArguments="-listen tcp" into sddm.conf just does not work for me.
So to workaround this, I changed my session manager to lxdm, and put the following in /etc/lxdm/lxdm.conf

Code: Select all
arg=/usr/bin/X -background -listen tcp
# uncomment this if you really want xserver listen to tcp
tcp_listen=1


Also I changed /etc/X11/xdm/Xservers accordingly.

The display manager is set in /etc/sysconfig/desktop, i.e.

Code: Select all
DISPLAYMANAGER=LXDM


Of course you have to install lxdm to get this to work.

If anyone has solved the problem with sddm I'd love to hear of it.
markwk
 
Posts: 1
Joined: Jan 25th, '18, 18:26

Re: get rid of -nolisten tcp

Postby doktor5000 » Jan 25th, '18, 20:17

mtm wrote:As a suggestion: Please make that configurable from the management GUI.

As a suggestion, if you actually want to have that changed, this is the wrong place. Best raise a feature request for that, if it wouldn't have been reported already (read below) https://wiki.mageia.org/en/How_to_report_a_bug_properly

Although this setting can already be changed from MCC via msec. It's on the first screenshot at http://doc.mageia.org/mcc/6/en/content/ ... ml#d4e3184
See also https://bugs.mageia.org/show_bug.cgi?id=19612
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14495
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

[SOLVED] Re: get rid of -nolisten tcp

Postby mtm » Feb 13th, '18, 17:49

Found this tool:

http://www.mageia-gr.org/rpm/6/x86_64/s ... x86_64.rpm

install it and then in the tax X11 type:

-listen tcp

in the field "Arguments passed to the X server invocation"

then it works.

To bad that this useful tool is not in the main repository.
Hope this helps ...
mtm
 
Posts: 4
Joined: May 26th, '12, 15:46

Re: get rid of -nolisten tcp

Postby doktor5000 » Feb 13th, '18, 23:14

Well, that only applies when using sddm, and you don't need a tool for that - you can simply edit /etc/sddm.conf.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14495
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Basic support

Who is online

Users browsing this forum: Google [Bot] and 1 guest